Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache configuratie, directory boom verbergen  (gelezen 1128 keer)

Offline agravain

  • Lid
  • Steunpunt: Nee
Apache configuratie, directory boom verbergen
« Gepost op: 2007/04/10, 21:10:52 »
Sinds kort heb ik Ubuntu Dapper geinstalleerd, hierop heb ik de ubuntu-lamp gezet. Alles werkt voorlopig naar tevredenheid op een ding na:
als ik op de website naar een subdirectory ga waar geen index bestand in staat wordt de directory boom weergegeven. Het staat me bij dat dit bij de vorige linux distributie (SuSe 10.1) niet het geval was. Daar kreeg ik een foutmelding (Forbidden  . . . . . . of zoiets) Nu ben ik al druk opzoek naar de apache configuratie files om dit te blokkeren. Voorlopig heb ik in elke subdirectory een index bestand gezet, maar ik ben op zoek naar een elegantere oplossing, namelijk via de configuratie. Het plaatsen van een index bestand in een nieuwe directory is immers snel vergeten.

Wie kan mij op weg helpen?
Groeten Walter
AMD Llano A8-3870K, Samsung 830 SSD 128Gb, Samsung S166 160GB HDD, 4x4096Mb ram, Xubuntu 12.04
Dell D600, Xubuntu 12.04

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Apache configuratie, directory boom verbergen
« Reactie #1 Gepost op: 2007/04/10, 21:28:14 »
Je zal zowiezo altijd in een map een index file moeten zetten om de files die erin staan te beschermen.
Het is in ieder geval beter dat die index file erin staat.

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sniper_david

  • Lid
    • http://www.computer-team.info
  • Steunpunt: Nee
Apache configuratie, directory boom verbergen
« Reactie #2 Gepost op: 2007/04/11, 22:00:44 »
Hoi,

Kijk eens in de map /etc/apache2/sites-available/ daar vind je een file "default"

Open de file als root !!! anders kan je hem niet opslaan.

Verander de regel die begint met Options.
Deze bepaald hoe de map en links doorzocht worden,...

Normaal zou die er als volgd moeten uitzien.

Options Indexes FollowSymlinks MultiVews

Zet voor de regel een # ervoor zodat het als commentaar gelzen word ;-)
restart de apache server met

sudo /etc/init.d/apach2 restart

en bekijk het resultaat.

Offline agravain

  • Lid
  • Steunpunt: Nee
Apache configuratie, directory boom verbergen
« Reactie #3 Gepost op: 2007/04/13, 19:56:37 »
Sniper_david en Gandyman,

bedankt voor de hulp. Alles werkt nu zoals ik het wil hebben. Mocht ik een index bestand vergeten dan wordt er een foutmelding gegenereerd. Wel heb ik nog een ding dat ik niet snap:
het restart commando geeft een foutmelding:

sudo /etc/init.d/apache2 restart

geeft de volgende melding:
* Forcing reload of apache 2.0 web server... apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName


Maar met een reboot van het systeem werkte de fix wel.

Walter
AMD Llano A8-3870K, Samsung 830 SSD 128Gb, Samsung S166 160GB HDD, 4x4096Mb ram, Xubuntu 12.04
Dell D600, Xubuntu 12.04