Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Feisty bèta: oplossing voor vertraging bij opstarten!  (gelezen 5081 keer)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Gepost op: 2007/04/09, 10:03:09 »
Er is een manier om de vertraging bij het opstarten van Feisty bèta, te verhelpen. Namelijk door een flink aantal regels in /etc/network/interfaces uit te commentariëren.

Als volgt (voorbeeld van mijn interfaces bestand):
auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet dhcp

# auto eth1
# iface eth1 inet dhcp

# auto eth2
# iface eth2 inet dhcp

# auto ath0
# iface ath0 inet dhcp

# auto wlan0
# iface wlan0 inet dhcp
Het uitcommentariëren van die regels heeft geen enkel nadelig effect, omdat Network Manager de netwerkkaarten sowieso al kan vinden. Let op: "lo" niet uitcommentariëren!

Werkt bij mij weer als een speer nu, een aanrader!

Zalig Pasen, Pjotr.

-toevoeging-
Het probleem waar het bovenstaande een oplossing voor biedt, bestaat waarschijnlijk niet meer, sinds een update van Feisty bèta van gisteravond (10-4).  Als je geen opstartvertraging hebt, pas mijn oplossing dan niet toe.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #1 Gepost op: 2007/04/09, 10:15:13 »
weer zo'n aardige tip om dingen te verbeteren/problemen op te lossen, net als het bericht over de opera fix in feisty.
:zou toch ook passen in een vastgezet-topic: aan de bel;)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #2 Gepost op: 2007/04/09, 10:33:02 »
als ik deze: # auto eth0
                  # iface eth0 inet dhcp
zou outcommenten heb ik volgens mij geen internet meer toch?

Azalin

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #3 Gepost op: 2007/04/09, 10:58:48 »
Jawel, want NetworkManager doet dit helemaal zelf uitzoeken... klik maar eens met je linker muisknop op het icoontje van NM, dan zie je dat je ook een Static COnfiguratie kunt opgeven mocht je dat willen... Toen ik VPN met NM wilde gebruiken werd al gezegd dat je bijna alles (op lo en sit na) in je network/interfaces file kunt uitzetten. Moet uitzetten zelfs...

Wat er nu gebeurt is waarschijnlijk dat NM én Ubuntu proberen je netwerk te configgen en dat duurt even voor het systeem door heeft dat het al gedaan is, denk ik.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #4 Gepost op: 2007/04/09, 12:44:49 »
Citaat van: leoquant
als ik deze: # auto eth0
                  # iface eth0 inet dhcp
zou outcommenten heb ik volgens mij geen internet meer toch?
Je kunt dat veilig doen, het is zoals Azalin zegt!

MichielArndts

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #5 Gepost op: 2007/04/09, 20:20:46 »
enne hoe doe je dat... Welk commando moet ik daarvoor gebruiken om het te kunnen editten...

Offline raydekok

  • Lid
    • http://www.kodekok.nl
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #6 Gepost op: 2007/04/09, 20:30:58 »
sudo gedit of kate /etc/network/interfaces
homemade HTPC

MichielArndts

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #7 Gepost op: 2007/04/09, 20:41:43 »
owja gedit was t

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #8 Gepost op: 2007/04/09, 23:50:33 »
Om het helemaal compleet te maken:

Ubuntu:
sudo gedit /etc/network/interfaces

Kubuntu:
sudo kate /etc/network/interfaces

Xubuntu:
sudo mousepad /etc/network/interfaces

Paretje

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #9 Gepost op: 2007/04/10, 00:04:36 »
Zou je dan nog een connectie hebben in de "tty"'s (de terminals dus (of toch die zonder X):P)?

Bij mij start die eigenlijk al zoiezo sneller op dan Edgy.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #10 Gepost op: 2007/04/10, 00:13:43 »
Die oplossing is natuurlijk niet geschikt voor iedereen, omdat network-manager niet compatibel is met alle netwerkkaarten en/of alle netwerktypen (WEP/WPA) bij bepaalde netwerkkaarten
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Paretje

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #11 Gepost op: 2007/04/10, 01:01:51 »
Compatible is de mijne waarschijnlijk wel, maar kmoet wel ook internet kunnen gebruiken buiten de grafische omgeving, en ik heb liever dat alles start bij het opstarten zelf, en niet bij X, ...

Offline siegi

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #12 Gepost op: 2007/04/10, 02:14:05 »
Citaat van: Paretje
Compatible is de mijne waarschijnlijk wel, maar kmoet wel ook internet kunnen gebruiken buiten de grafische omgeving, en ik heb liever dat alles start bij het opstarten zelf, en niet bij X, ...
Je hebt wel maar internet internet device nodig he :)

Azalin

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #13 Gepost op: 2007/04/10, 09:37:48 »
Naja, als de Network Manager niet voor jou werkt, dan de-installeer je die en laat je je interfaces bestand met rust. Je moet één van de twee gebruiken, niet allebei... dat is blijkbaar op dit moment een probleem.

Paretje

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #14 Gepost op: 2007/04/10, 10:26:44 »
Tzal wel werken, maar wou enkel weten of je buiten de grafische omgeving connectie hebt.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #15 Gepost op: 2007/04/11, 00:40:06 »
Een andere oplossing is om het niet via dhcp te doen.
Via dhcp krijgt je computer alle instellingen automatisch van je router.
Als je die instellingen handmatig invoert, dan gaat het ook veel sneller.

Voorbeeldje van mijn /etc/network/interfaces:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.9
netmask 255.255.255.0
gateway 192.168.1.1
Buiten de grafische omgeving heb je dan ook nog gewoon internet.

zambo

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #16 Gepost op: 2007/04/11, 07:32:52 »
De vertraging heeft zichzelf opgelost gisteren tijdens een update.  Start op zoals het moet, snel en vooruitgaand.  Zonder de wijzigingen die hierboven beschreven zijn toe te passen.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #17 Gepost op: 2007/04/11, 10:44:13 »
Sinds update van gisteravond zegt mijn networkmanager-applet dat er geen verbinding is op mijn bekabelde netwerk, maar die is ter wel...
Dus ik denk dat voor mij de networkmanager-applet niet werkt, weet iemand hoe ik die kan de-installeren?
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #18 Gepost op: 2007/04/11, 10:44:44 »
De vertraging wordt (hier op mijn laptop) veroorzaakt doordat Ubuntu bij het opstarten wacht op een DHCP adres terwijl de netwerkkabel niet is aangesloten.
Dit kan je ook oplossen in de grafische interface via Systeem --> Beheer --> Netwerk. Haal het vinkje weg voor de Draadverbinding als deze niet is aangesloten.
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #19 Gepost op: 2007/04/11, 11:06:31 »
na het uitvoeren van pjotr123 stappenplan heb ik idd geen internet meer. dat staat nu standaard uit.
=wired disabled= ik denk dat ik het maar weer terugzet in de oude setting....:(

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #20 Gepost op: 2007/04/11, 11:23:48 »
Ik heb dat ook: network manager zegt dat het netwerk disabled is.
Er is alleen wel gewoon netwerk en internet. Het werkt gewoon, al zegt network manager van niet.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #21 Gepost op: 2007/04/11, 11:31:28 »
Gisteren was er een update van Feisty bèta, waardoor mijn bovenstaande verhaal waarschijnlijk komt te vervallen. Ik zal het later vandaag eens uitproberen op mijn klaptop. Indien het zo is, dan zal ik mijn tekst schrappen, om verwarring te voorkomen.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #22 Gepost op: 2007/04/12, 09:16:04 »
Citaat van: pjotr123
Gisteren was er een update van Feisty bèta, waardoor mijn bovenstaande verhaal waarschijnlijk komt te vervallen. Ik zal het later vandaag eens uitproberen op mijn klaptop. Indien het zo is, dan zal ik mijn tekst schrappen, om verwarring te voorkomen.
er is sprake van een behoorlijk bug, waarschijnlijk in de netwerkmanager van feisty, na de update van gister. de bug is confirmed. dus een fixrelease zal nog wel eventjes duren. ik houd je/jullie op de hoogte. de bug maakt internetten niet onmogelijk.

Offline raydekok

  • Lid
    • http://www.kodekok.nl
  • Steunpunt: Nee
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #23 Gepost op: 2007/04/12, 09:23:52 »
inderdaad want ik kan gewoon internetten. maar dat er iets is met het internet sinds die ene update waarbij mijn draadloze kaartje zomaar niet meer herkend werd is het nog niet veel soeps.
homemade HTPC

Azalin

  • Gast
Feisty bèta: oplossing voor vertraging bij opstarten!
« Reactie #24 Gepost op: 2007/04/12, 11:55:48 »
Heeft overigens dus niet alleen betrekking op draadloos maar ook bedraad internet, ik heb hier ook sinds de update dat mijn network manager roept dat er geen verbinding is terwijl ik gewoon online ben. Offline en weer online zetten zorgt dat de status dan ineens wel weer klopt... naja, zal wel gefixed gaan worden, mag ik hopen :)