Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstartprobleem .... Input/output error  (gelezen 757 keer)

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Opstartprobleem .... Input/output error
« Gepost op: 2015/07/27, 16:29:00 »
Mijn computer (Ubuntu 14) start plots niet meer op.
Na het bootmenu krijg ik een zwart scherm en dan volgende melding:
mountall: error while loading shared libraries: libply-boot-client.so.2: cannot open shared object file: Input/output error

Ik heb al wat zitten zoeken, en vond wat informatie (http://askubuntu.com/questions/364768/xubuntu-13-04-64-bit-mountall-error-cant-boot).
Ik startte op met installatie-cd  en koos voor 'Proberen' (is dat hetzelfde als een live-cd?) en probeerde met de instructies éen en ander te doen, zonder resultaat.
Is er iemand die een gelijkaardig probleem heeft gehad?

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #1 Gepost op: 2015/07/27, 16:51:25 »
Kan je ook vertellen wát je gedaan hebt. De link waar je naar verwijst lijkt me goed. Plymouth is de module die bij het opstarten v/h systeem het Ubuntu-logo+de paarse stipjes geeft.

In het 2e commentaar van die link is te lezen dat de pc is opgestart in recovery mode en dat die module weer wordt geinstalleerd. (het verstandig is om een wired verbinding te makn met je modem, voor het geval er een update opgehaald moet worden).

sudo apt-get install --reinstall libplymouth2

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #2 Gepost op: 2015/07/27, 21:06:11 »
Ik start in recovery mode, kies 'Terugvallen op terminal met rootbevoegdheid'.
Dat typ ik dat commando:
sudo apt-get install --reinstall libplymouth2
W: Er wordt geen vergrendeling gebruikt voor het alleen-lezen-vergrendelingsbestand /var/lib/dpkg/lock
E: Kan niet naar /var/cache/apt/ schrijven
E: De pakketlijsten of het statusbestand konden of niet ontleed, of niet geopend wrden.

en krijg ik bovenstaande meldingen

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Opstartprobleem .... Input/output error
« Reactie #3 Gepost op: 2015/07/28, 12:41:18 »
In recovery shell moet je eerst je systeem nog beschrijfbaar maken.mount -o remount,rw /Daarna kan je de install uitvoeren. Sudo is niet nodig.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #4 Gepost op: 2015/07/28, 14:40:09 »
Na het beschrijfbaar maken en het apt-get install... commando krijg ik de foutmelding:
Kon 'be.archive.ubuntu.com' niet vinden.
Ik vermoed dat ik geen internet connectie heb (ping -c 5 google.com => unknown host).
De computer is verbonden met een kabel met de router (en op een andere computer werkt internet)..
Hoe kan ik dat oplossen?

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Opstartprobleem .... Input/output error
« Reactie #5 Gepost op: 2015/07/28, 14:59:58 »
In de recovery menu kan je eerst de internet verbinding activeren. Ik meen zelfs dat bij die activatie je systeemschijf automatisch in read/write wordt gezet.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #6 Gepost op: 2015/07/28, 15:54:44 »
Inderdaad, nu werden de paketten wel opgehaald.
Maar daarna de foutmelding:
/bin/df: kan tabel van aangekoppelde bestandssystemen niet lezen: Invoer-/uitvoerfout
Fouten gevonden tijdens het behandelen van: /var/cache/apt/archives/libplymouth2_0.8.8-2ubuntu31.1_i386.deb

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #7 Gepost op: 2015/07/28, 17:00:33 »
Heeft iets te maken met etc/fstab, maar hoe en wat is mij niet bekend. In het engels :
df: cannot read table of mounted filesystems: Input/output error


Vraag aan VandenBossche:
  Werd de apt-get opdracht vooraf gegaan door de mount opdracht ?


edit:
Of is de harde schijf vol?
Misschien is het verstandig de pc op te starten vanaf een Ubuntu LiveCD en de schijf te inspecteren.
« Laatst bewerkt op: 2015/07/28, 17:14:19 door EZ-man »

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #8 Gepost op: 2015/07/28, 17:16:13 »
Ik heb eerst in het herstel menu voor de internet aansluiting gekozen.
Dan heb ik die mount -o remount,rw / gebruikt.
Ten slotte: apt-get install --reinstall libplymouth2.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #9 Gepost op: 2015/07/28, 17:18:42 »
OK, dan is het op de juiste manier aangekoppeld.

Afgaande op onderstaande link, vermoed ik toch dat het een overvolle partitie is :
   http://www.novell.com/coolsolutions/tip/19656.html

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #10 Gepost op: 2015/07/28, 19:53:23 »
Er zitten 3 harde schijven in de computer: 1 met Windows, 1 voor backup en de grootste schijf (160 GB) heeft een partitie met ubuntu (30 GB voor 67 % vol) en een home partitie (125 GB voor 25 % vol).
Dus daar zal het probleem niet liggen.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Opstartprobleem .... Input/output error
« Reactie #11 Gepost op: 2015/07/28, 20:01:49 »
Wat zeggen de SMART gegevens van je schijf?

In de recovery mode, na het inschakelen van het netwerk:apt-get install smartmontools
smartctl -A /dev/sdc
in de veronderstelling dat sdc de schijf is waar Ubuntu op staat.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #12 Gepost op: 2015/07/28, 20:07:03 »
Nero, ik zit ook aan SMART te denken.

Maar als het systeem in een eerdere instantie niets wilde installeren,
 dan gaat dat nu toch ook niet lukken (of maak ik een denkfout) ?

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #13 Gepost op: 2015/07/28, 21:06:37 »
Ik heb SMART geînstalleerd (ik kreeg nog wel runlevel:/var/run/utmp Bestand of map betsaat niet).
Ik heb het commando uitgevoerd en kreeg dan een 50-tal regels met type prefail of Old-age.
Kan ik daar conclusies uit trekken?
Jullie denken dat de schijf het aan het begeven is?
Wat me verontrust is dat ik via een live cd geen home bestanden naar een usb-stick kon kopiëren, wegens geen rechten.
Ik hoop dat daar iets aan te doen is.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #14 Gepost op: 2015/07/28, 22:28:09 »
Wat me verontrust is dat ik via een live cd geen home bestanden naar een usb-stick kon kopiëren, wegens geen rechten.

zie http://askubuntu.com/questions/83268/how-do-i-get-root-access-to-hard-drive-from-livecd

sudo nautilus

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Opstartprobleem .... Input/output error
« Reactie #15 Gepost op: 2015/07/29, 09:44:36 »
Ik heb het commando uitgevoerd en kreeg dan een 50-tal regels met type prefail of Old-age.
Kan ik daar conclusies uit trekken?
Kan je deze resultaten hier eens posten? Van uit de recovery mode kan jesmartctl -A /dev/sdc > smartmon.loguitvoeren. Als je dan opstart met een live CD/DVD/USB kan je het bestand smartmon.log alsnog hier plaatsen, liefst tussen code-tags.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #16 Gepost op: 2015/07/29, 16:02:59 »
Of is dit weer zo'n vage foutmelding als gevolg van een cmos-batterij die leeg is? 

Recentelijk hebben we weer zo'n geval hier gehad :
   https://forum.ubuntu-nl.org/index.php?topic=89251.msg957670#msg957670

@VandenBossche :
   Vervang/controleer het batterijtje op het moederbord, zie bovenstaande link.
    Het is altijd goedkoper een batterij van 5 euro te vervangen dan een andere schijf te regelen.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #17 Gepost op: 2015/07/29, 20:12:15 »
De output van SMART ziet er als volgt uit:
smartctl 5.41 2011-06-09 r3365 [i686-linux-3.2.0-88-generic-pae] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  3 Spin_Up_Time            0x0027   221   220   063    Pre-fail  Always       -       7305
  4 Start_Stop_Count        0x0032   248   248   000    Old_age   Always       -       10855
  5 Reallocated_Sector_Ct   0x0033   253   253   063    Pre-fail  Always       -       0
  6 Read_Channel_Margin     0x0001   253   253   100    Pre-fail  Offline      -       0
  7 Seek_Error_Rate         0x000a   253   252   000    Old_age   Always       -       0
  8 Seek_Time_Performance   0x0027   251   244   187    Pre-fail  Always       -       39070
  9 Power_On_Minutes        0x0032   217   217   000    Old_age   Always       -       663h+47m
 10 Spin_Retry_Count        0x002b   253   252   157    Pre-fail  Always       -       0
 11 Calibration_Retry_Count 0x002b   253   252   223    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   226   226   000    Old_age   Always       -       10831
192 Power-Off_Retract_Count 0x0032   245   245   000    Old_age   Always       -       8482
193 Load_Cycle_Count        0x0032   244   244   000    Old_age   Always       -       36111
194 Temperature_Celsius     0x0032   253   253   000    Old_age   Always       -       26
195 Hardware_ECC_Recovered  0x000a   253   252   000    Old_age   Always       -       10980
196 Reallocated_Event_Count 0x0008   253   253   000    Old_age   Offline      -       0
197 Current_Pending_Sector  0x0008   253   253   000    Old_age   Offline      -       0
198 Offline_Uncorrectable   0x0008   253   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0008   199   199   000    Old_age   Offline      -       0
200 Multi_Zone_Error_Rate   0x000a   253   252   000    Old_age   Always       -       0
201 Soft_Read_Error_Rate    0x000a   253   252   000    Old_age   Always       -       1
202 Data_Address_Mark_Errs  0x000a   253   252   000    Old_age   Always       -       0
203 Run_Out_Cancel          0x000b   253   252   180    Pre-fail  Always       -       3
204 Soft_ECC_Correction     0x000a   253   252   000    Old_age   Always       -       0
205 Thermal_Asperity_Rate   0x000a   253   252   000    Old_age   Always       -       0
207 Spin_High_Current       0x002a   253   252   000    Old_age   Always       -       0
208 Spin_Buzz               0x002a   253   252   000    Old_age   Always       -       0
209 Offline_Seek_Performnce 0x0024   186   184   000    Old_age   Offline      -       0
 99 Unknown_Attribute       0x0004   253   253   000    Old_age   Offline      -       0
100 Unknown_Attribute       0x0004   253   253   000    Old_age   Offline      -       0
101 Unknown_Attribute       0x0004   253   253   000    Old_age   Offline      -       0
Ik kan proberen het batterijtje te vervangen, dat zal voor morgen zijn.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #18 Gepost op: 2015/07/30, 14:24:05 »
Kunnen jullie iets opmaken uit de log van SMART?
Ik heb het batterijtje gestest: 3 volt zoals er op staat.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #19 Gepost op: 2015/07/30, 14:29:35 »
Kunnen jullie iets opmaken uit de log van SMART?

Nee, daar ben ik geen expert in. Misschien geeft de tool "Schijven" een beter overzicht van SMART, zie link
   http://askubuntu.com/questions/20393/how-do-i-interpret-hdd-s-m-a-r-t-results

en de wikipedia :
   https://en.wikipedia.org/wiki/S.M.A.R.T.#ATA_S.M.A.R.T._attributes


PS:
goed om te horen dat de batterij in orde is

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Opstartprobleem .... Input/output error
« Reactie #20 Gepost op: 2015/07/30, 14:35:50 »
Misschien geeft de tool "Schijven" een beter overzicht van SMART
Nogal moeilijk zonder grafische omgeving.

Overigens zie ik op 't eerste zicht geen abnormale waarden.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #21 Gepost op: 2015/07/30, 14:39:08 »
Nero, "schijven" kan ook vanaf de Ubuntu LiveCD gedraaid worden.

Terug naar het probleem. Is herinstallatie een optie?

Aanvulling
@ VandenBossche :  toch wil ik meer weten van het ubuntu systeem. Kan je de output geven van :
inxi -Fxz
« Laatst bewerkt op: 2015/07/30, 15:05:18 door EZ-man »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #22 Gepost op: 2015/07/30, 16:05:19 »
Als eerste zou ik even fsck doen op al je schijven,(naar aanleiding van je tabel fout boven),
boot vanaf de livecd, start gparted,
dan kies hd,
kies partitie,
dan met muis rechts klik, dan check kiezen, dit is fsck met grafische scherm.
Schijf moet ook ontkoppelt zijn.

Zou ook nog defecte geheugen kunnen zijn.
Met memtest86, vanaf een cd booten(usb stick), laat dit 12 uur lopen.
0 fouten moet het zijn.
« Laatst bewerkt op: 2015/07/30, 16:09:11 door jan11000 »

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #23 Gepost op: 2015/07/30, 16:31:04 »
Ik kan inxi niet installeren in recovery mode. De computer blijft hangen (gaat niet terug naar recovery scherm) als het netwerk probeer in te schakelen (was daarvooor nochthans wel al gelukt).
Ik zal die gparted eens proberen.
Overigens, Windows start wel gewoon op (staat op andere schijf).

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem .... Input/output error
« Reactie #24 Gepost op: 2015/07/30, 16:50:48 »
Als ik de partitie met ubuntu check, krijg ik File system is not clean.
De home partitie en de Windows schijf zijn wel 'clean'.