Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: HP All-in-one netwerk scanner werkt niet meer ?!  (gelezen 543 keer)

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
HP All-in-one netwerk scanner werkt niet meer ?!
« Gepost op: 2015/07/12, 18:46:27 »
Mijn HP OfficeJet Pro 8500A 910 all in one printer werkt normaal, maar ik krijg de scanner niet meer aan de praat.
We zijn deze week overgestapt van Proximus (Belgacom) naar Scarlet en daardoor moest ik zowel in de Ubuntu laptop als in de Windows 7 desktop van mijn vrouw opnieuw verbinding maken met de router en de netwerksleutel ingeven om de printer terug te kunnen gebruiken - deze staat op een lokaal netwerkje met een vast ip-adres (192.168.1.66). Maar daar heeft mijn probleem niets mee te maken vermits de scannere voor de omschakeling van provider ook al niet werkte.
Vanop de Win-7 pc kan ik nu wel scannen, maar vanop de Ubuntu laptop lukt het niet.
Ik heb al heel wat ondernomen: op de Win-7 de Officejet verwijderd en opnieuw geïnstalleerd - de printer gedeeld in Windows - hp-device manager (HPLIP) opnieuw geinstalleerd op de laptop en ge-update naar versie 3.15.6 - in Ubuntu/Systeeminstellingen/Afdrukbeheer bij Eigenschappen van de Officejet Instellingen/Apparaat URI aangepast van Verbinding=HPLIP naar Socket gezet en opnieuw terug naar HPLIP ...
Ik begin er gek van te worden ...
Als ik Sane opstart en op 'scannen' druk, krijg ik de melding 'Scannen is mislukt Kan niet verbinden met scanner'
Als ik Xsane opstart krijg ik 'Kan apparaat niet vinden 'hpaio:/net/Officejet.... ' Fout tijdens apparaat communicatie
Als ik in Firefox het ipadres ingeef van de printer krijg ik geen verbinding (192.168.1.66)
Kan hier iemand mij op het goede spoor zetten ???
Het rare is dat mijn scanner het jaren wel goed gedaan heeft !?
O ja, ik werk in Ubuntu 14.04 LTS en zowel de laptop met Ubuntu als de desktop met Win7 zijn draadloos verbonden met het lokaal netwerkje waarin de printer/scanner eveneens draadloos hangt.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #1 Gepost op: 2015/07/12, 20:34:37 »
Shadoogie2960,

Kijks eens naar je rechten, firewall instelling etc etc.
Maw, of je opdrachtem met sudo ervoor wel de scanner kan benaderen.
Voorbeeld:
sudo scanimage -L
t.o.v.
scanimage -L

MvG,
MauRice
Registered Linux user: 473556

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #2 Gepost op: 2015/07/12, 20:41:06 »
Beste MauRice,
Bedankt voor jouw reactie.
Ik heb geen actieve Firewall in Ubuntu en zowel als sudo als gewoon krijg ik als antwoord:
xxxxxxx@xxxxxxxx-P7818:~$ scanimage -L
device `hpaio:/net/Officejet_Pro_8500_A910?ip=192.168.1.66' is a Hewlett-Packard Officejet_Pro_8500_A910 all-in-one

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #3 Gepost op: 2015/07/14, 19:56:17 »
Beste MauRice,
Bedankt voor jouw reactie.
Ik heb geen actieve Firewall in Ubuntu en zowel als sudo als gewoon krijg ik als antwoord:
xxxxxxx@xxxxxxxx-P7818:~$ scanimage -L
device `hpaio:/net/Officejet_Pro_8500_A910?ip=192.168.1.66' is a Hewlett-Packard Officejet_Pro_8500_A910 all-in-one
Shadoogie2960,

Als je de opdracht scanimage -L als gebruiker uitvoer.
En je krijg melding dat er een is gevonden.
Moet het in theorie alle scan programma's oa simplescan, xsane ook werken.

PS
Een simpele terminal opdracht om het te controleren:
scanimage >out.pnm
Als er iets onder de scanner lig, krijg je nu er een afbeelding van 'out.pnm'
« Laatst bewerkt op: 2015/07/14, 20:04:14 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #4 Gepost op: 2015/07/16, 20:35:16 »
HPLIP-gui moet je ook installeren, heb je die?
Ja, Femke98, die heb ik geïnstalleerd en ook reeds geüpdate.

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #5 Gepost op: 2015/07/16, 20:39:34 »
...

PS
Een simpele terminal opdracht om het te controleren:
scanimage >out.pnm
Als er iets onder de scanner lig, krijg je nu er een afbeelding van 'out.pnm'
Ik krijg volgende foutmelding:
scanimage: open of device hpaio:/net/Officejet_Pro_8500_A910?ip=192.168.1.66 failed: Error during device I/O

Bedankt voor de tip, MauRice2 !

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #6 Gepost op: 2015/07/17, 19:15:44 »
Shadoogie2960,

Ik vermoed dat het toch iets met rechten te maken heeft.
Je heb een I/O fout, dus een communicatie (verbinding).
MvG,
MauRice
Registered Linux user: 473556

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #7 Gepost op: 2015/07/18, 16:47:35 »
MauRice,

Het gaat inderdaad over een communicatiefout:
"Als ik Sane opstart en op 'scannen' druk, krijg ik de melding 'Scannen is mislukt Kan niet verbinden met scanner'
Als ik Xsane opstart krijg ik 'Kan apparaat niet vinden 'hpaio:/net/Officejet.... ' Fout tijdens apparaat communicatie"
maar dat betekent nog niet dat het met 'rechten' te maken zou hebben ...
sudo of als user maakt geen enkel verschil ... ???

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #8 Gepost op: 2015/07/18, 21:20:48 »
Eventueel zou je zoals in deze hyperlink https://answers.launchpad.net/hplip/+question/199727 de output kunnen checken en posten van
hp-check -t [Enter]

Die output kun je vinden in ~/hp-check.log

Klopt verder het IP-adres nog van je HP All-in-one, zoals die in je router staat opgeslagen?
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: HP All-in-one netwerk scanner werkt niet meer ?!
« Reactie #9 Gepost op: 2015/07/19, 07:22:35 »
Shadoogie2960,

Ik vermoed toch een rechten/firewall probleempje.
Maar dan wel op de router.

Kijk eens naar dit topic.
Het ging hierin weliswaar over een HP all-in-one via een Print-server in een thuis netwerkje.
Maar het scannen van eender PC/Laptop ging pas als de rechten van de device op 0666 (root:lp) en bepaalde poorten opstonden op de Print-server.

Controlleer eens of je ook dit kan instellen uw router.
Anders, iets radicaler 192.168.1.166 op DMZ zetten.

Oh ja, in /etc/sane.d/net.conf bestandje van de clients, staat wel het IP-adres van deze Print-server.
In uw geval: 192.168.1.66
MvG,
MauRice
Registered Linux user: 473556