Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gek gedoe met geluid.  (gelezen 1841 keer)

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Gek gedoe met geluid.
« Gepost op: 2015/06/21, 18:50:16 »
Ik heb een dongle om muziek over te brengen naar mijn stereo,is bluetooth.Dus daar na wil ik weer naar gewoon geluid via de speakers van de pc en dat gaat in eens niet meer!
Als ik de dongle er uit trek gaat het niet terug,ook al staat er alleen maar intern geluid in de instellingen.Als ik hem laat zitten en kies voor intern geluid werkt het ook niet.
Wat doe ik fout?
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #1 Gepost op: 2015/06/21, 23:53:51 »
Nog geprobeerd met de hoofdtelefoon direkt op de uitgang van de PC,maar ook dan geen geluid,dus het ligt ook niet aan de versterker..En volgens mij moet dat ook in de geluidsinstellingen staan:Hoofdtelefoon.
Zit ook geen geluidskaart in die misschien geen contact maakt,is allemaal op het moederbord.
« Laatst bewerkt op: 2015/06/21, 23:55:51 door Lowlands »
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #2 Gepost op: 2015/06/23, 12:05:57 »
Niemand die hier iets op weet? :'(
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #3 Gepost op: 2015/06/26, 00:00:14 »
Na een bezoek aan Windows XP op dezelfde PC weet ik nu dat het toch echt aan Ubuntu ligt,want daar speelde hij prima geluid af!Ik mis dus een driver!
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #4 Gepost op: 2015/06/26, 19:42:10 »
Stond het dan ook zo ingesteld, toen het geluid via de pc speakers nog wel werkte? Want als deze zijn aangesloten via een 3,5 mm jack plug, dan zou er in die afbeelding "Analoge output  Intern geluid" behoren te staan vermeld. Je zou om mee te beginnen het terminalvenster commando
aplay -L [Enter] kunnen uitvoeren, en hier posten. 
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #5 Gepost op: 2015/06/26, 22:34:39 »
Dit stond er toen de dongle nog stond aangesloten,nu staat er alleen maar intern digitaal geluid.Dus geen vermelding van hoofdtelefoonuitgang.
aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
sysdefault:CARD=SB
    HDA ATI SB, STAC9221 A2 Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Digital
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    Direct sample mixing device
dmix:CARD=SB,DEV=1
    HDA ATI SB, STAC9221 A2 Digital
    Direct sample mixing device
dsnoop:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    Direct sample snooping device
dsnoop:CARD=SB,DEV=1
    HDA ATI SB, STAC9221 A2 Digital
    Direct sample snooping device
hw:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    Direct hardware device without any conversions
hw:CARD=SB,DEV=1
    HDA ATI SB, STAC9221 A2 Digital
    Direct hardware device without any conversions
plughw:CARD=SB,DEV=0
    HDA ATI SB, STAC9221 A2 Analog
    Hardware device with all software conversions
plughw:CARD=SB,DEV=1
    HDA ATI SB, STAC9221 A2 Digital
    Hardware device with all software conversions

Moderator Edit: even code tags geplaatst
« Laatst bewerkt op: 2015/06/27, 12:06:57 door Joshua Orbit »
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline soppel

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #6 Gepost op: 2015/06/27, 10:29:41 »
Ik ben niet erg bekend meer met Ubuntu, werk met Debian dus ik weet niet of het voor jou opgaat. Ik meld het toch maar even, misschien dat het toch een tip kan zijn waar een ander weer mee verder kan.

Ik heb onder 'bepaalde omstandigheden' dat er instellingen van alsamixer wijzigen, waardoor ik geen geluid meer heb.
( ik weet niet wanneer die 'bepaalde omstandigeden' optreden)
Ik moet dan de instellingen van alsamixer even nalopen. Of je onder Ubuntu nog alsamixer hebt weet ik niet.
Sinds Debian ook Pulseaudio aan boord heeft heb ik er vaker last van.


disclaimer: ik probeer niet je topic te kapen voor mijn probleem, het is puur informatief.

Gooi je windows uit het raam
en je virusscanner d'r achteraan

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #7 Gepost op: 2015/06/27, 12:35:29 »
Tja,maar waar zou ik die dan moeten wijzigen,anders dan in Geluidinstellingen?Maar misschien moet ik die opnieuw installeren,dus van uit Synaptic..

Wow!Daar staan een heleboel audiodingen met pulseaudio.Wat moet ik aankruisen om te verwijderen en later herinstalleren?

Nog even informatie,als je een bestand laad in b.v. Rythmbox,dan speelt die het gewoon af!Alleen je hoort niks.En er is niks gedempt in de geluidinstellingen of Rythmbox.Ook een andere speler laat niks horen..Maar je ziet wel in b.v. Audacious de volumemeter reageren op het bestand.Het lijkt dus net als of je alleen maar het volume moet open draaien,maar die staat al max..
« Laatst bewerkt op: 2015/06/27, 12:55:44 door Lowlands »
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline soppel

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #8 Gepost op: 2015/06/27, 12:42:49 »
in de terminal intoetsen 'alsamixer'

dan heb je 2 mogelijkheden:
1) er start een scherm alsamixer op, dan spelen met de instellingen. ( eventueel een screendump dan kijk ik even mee)
2) alsamixer start niet....dan is dat niet in ubuntu aanwezig en kan je alles vergeten wat ik geschreven heb.
Gooi je windows uit het raam
en je virusscanner d'r achteraan

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #9 Gepost op: 2015/06/27, 12:50:26 »
Er is in Ubuntu inderdaad een terminalversie van alsamixer beschikbaar. Eventueel zou via Ubuntu' Softwarecentrum de grafische gnome-alsamixer geïnstalleerd kunnen worden.

Verder zou je van deze hyperlink https://help.ubuntu.com/community/SoundTroubleshooting stap 1 t/m stap 6 kunnen uitvoeren, zodat je de output daarvan kunt posten. De output van je vorig bericht lijkt me in orde. 
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline soppel

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #10 Gepost op: 2015/06/27, 12:56:07 »
Bedoel jij dat ie standaard geïnstalleerd is Jolo?
Want als ie niet standaard geïnstalleerd is, zou ik 'm niet zomaar installeren.
Het zou dan immers zonder 'moeten' werken.
Als het uiteindelijk nodig blijkt is het vroeg genoeg.

Overigens vind ik de terminalversie 10x handiger dan de grafische, maar dat is ongetwijfeld persoonlijk.
Gooi je windows uit het raam
en je virusscanner d'r achteraan

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #11 Gepost op: 2015/06/27, 13:14:26 »
De grafische gnome-alsamixer is standaard niet geïnstalleerd in Ubuntu 14.04. Deze mixer is inderdaad niet vereist. Belangrijker lijkt me de in de startpost geposte screenshot van Geluid, er bij Uitvoer zoiets zou moeten staan als "Analoge output Intern geluid". Want als die daar niet staat, kun je 'm ook niet selecteren.
   
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #12 Gepost op: 2015/06/27, 15:07:02 »
Precies!Maar hoe krijg je die daar weer in???
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline soppel

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #13 Gepost op: 2015/06/27, 15:09:15 »
Ben het met je eens Jolo, maar ik blijf een beetje eigenwijs  ;)

Lowland, als je alsamixer opent druk dan eens op F6.
Hoeveel geluidskaarten staan daar?

Kans bestaat dat je normaliter gebruik maakt van de onboard geluidskaart, maar dat nu bv de hdmi als standaard aangemerkt staat.
In mijn geval: ik heb -uiteraard- een onboard geluidskaart, een insteek pci kaart en op de grafische kaart zit de hdmi geluidskaart.
Geluidskaarten tellen 0,1,2 enz.
Welke 0 of 1 wordt staat niet vast tijdens de opstart van de pc, hoewel in de praktijd de wet van bartjens geld en dat meestal de verkeerde 0 wordt  :evil:
Ik maak alleen gebruik van de pci kaart en heb dus de onboard in de bios uitgeschakeld en de hdmi staat op een blacklist.
Doe ik dan niet dan start ie random op en zit ik steeds te etteren.
Als bij jou nu de hdmi de eerste is en je wilt gebruik maken van de on-board moet je de hdmi dus gaan blacklisten.



Gooi je windows uit het raam
en je virusscanner d'r achteraan

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #14 Gepost op: 2015/06/27, 23:23:43 »
Ik heb dus geen alsa mixer...En zo als je al kon zien bij de schermafdruk staat er dus maar 1 en wel intern digitaal geluid..En dat verandert niet als ik op f6 druk..HDMI is niet aangesloten aan het scherm omdat er geen speakers in zitten..Dus met DVI,maar dat heeft niks te maken met geluid..Dat komt uit de blauwe 2,5 mm plug aan de achterkant.En ja,dat is de goede uitgang,heb de andere ook geprobeerd.En de jack van de versterker is ook blauw..En de hoofdtelefoon direct op de uitgang doet ook niks..
« Laatst bewerkt op: 2015/06/27, 23:28:08 door Lowlands »
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #15 Gepost op: 2015/06/27, 23:34:43 »
Bluetooth verwijderen, losmaken.
rebooten,
dan weer audio instellen gaan proberen.

Offline soppel

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #16 Gepost op: 2015/06/27, 23:40:55 »
sorry hoor, ik wist niet dat je kwaad werd.
Ik heb meerdere keren aangegeven dat ik niet 100% thuis ben in ubuntu.
Als je geen alsamixer hebt heeft het natuurlijk geen nut om op f6 te drukken, wat een functie is IN alsamixer.
En als je pc hdmi heeft zit daar wel degelijk geluid in. Dat je dat niet aansluit is wat anders, maar als je pc het geluid naar die hdmi stuurt komt er niks uit het blauwe stekkertje
Gooi je windows uit het raam
en je virusscanner d'r achteraan

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #17 Gepost op: 2015/06/27, 23:57:16 »
Probeer ook alle hardware uit te zetten, zodat er maar 1 over blijft, bij je geluids instellingen.
Misschien nog een keer rebooten, dan zou er maar 1 hardware over moeten blijven.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #18 Gepost op: 2015/06/28, 12:08:11 »
sorry hoor, ik wist niet dat je kwaad werd.
Ik heb meerdere keren aangegeven dat ik niet 100% thuis ben in ubuntu.
Als je geen alsamixer hebt heeft het natuurlijk geen nut om op f6 te drukken, wat een functie is IN alsamixer.
En als je pc hdmi heeft zit daar wel degelijk geluid in. Dat je dat niet aansluit is wat anders, maar als je pc het geluid naar die hdmi stuurt komt er niks uit het blauwe stekkertje
Sorry als je dacht dat ik kwaad op je werd,is helemaal niet waar hoor..Maar ik gaf alleen aan dat het niet nodig is om hdmi aan te sluiten als je toch geen speakers in je scherm hebt. Vandaar dus de DVI aansluiting.Kan hem wel aansluiten,zit wel een hdmi ingang op...
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #19 Gepost op: 2015/06/28, 12:09:43 »
Bluetooth verwijderen, losmaken.
rebooten,
dan weer audio instellen gaan proberen.
Dat is ook wat ik gedaan hebt.Maar alleen de interne digitale geluid bleef over,geen hoofdtelefoon uitgang.Er is gewoon niks meer te kiezen..
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #20 Gepost op: 2015/06/28, 12:14:59 »
 :'(
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #21 Gepost op: 2015/06/28, 14:44:15 »
Bij xubuntu kun je ook de uitvoer instellen, maar ook aangeven welke hardware geluid mogen spelen, dat is wat ik bedoelde.
Zoek of je  je hardware kunt voorkiezen, welke geluid mag afspelen, dit proberen in te stellen zodat er maar 1 over blijft.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #22 Gepost op: 2015/06/28, 15:04:27 »
Zou niet weten hoe dat in Ubuntu moet...

Heb in het Bios de onboardaudio uit geschakeld en na opnieuw opstarten kreeg ik alleen dummy uitvoer te zien in geluidsinstellingen.Weer opnieuw opgestart en in de BIOS weer enabled en na opstarten van van Ubuntu was er niks verandert ,weer alleen digitale uitgang intern.(electronica kan wel eens tussen aan en uit zweven,vandaar..)

sudo lshw gedaan en dan krijg je dit te zien wat betreft audio:
 description: Audio device
             product: SBx00 Azalia (Intel HDA)
             vendor: Advanced Micro Devices, Inc. [AMD/ATI]
             physical id: 14.2
             bus info: pci@0000:00:14.2
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: driver=snd_hda_intel latency=64
             resources: irq:16 memory:fbff4000-fbff7fff
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #23 Gepost op: 2015/06/28, 15:21:44 »
Zover ik begrijp heeft het geluid eerst gewoon gewerkt. Klopt dat?
Wat heb je precies gedaan bij het installeren en instellen van de dongel?

Verder wat ik een keer heb mee gemaakt:

PulseAudio is de standaard sounddriver voor Ubuntu, maar dat maakt deels gebruik van alsa.
Je kan alsa ook direct als sounddriver gebruiken.

Ik ben eens bezig geweest om mijn geluid via het netwerk naar mijn server te laten sturen en die het op mijn stereo te laten afspelen.
PulseAudio blijkt daar een mooie ondersteuning voor te hebben. ( Maar dat ter zijde.)

Tijdens het proberen heb ik eens mijn Ubuntu installatie direct op alsa laten werken i.p.v. PulseAudio.
Dit gaf bij mij problemen en had ik opeens ook geheel geen geluid meer.

Het kan zijn dat bij jouw met het installeren en instellen van de dongel dit ook is gebeurd. (Hoewel het volgens mij niet zou moeten.)
Ik weet helaas niet het commando om dit te controleren en kan het ook niet snel vinden.
Wat je in ieder geval kan proberen is het volgend commando:
pulseaudio -D --startDit zou PulseAudio weer moeten op te starten. Het kan hierbij geen kwaad als PulseAudio al actief is.

EDIT: Ik had het stukje dat alleen de digitale uitgang wordt gegeven nog niet goed gelezen.
« Laatst bewerkt op: 2015/06/28, 15:28:44 door Erik Krom »

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Gek gedoe met geluid.
« Reactie #24 Gepost op: 2015/06/28, 15:24:41 »
Om te checken of het een hardware probleem is, zou je de pc kunnen opstarten vanaf een Ubuntu dvd. Kies dan voor "Ubuntu uitproberen zonder te installeren"/"Try Ubuntu" zodat een Live-sessie start. Doe dit bij voorkeur met de zelfde Ubuntu versie, als de Ubuntu op je harddisk. Heb je daarmee dan wel "Analoge output Intern geluid" op tabblad Uitvoer?
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM