Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gnome-commander herinstalleren  (gelezen 446 keer)

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Gnome-commander herinstalleren
« Gepost op: 2015/06/17, 21:15:17 »
Zoals het onderwerp al zegt, wil ik Gnome-commander opnieuw installeren op Ubuntu 12.04.
Ik heb het helemaal er af gehaald met synaptic, maar nu wil het niet meer installeren.
Als ik via de terminal het wil installeren zegt dan krijg ik deze melding
Citaat
Sommige pakketten konden niet geinstalleerd worden. Dit kan betekenen dat u een onmogelijke situatie gevraagd hebt of dat u de 'unstable'- distributie gebruikt en sommige benodigde pakketten vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder

De volgende pakketten hebben niet-voldane vereisten:
gnome-commander : Vereisten: libexiv2-12 maar het is niet installeerbaar
                                          Vereisten: libglib2.0.0 (>= 2.37.3) maar 2.32.4-0ubuntu1 zal geinstalleerd worden
                                          Vereisten: libpango-1.0-0 (>= 1.14.0) maar het is niet installeerbaar

E: Kan problemen niet verhelpen, u houd defecte pakketen vast

Hoe kan ik het verhelpen zodat ik weer Gnome-commander kan gebruiken?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #1 Gepost op: 2015/06/17, 21:37:30 »
Citaat
Kan problemen niet verhelpen, u houd defecte pakketen vast
Heb je in Synaptic al "defecte pakketten repareren" geprobeerd?

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #2 Gepost op: 2015/06/17, 21:39:17 »
Citaat
Kan problemen niet verhelpen, u houd defecte pakketen vast
Heb je in Synaptic al "defecte pakketten repareren" geprobeerd?
Dat had ik geprobeerd, maar dat hielp niet.
Vandaar dat ik het heb gedeinstalleerd, maar nu wil het niet meer installeren.
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #3 Gepost op: 2015/06/18, 09:44:49 »
Wat geeftdpkg -l libglib*

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #4 Gepost op: 2015/06/22, 10:34:43 »
Wat geeftdpkg -l libglib*
Zie hieronder:
Citaat
rick@ubuntu:~$ dpkg -l libglib*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Naam           Versie         Omschrijving
+++-==============-==============-============================================
ii  libglib-perl   2:1.241-1      interface to the GLib and GObject libraries
ii  libglib2.0-0   2.32.4-0ubuntu GLib library of C routines
ii  libglib2.0-bin 2.32.4-0ubuntu Programs for the GLib library
ii  libglib2.0-cil 2.12.10-2ubunt CLI binding for the GLib utility library 2.1
ii  libglib2.0-dat 2.32.4-0ubuntu Common files for GLib library
un  libglib2.0-dev <none>         (geen beschrijving beschikbaar)
ii  libglibmm-2.4- 2.32.0-0ubuntu C++ wrapper for the GLib toolkit (shared lib
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #5 Gepost op: 2015/06/22, 18:17:24 »
Waar heb je de gnome-commander vandaan? Volgens de package list van Ubuntu 12.04 (Precise) heeft die libglib2.0-0 (>= 2.31.2) nodig, terwijl jouw package vraagt naar libglib2.0.0 (>= 2.37.3).

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #6 Gepost op: 2015/06/22, 19:01:48 »
Waar heb je de gnome-commander vandaan? Volgens de package list van Ubuntu 12.04 (Precise) heeft die libglib2.0-0 (>= 2.31.2) nodig, terwijl jouw package vraagt naar libglib2.0.0 (>= 2.37.3).
Ik geloof dat ik die via Pjotter zijn webpage vandaan had gehaald.
En de laatste wil ik via Synaptic installeren, maar dat werkte ook niet.
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #7 Gepost op: 2015/06/22, 19:31:02 »
De site van Pjotr is bijgewerkt voor de laatste LTS versie 14.04, en is bijgevolg niet klakkeloos te volgen voor vorige versies. Je kan best gewoon de versie van Ubuntu zelf pakken.
sudo apt-get clean
sudo apt-get update
sudo apt-get install gnome-commander

Edit: op de site van Pjotr vind ik geen installeerbaar pakket voor gnome-commander, wel de apt-get install zoals ik die hierboven heb gegeven.
« Laatst bewerkt op: 2015/06/22, 19:36:03 door Nero »

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #8 Gepost op: 2015/06/22, 19:49:07 »
De site van Pjotr is bijgewerkt voor de laatste LTS versie 14.04, en is bijgevolg niet klakkeloos te volgen voor vorige versies. Je kan best gewoon de versie van Ubuntu zelf pakken.
sudo apt-get clean
sudo apt-get update
sudo apt-get install gnome-commander

Edit: op de site van Pjotr vind ik geen installeerbaar pakket voor gnome-commander, wel de apt-get install zoals ik die hierboven heb gegeven.
Heel vreemd, maar hij blijft het bovenstaande geven.
Zit er ergens een verborgen bestand wat ik nog eerst moet verwijderen om het opnieuw te installeren?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #9 Gepost op: 2015/06/22, 20:12:29 »
Wat is het resultaat vansudo apt-get install --reinstall libglib2.0-0

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #10 Gepost op: 2015/06/22, 20:18:13 »
Wat is het resultaat vansudo apt-get install --reinstall libglib2.0-0
Dat werkt, maar ik krijg als ik gnome commander wil installeren toch dezelfde melding.
Heel vreemd.
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #11 Gepost op: 2015/06/22, 20:19:24 »
Maar welke versie van libglib is nu geïnstalleerd?

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #12 Gepost op: 2015/06/22, 20:20:19 »
Maar welke versie van libglib is nu geïnstalleerd?
Hoe krijg ik dat te zien?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #13 Gepost op: 2015/06/22, 20:34:05 »
dpkg -l libglib2*

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #14 Gepost op: 2015/06/22, 20:35:32 »
dpkg -l libglib2*
Bedankt.
Citaat
rick@ubuntu:~$ dpkg -l libglib2*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Naam           Versie         Omschrijving
+++-==============-==============-============================================
ii  libglib2.0-0   2.32.4-0ubuntu GLib library of C routines
ii  libglib2.0-bin 2.32.4-0ubuntu Programs for the GLib library
ii  libglib2.0-cil 2.12.10-2ubunt CLI binding for the GLib utility library 2.1
ii  libglib2.0-dat 2.32.4-0ubuntu Common files for GLib library
un  libglib2.0-dev <none>         (geen beschrijving beschikbaar)
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #15 Gepost op: 2015/06/22, 20:41:23 »
Citaat
rick@ubuntu:~$ dpkg -l libglib2*
Desired=Unknown/Install/Remove/Purge/Hold


Mss dat dit soelaas biedt:
sudo apt-get autoclean && sudo apt-get clean && sudo apt-get autoremove

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #16 Gepost op: 2015/06/22, 21:40:55 »
Citaat
rick@ubuntu:~$ dpkg -l libglib2*
Desired=Unknown/Install/Remove/Purge/Hold


Mss dat dit soelaas biedt:
sudo apt-get autoclean && sudo apt-get clean && sudo apt-get autoremove
Dit is wat er gegeven word:
Citaat
rick@ubuntu:~$ sudo apt-get autoclean && sudo apt-get clean && sudo apt-get autoremove
[sudo] password for rick:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
En dit als ik opnieuw Gome-Commander wil instaleren:
Citaat
rick@ubuntu:~$ sudo apt-get install gnome-commander
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 gnome-commander : Vereisten: libexiv2-12 maar het is niet installeerbaar
                   Vereisten: libglib2.0-0 (>= 2.37.3) maar 2.32.4-0ubuntu1 zal geïnstalleerd worden
                   Vereisten: libpango-1.0-0 (>= 1.14.0) maar het is niet installeerbaar
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

Weet iemand hoe ik het anders kan oplossen?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #17 Gepost op: 2015/06/22, 21:50:19 »
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

Het praat wel Nederlands terug  :D

Kan je wat uitrichten met synaptic (zie plaatje hieronder) ?
Bijvoorbeeld repareren?

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #18 Gepost op: 2015/06/22, 22:04:33 »
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

Het praat wel Nederlands terug  :D

Kan je wat uitrichten met synaptic (zie plaatje hieronder) ?
Bijvoorbeeld repareren?
Geprobeerd, maar hij geeft het volgende aan:
Citaat
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
E: Fout, pkgProblemResolver::Resolve maakte scheidingen aan, dit kan veroorzaakt worden door vastgehouden pakketten.
E: Kan afhankelijkheden niet corrigeren
E: Fout, pkgProblemResolver::Resolve maakte scheidingen aan, dit kan veroorzaakt worden door vastgehouden pakketten.
E: Kan afhankelijkheden niet corrigeren
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #19 Gepost op: 2015/06/23, 10:24:11 »
Het lijkt er op dat je steeds een versie van gnome-commander dan de versie die Ubuntu aanbiedt voor 12.04 probeert te installeren. Op http://packages.ubuntu.com/precise/gnome-commander zie je alle versienummers die GC nodig heeft voor Precise. GC van 12.04 vraagt bv libexiv2-11 terwijl jouw install zoekt naar libexiv2-12.

Er is op een of andere wijze gerommeld met de sources.list.

Wat geeftaptitude why libglib2.0-0

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #20 Gepost op: 2015/06/23, 10:39:18 »
Het lijkt er op dat je steeds een versie van gnome-commander dan de versie die Ubuntu aanbiedt voor 12.04 probeert te installeren. Op http://packages.ubuntu.com/precise/gnome-commander zie je alle versienummers die GC nodig heeft voor Precise. GC van 12.04 vraagt bv libexiv2-11 terwijl jouw install zoekt naar libexiv2-12.

Er is op een of andere wijze gerommeld met de sources.list.

Wat geeftaptitude why libglib2.0-0
Het onderstaande:
Citaat
rick@ubuntu:~$ aptitude why libglib2.0-0
i   handbrake-gtk Vereisten libglib2.0-0 (>= 2.31.8)
Hoe kan ik het terugdraaien de gerommelde sources list?
« Laatst bewerkt op: 2015/06/23, 10:41:33 door Mustangman1966 »
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #21 Gepost op: 2015/06/23, 11:54:16 »
Wat staat er nu in /etc/apt/sources.list? En welke bestanden (met inhoud) staan er in /etc/apt/sources.list.d/?

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #22 Gepost op: 2015/06/23, 12:00:35 »
Wat staat er nu in /etc/apt/sources.list? En welke bestanden (met inhoud) staan er in /etc/apt/sources.list.d/?
In de /etc/apt/sources.list staat:
Citaat
#

# deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release i386 (20130820.2)]/ precise main restricted

# deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release i386 (20130820.2)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ precise universe
deb http://nl.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nl.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://nl.archive.ubuntu.com/ubuntu/ precise-security main restricted
deb http://nl.archive.ubuntu.com/ubuntu/ precise-security universe
deb http://nl.archive.ubuntu.com/ubuntu/ precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://download.virtualbox.org/virtualbox/debian precise contrib
# deb-src http://download.virtualbox.org/virtualbox/debian precise contrib
En in de /etc/apt/sources.list.d staan:
Citaat
deb http://archive.getdeb.net/ubuntu trusty-getdeb apps
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Gnome-commander herinstalleren
« Reactie #23 Gepost op: 2015/06/23, 12:34:33 »
In dat laatste zit het 'm. Daar wordt verwezen naar pakketten uit Trusty (14.04). waardoor je een ongezonde mix krijgt. Verwijder dat bestand eens (eventueel eerst een copy maken) en voer daarna nogmaals de update uit.
sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall gnome-commander

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Gnome-commander herinstalleren
« Reactie #24 Gepost op: 2015/06/23, 12:36:10 »
In dat laatste zit het 'm. Daar wordt verwezen naar pakketten uit Trusty (14.04). waardoor je een ongezonde mix krijgt. Verwijder dat bestand eens (eventueel eerst een copy maken) en voer daarna nogmaals de update uit.
sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall gnome-commander
Hoe kan ik die laatste zin het veiligste verwijderen?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress