Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: cryptswap1 niet gereed?  (gelezen 122 keer)

Offline partyrabbit

  • Lid
  • Steunpunt: Ja
cryptswap1 niet gereed?
« Gepost op: 2015/06/17, 16:40:32 »
Als ik deze laptop (Ubuntu 12.04LTS) opstart krijg ik tijdens de opstartprocedure:
Het schrijfstation voor /dev/mapper/crypswap1 is nog niet gereed of niet aanwezig.
Doorgaan met wachten, of druk op S om het aankoppelen over te slaan, of M voor handmatig herstel.

Dit krijg ik op mijn pc (Ubuntu 12.04LTS) niet. Op deze laptop wel, ook bij vorige installaties van Ubuntu 12.02LTS.
Wachten, S of M, maakt niet uit want hij start wel gewoon op.

Is dit iets belangrijks? Gaat hier iets verkeerd? Moet of kan ik hier iets mee? Of negeren?
« Laatst bewerkt op: 2015/06/17, 16:42:03 door partyrabbit »
I ♥ Linux
 
"Schroom niet af en toe je kop boven het maaiveld uit te steken. Zulke mensen zijn nodig. Buk gewoon op tijd." --partyrabbit--

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: cryptswap1 niet gereed?
« Reactie #1 Gepost op: 2015/06/17, 16:49:29 »
dan staat het waarschijnlijk niet goed in fstab.
Vergeljk de UIID van fstab en controleer deze met sudo blkid

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: cryptswap1 niet gereed?
« Reactie #2 Gepost op: 2015/06/17, 16:52:40 »
Waarschijnlijk heb jij je /home versleuteld bij de installatie.
Het is een bekende bug bij Ubuntu/Mint dat dit niet goed gaat met de swap (en hibernation). Waarschijnlijk heb je nu geen werkende swap (check maar eens).


Mijn oplossing was de swap gewoon niet encrypten, maar via je zoekboer kun je natuurlijk ook andere oplossingen vinden.
https://startpage.com/do/search?q=ubuntu+swap+encrypted+home&lui=nederlands&l=nederlands

#enable encryption
sudo ecryptfs-setup-swap

#disable encryption (allows hibernation)
sudo swapoff -a
sudo cryptsetup remove /dev/mapper/cryptswap1
sudo cp /etc/crypttab /etc/crypttab_bk
sudo gedit /etc/crypttab
#remove the /dev/sdaX line
sudo /sbin/mkswap /dev/sdaX
sudo swapon /dev/sdaX
sudo cp /etc/fstab /etc/fstab_bk
sudo gedit /etc/fstab
#replace /dev/mapper/cryptswap1 with /dev/sdaX

Offline partyrabbit

  • Lid
  • Steunpunt: Ja
Re: cryptswap1 niet gereed?
« Reactie #3 Gepost op: 2015/06/17, 16:58:30 »
Waarschijnlijk heb jij je /home versleuteld bij de installatie.
Deze keer wel. Eerdere keer niet en toen kreeg ik die melding ook.

Ik ga met deze antwoorden aan de gang. Al zal ik waarschijnlijk EZ nog even moeten vragen wat hij precies bedoeld.  :laugh:
I ♥ Linux
 
"Schroom niet af en toe je kop boven het maaiveld uit te steken. Zulke mensen zijn nodig. Buk gewoon op tijd." --partyrabbit--

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: cryptswap1 niet gereed?
« Reactie #4 Gepost op: 2015/06/17, 17:10:28 »
Al zal ik waarschijnlijk EZ nog even moeten vragen wat hij precies bedoeld.  :laugh:

Dat mag altijd. lees voor UIID (in mijn vorige bericht) UUID  =D