Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid standaard afspeel apparaat instellen.  (gelezen 1430 keer)

Offline jos34

  • Lid
Geluid standaard afspeel apparaat instellen.
« Gepost op: 2015/06/12, 19:50:43 »
Hoe kan ik er voor zorgen dat hij standaard op Xonar Luidsreker staat want bij elke PC herstart staat hij weer op Analoge output.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #1 Gepost op: 2015/06/12, 20:37:37 »
Welke versie van Ubuntu is dit?
Mocht het MINT zijn, dan hoort dit bij overige distributies en moet de vraag verplaatst worden.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #2 Gepost op: 2015/06/12, 20:44:13 »
jos34,

Even een tip.... Aangezien je Linux Mint gebruikt, wat ik haal uit je bovenstaande screenshot en voorgaande topics, heb je twee opties...

1. je post je vragen over Linux Mint onder Andere Distributies hier op het forum.

Of....

2.  je vraagt het op 1 van de twee Nederlandstalige Linux Mint forums.

Begrijp me niet verkeerd maar dit is op een bepaald moment gewoon te verwarrend voor andere gebruikers en levert het het forumteam extra werk om steeds je topics eruit te pikken en te verplaatsen.
« Laatst bewerkt op: 2015/06/12, 20:47:10 door Maik »

Offline jos34

  • Lid
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #3 Gepost op: 2015/06/12, 23:12:03 »
Ik heb het al opgelost gekregen met de volgende tut:

On the Dash, search for Multimedia Systems Selector.
Open it and in its Audio tab you can select the default audio Input and Output devices.

This application is installed by default in Ubuntu Installation. But if you haven`t this somehow can install by

sudo apt-get install gnome-media

If it is not shown in the Dash, run:

gksudo gedit /usr/share/applications/gstreamer-properties.desktop

In the resulting text file, go to the line starts with NoDisplay=. Change the NoDisplay=true to NoDisplay=false

Offline jos34

  • Lid
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #4 Gepost op: 2015/07/14, 22:18:05 »
Na een herinstalatie van Mint weer hetzelfde euvel en dit keer werkt die tool niet. (Multimedia Systems Selector)
De ene keer onthoud die het audio apparaat wel, dan weer niet.
Iemand nog een idee?

Of weet mischien iemand of en hoe het mogelijk is die andere audio apparaten geheel te verwijderen, dat kan ook een optie zijn.
« Laatst bewerkt op: 2015/07/14, 22:25:29 door jos34 »

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #5 Gepost op: 2015/07/14, 23:01:27 »
Kijk eens naar http://askubuntu.com/questions/158908/how-can-i-force-a-preferred-sound-output-device-to-be-used
default.pa  is de standaard van PulseAudio.

Je zult het zelf moeten aanpassen na een inventarisatie van de volgende opdracht :
pacmd list-sinks
In de output kijk je onder Ports :
ports:                                <<<<<<<<<<<<<<<<<<--------                       LET OP        !!!!!!!!!!!!!!!!!
   analog-output: Analoge output (priority 9900, latency offset 0 usec, available: unknown)   

   analog-output-speaker: Luidsprekers (priority 10000, latency offset 0 usec, available: unknown) 
device.icon_name = "audio-speakers"

   analog-output-headphones: Analoge koptelefoon (priority 9000, latency offset 0 usec, available: no) 
           properties:    device.icon_name = "audio-headphones"


active port: <analog-output-speaker>

Zoals je bij mij kan zien in als active port analog-output-speaker geselecteerd.
Die is te wijzigen in een van de andere :  Luidsprekers    of   Analoge koptelefoon

Offline jos34

  • Lid
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #6 Gepost op: 2015/07/15, 14:55:02 »
pacmd list-sinks

Welcome to PulseAudio! Use "help" for usage information.
>>> 2 sink(s) available.
    index: 0
name: <alsa_output.pci-0000_02_00.1.hdmi-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9050
volume: 0: 100% 1: 100%
        0: 0,00 dB 1: 0,00 dB
        balance 0,00
base volume: 100%
             0,00 dB
volume steps: 65537
muted: no
current latency: 0,00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 0
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 0,00 ms; range is 0,50 .. 371,52 ms
card: 0 <alsa_card.pci-0000_02_00.1>
module: 4
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "HDMI 0"
alsa.id = "HDMI 0"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "3"
alsa.card = "1"
alsa.card_name = "HDA NVidia"
alsa.long_card_name = "HDA NVidia at 0xf7080000 irq 18"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:02:00.1"
sysfs.path = "/devices/pci0000:00/0000:00:01.1/0000:02:00.1/sound/card1"
device.bus = "pci"
device.vendor.id = "10de"
device.vendor.name = "NVIDIA Corporation"
device.product.id = "0e0a"
device.product.name = "GK104 HDMI Audio Controller"
device.string = "hdmi:1"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "hdmi-stereo"
device.profile.description = "Digital Stereo (HDMI)"
device.description = "GK104 HDMI Audio Controller Digital Stereo (HDMI)"
alsa.mixer_name = "Nvidia GPU 40 HDMI/DP"
alsa.components = "HDA:10de0040,14622847,00100100"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
properties:
device.icon_name = "video-display"
device.product.name = "SAMSUNG"
active port: <hdmi-output-0>
  * index: 1
name: <alsa_output.pci-0000_06_04.0.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9059
volume: 0:  21% 1:  21%
        0: -40,15 dB 1: -40,15 dB
        balance 0,00
base volume: 100%
             0,00 dB
volume steps: 65537
muted: no
current latency: 0,00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 1
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
card: 1 <alsa_card.pci-0000_06_04.0>
module: 5
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "Multichannel"
alsa.id = "Multichannel"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "Xonar STX"
alsa.long_card_name = "Asus Virtuoso 100 at 0xc000, irq 19"
alsa.driver_name = "snd_virtuoso"
device.bus_path = "pci-0000:06:04.0"
sysfs.path = "/devices/pci0000:00/0000:00:1c.3/0000:05:00.0/0000:06:04.0/sound/card0"
device.bus = "pci"
device.vendor.id = "13f6"
device.vendor.name = "C-Media Electronics Inc"
device.product.id = "8788"
device.product.name = "Virtuoso 100 (Xonar Essence STX)"
device.string = "front:0"
device.buffering.buffer_size = "352800"
device.buffering.fragment_size = "352800"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analoog stereo"
device.description = "Virtuoso 100 (Xonar Essence STX) Analoog stereo"
alsa.mixer_name = "AV200"
alsa.components = "PCM1792A CS5381 AV200"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output;output-speaker: Analoge output / Luidspreker (priority 9910, latency offset 0 usec, available: unknown)
properties:

analog-output;output-headphones-1: Analoge output / Analoge koptelefoon 1 (priority 9909, latency offset 0 usec, available: unknown)
properties:

analog-output;output-headphones-2: Analoge output / Analoge koptelefoon 2 (priority 9908, latency offset 0 usec, available: unknown)
properties:

active port: <analog-output;output-speaker>

Ik heb een heleboel tuts geprobeerd en het probleem blijft steeds terug komen :( >:( :evil:, de ene keer blijft hij op Xonar staan en dan gaat hij weer wel terug.
Uren ben ik er al mee bezig geweest.
https://wiki.archlinux.org/index.php/PulseAudio/Examples#Set_the_defaulting_output_source
http://askubuntu.com/questions/15497/how-to-remove-nvidia-hdmi-audio-output-in-pulseaudio
https://bbs.archlinux.org/viewtopic.php?id=164868
http://forums.linuxmint.com/viewtopic.php?t=70675&f=42
http://forums.linuxmint.com/viewtopic.php?f=42&t=60485&start=20
http://unix.stackexchange.com/questions/53631/set-default-sound-card-in-pulse-audio
http://askubuntu.com/questions/71863/how-to-change-pulseaudio-sink-with-pacmd-set-default-sink-during-playback
http://superuser.com/questions/626606/how-to-make-alsa-pick-a-preferred-sound-device-automatically
http://ubuntuforums.org/showthread.php?t=844794
http://ubuntuforums.org/showthread.php?t=997506
http://forums.linuxmint.com/viewtopic.php?f=48&t=95337
http://askubuntu.com/questions/14077/how-can-i-change-the-default-audio-device-from-command-line

Ik heb het probleem nu eindelijk opgelost door de onboard audio in de Bios uit te schakelen. Nu kiest hij wel standaard de Xonar.
Het ziet er nu zo uit:

Een geluk dat hij nu niet standaard voor de HDMI audio kiest.
« Laatst bewerkt op: 2015/07/15, 20:35:22 door jos34 »

Offline jos34

  • Lid
Re: Geluid standaard afspeel apparaat instellen.
« Reactie #7 Gepost op: 2015/07/15, 18:18:50 »
En alweer Hulde!!

En toch hoor deze topic in Andere distributies.

Geluid standaard afspeel apparaat instellen.

Nou eigenlijk ook weer niet want het standaard apparaat zal nog steeds verkeerd gekozen worden als ik de onboard audio weer aanzet.
Dat het uitschakelen van de onboard audio ook het gewenenste resultaat opleverde is weer een ander verhaal, maar het euvel van dat de verkeerde audio apparaat wordt gekozen is nog steeds aanwezig.