Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Update lukt niet  (gelezen 659 keer)

Offline peet2222

  • Lid
  • Steunpunt: Nee
Update lukt niet
« Gepost op: 2015/05/26, 09:38:31 »
Gebruik al geruime tijd Ubuntu 4.04 en update pakketen gingen altijd strak en probleemloos
Nu blijft de update elke keer staan en geeft aan mislukt en controleer internet. Ook via een vaste verbinding internet geen succes
Ook via 3G lukt het niet
Gaarne advies in deze

Peet
kwaliteit is toeval uitsluiten

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #1 Gepost op: 2015/05/26, 09:46:42 »
Ik neem aan dat je 14.04 bedoeld en niet 4.04 :)

Probeer eens via de console te updaten, misschien krijg je dan een iets nuttigere foutmelding.
Dus met
sudo apt-get update
sudo apt-get upgrade

En dan de uitkomst hier posten.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline peet2222

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #2 Gepost op: 2015/05/26, 14:13:36 »
Beide commando regels heb ik uitgevoerd. En is afgerond. Is het noodzakelijk om beide regels uit te voeren ?
Zie geen foutmeldingen
kwaliteit is toeval uitsluiten

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #3 Gepost op: 2015/05/26, 14:36:21 »
Ja, apt-get update ververst je pakketlijst en apt-get upgrade haalt de updates binnen.

Je kan ze ook in één regel samenvoegen en uitvoeren:

sudo apt-get update && sudo apt-get upgrade

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #4 Gepost op: 2015/05/26, 15:36:25 »
Als beide regels goed zijn gegaan: dan heb je zo juist succesvol geüpdate :)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline peet2222

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #5 Gepost op: 2015/05/26, 15:42:08 »
Met dank dan doe ik het voorlopig in de terminal mode

Peet
kwaliteit is toeval uitsluiten

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #6 Gepost op: 2015/05/26, 21:34:01 »
Femke, je schreef: 'Nu kan je via de terminal de volgend eodracht ingeven: up'
Er bestaat een kans dat terminal het bestand niet kan vinden, door het bestandje up naar terminal te slepen, kan terminal het pad naar het bestand wel vinden.  Het is maar een tip  ;)

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #7 Gepost op: 2015/05/27, 09:02:05 »
Citaat
Nou, dan heb je die regeltjes handmatig ook allang in de terminal gezet. ;) ;)
Dan moet je wel een zeer goed geheugen hebben  ;)

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #8 Gepost op: 2015/05/27, 16:38:20 »
Femke, je schreef: 'Nu kan je via de terminal de volgend eodracht ingeven: up'
Er bestaat een kans dat terminal het bestand niet kan vinden, door het bestandje up naar terminal te slepen, kan terminal het pad naar het bestand wel vinden.  Het is maar een tip  ;)
Als je het bestandje 'up' in /usr/local/bin zet, dan kan het altijd gevonden worden, want die map zit in het zoekpad. Open dan de terminal (maakt niet uit waar je staat) en type 'up' en off-we-go....

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #9 Gepost op: 2015/05/27, 19:24:49 »
Het hoeft dus niet per se in /usr/local/bin
De map bin verplaatst naar /usr/local/
Terminal geeft
r@r-SATELLITE-L50-B:~$ up
up: opdracht niet gevonden

Sleep ik up naar terminal en klik op enter:
[sudo] password for r:
Genegeerd http://extras.ubuntu.com trusty InRelease
Genegeerd http://nl.archive.ubuntu.com trusty InRelease                       
Ophalen:1 http://deb.opera.com stable InRelease [2590 B]                       
Genegeerd http://nl.archive.ubuntu.com trusty-updates InRelease               
Genegeerd http://nl.archive.ubuntu.com trusty-backports InRelease             
Geraakt http://extras.ubuntu.com trusty Release.gpg                           
Genegeerd http://dl.google.com stable InRelease                               
Genegeerd http://ppa.launchpad.net trusty InRelease                           
Genegeerd http://ppa.launchpad.net trusty InRelease                           
Genegeerd http://ppa.launchpad.net trusty InRelease                           
Geraakt http://nl.archive.ubuntu.com trusty Release.gpg                       
Geraakt http://extras.ubuntu.com trusty Release                               
Geraakt http://ppa.launchpad.net trusty Release.gpg                           
Geraakt http://dl.google.com stable Release.gpg                               
Ophalen:2 http://nl.archive.ubuntu.com trusty-updates Release.gpg [933 B]     
Ophalen:3 http://nl.archive.ubuntu.com trusty-backports Release.gpg [933 B]   
Geraakt http://ppa.launchpad.net trusty Release.gpg                           
Geraakt http://ppa.launchpad.net trusty Release.gpg                           
Geraakt http://nl.archive.ubuntu.com trusty Release                           
Geraakt http://dl.google.com stable Release                                   
Geraakt http://ppa.launchpad.net trusty Release                               
Genegeerd http://security.ubuntu.com trusty-security InRelease                 
Ophalen:4 http://nl.archive.ubuntu.com trusty-updates Release [63,5 kB]       
Geraakt http://ppa.launchpad.net trusty Release                               
Geraakt http://ppa.launchpad.net trusty Release                               
Ophalen:5 http://deb.opera.com stable/non-free amd64 Packages [1800 B]         
Ophalen:6 http://nl.archive.ubuntu.com trusty-backports Release [63,5 kB]     
Ophalen:7 http://security.ubuntu.com trusty-security Release.gpg [933 B]       
Ophalen:8 http://deb.opera.com stable/non-free i386 Packages [1442 B]         
Geraakt http://extras.ubuntu.com trusty/main Sources                           
Geraakt http://extras.ubuntu.com trusty/main amd64 Packages                   
Geraakt http://nl.archive.ubuntu.com trusty/main Sources                       
Geraakt http://nl.archive.ubuntu.com trusty/restricted Sources                 
Geraakt http://extras.ubuntu.com trusty/main i386 Packages                     
Geraakt http://nl.archive.ubuntu.com trusty/universe Sources                   
Geraakt http://dl.google.com stable/main amd64 Packages                       
Geraakt http://nl.archive.ubuntu.com trusty/multiverse Sources                 
Ophalen:9 http://security.ubuntu.com trusty-security Release [63,5 kB]         
Geraakt http://dl.google.com stable/main i386 Packages                         
Geraakt http://nl.archive.ubuntu.com trusty/main amd64 Packages               
Geraakt http://ppa.launchpad.net trusty/main amd64 Packages                   
Geraakt http://nl.archive.ubuntu.com trusty/restricted amd64 Packages         
Geraakt http://ppa.launchpad.net trusty/main i386 Packages                     
Geraakt http://nl.archive.ubuntu.com trusty/universe amd64 Packages           
Geraakt http://ppa.launchpad.net trusty/main Translation-en                   
Geraakt http://nl.archive.ubuntu.com trusty/multiverse amd64 Packages         
Geraakt http://nl.archive.ubuntu.com trusty/main i386 Packages                 
Geraakt http://ppa.launchpad.net trusty/main amd64 Packages                   
Genegeerd http://deb.opera.com stable/non-free Translation-nl_NL               
Genegeerd http://deb.opera.com stable/non-free Translation-nl                 
Geraakt http://nl.archive.ubuntu.com trusty/restricted i386 Packages           
Geraakt http://ppa.launchpad.net trusty/main i386 Packages                     
Genegeerd http://deb.opera.com stable/non-free Translation-en                 
Geraakt http://ppa.launchpad.net trusty/main Translation-en                   
Geraakt http://ppa.launchpad.net trusty/main amd64 Packages                   
Geraakt http://ppa.launchpad.net trusty/main i386 Packages                     
Geraakt http://nl.archive.ubuntu.com trusty/universe i386 Packages             
Geraakt http://nl.archive.ubuntu.com trusty/multiverse i386 Packages           
Geraakt http://ppa.launchpad.net trusty/main Translation-en                   
Geraakt http://nl.archive.ubuntu.com trusty/main Translation-nl               
Genegeerd http://extras.ubuntu.com trusty/main Translation-nl_NL               
Geraakt http://nl.archive.ubuntu.com trusty/main Translation-en               
Genegeerd http://extras.ubuntu.com trusty/main Translation-nl                 
Genegeerd http://extras.ubuntu.com trusty/main Translation-en                 
Geraakt http://nl.archive.ubuntu.com trusty/multiverse Translation-nl         
Geraakt http://nl.archive.ubuntu.com trusty/multiverse Translation-en         
Genegeerd http://dl.google.com stable/main Translation-nl_NL                   
Genegeerd http://dl.google.com stable/main Translation-nl                     
Geraakt http://nl.archive.ubuntu.com trusty/restricted Translation-nl         
Genegeerd http://dl.google.com stable/main Translation-en                     
Geraakt http://nl.archive.ubuntu.com trusty/restricted Translation-en         
Geraakt http://nl.archive.ubuntu.com trusty/universe Translation-nl           
Geraakt http://nl.archive.ubuntu.com trusty/universe Translation-en
Ophalen:10 http://security.ubuntu.com trusty-security/main Sources [81,9 kB]
Ophalen:11 http://nl.archive.ubuntu.com trusty-updates/main Sources [206 kB]   
Ophalen:12 http://nl.archive.ubuntu.com trusty-updates/restricted Sources [3433 B]
Ophalen:13 http://nl.archive.ubuntu.com trusty-updates/universe Sources [117 kB]
Ophalen:14 http://nl.archive.ubuntu.com trusty-updates/multiverse Sources [5152 B]
Ophalen:15 http://nl.archive.ubuntu.com trusty-updates/main amd64 Packages [525 kB]
Ophalen:16 http://security.ubuntu.com trusty-security/restricted Sources [2061 B]
Ophalen:17 http://nl.archive.ubuntu.com trusty-updates/restricted amd64 Packages [11,8 kB]
Ophalen:18 http://security.ubuntu.com trusty-security/universe Sources [25,2 kB]
Ophalen:19 http://nl.archive.ubuntu.com trusty-updates/universe amd64 Packages [281 kB]
Ophalen:20 http://nl.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [11,9 kB]
Ophalen:21 http://nl.archive.ubuntu.com trusty-updates/main i386 Packages [512 kB]
Ophalen:22 http://security.ubuntu.com trusty-security/multiverse Sources [2333 B]
Ophalen:23 http://nl.archive.ubuntu.com trusty-updates/restricted i386 Packages [11,8 kB]
Ophalen:24 http://nl.archive.ubuntu.com trusty-updates/universe i386 Packages [281 kB]
Ophalen:25 http://security.ubuntu.com trusty-security/main amd64 Packages [273 kB]
Ophalen:26 http://nl.archive.ubuntu.com trusty-updates/multiverse i386 Packages [12,1 kB]
Geraakt http://nl.archive.ubuntu.com trusty-updates/main Translation-en       
Geraakt http://nl.archive.ubuntu.com trusty-updates/multiverse Translation-en
Geraakt http://nl.archive.ubuntu.com trusty-updates/restricted Translation-en
Geraakt http://nl.archive.ubuntu.com trusty-updates/universe Translation-en   
Ophalen:27 http://nl.archive.ubuntu.com trusty-backports/main Sources [5851 B]
Ophalen:28 http://nl.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Ophalen:29 http://nl.archive.ubuntu.com trusty-backports/universe Sources [26,2 kB]
Ophalen:30 http://nl.archive.ubuntu.com trusty-backports/multiverse Sources [1898 B]
Ophalen:31 http://nl.archive.ubuntu.com trusty-backports/main amd64 Packages [6256 B]
Ophalen:32 http://nl.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Ophalen:33 http://nl.archive.ubuntu.com trusty-backports/universe amd64 Packages [29,9 kB]
Ophalen:34 http://nl.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1245 B]
Ophalen:35 http://nl.archive.ubuntu.com trusty-backports/main i386 Packages [6285 B]
Ophalen:36 http://nl.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Ophalen:37 http://nl.archive.ubuntu.com trusty-backports/universe i386 Packages [29,9 kB]
Ophalen:38 http://nl.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1249 B]
Geraakt http://nl.archive.ubuntu.com trusty-backports/main Translation-en     
Geraakt http://nl.archive.ubuntu.com trusty-backports/multiverse Translation-en
Geraakt http://nl.archive.ubuntu.com trusty-backports/restricted Translation-en
Geraakt http://nl.archive.ubuntu.com trusty-backports/universe Translation-en
Ophalen:39 http://security.ubuntu.com trusty-security/restricted amd64 Packages [8875 B]
Ophalen:40 http://security.ubuntu.com trusty-security/universe amd64 Packages [105 kB]
Genegeerd http://nl.archive.ubuntu.com trusty/main Translation-nl_NL           
Genegeerd http://nl.archive.ubuntu.com trusty/multiverse Translation-nl_NL     
Genegeerd http://nl.archive.ubuntu.com trusty/restricted Translation-nl_NL
Genegeerd http://nl.archive.ubuntu.com trusty/universe Translation-nl_NL
Ophalen:41 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [3681 B]
Ophalen:42 http://security.ubuntu.com trusty-security/main i386 Packages [261 kB]
Ophalen:43 http://security.ubuntu.com trusty-security/restricted i386 Packages [8846 B]
Ophalen:44 http://security.ubuntu.com trusty-security/universe i386 Packages [105 kB]
Ophalen:45 http://security.ubuntu.com trusty-security/multiverse i386 Packages [3840 B]
Geraakt http://security.ubuntu.com trusty-security/main Translation-en     
Geraakt http://security.ubuntu.com trusty-security/multiverse Translation-en
Geraakt http://security.ubuntu.com trusty-security/restricted Translation-en
Geraakt http://security.ubuntu.com trusty-security/universe Translation-en
3166 kB opgehaald in 5s (620 kB/s)                 
Pakketlijsten worden ingelezen... Klaar
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Opwaardering wordt doorgerekend... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Opwaardering wordt doorgerekend... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
r@r-SATELLITE-L50-B:~$ update
Opdracht ‘update’ niet gevonden, bedoelde u:
 Opdracht ‘uupdate’ uit pakket ‘devscripts’ (main)
 Opdracht ‘pupdate’ uit pakket ‘pbuilder-scripts’ (universe)
 Opdracht ‘lupdate’ uit pakket ‘qtchooser’ (main)
 Opdracht ‘xupdate’ uit pakket ‘libxml-xupdate-libxml-perl’ (universe)
update: opdracht niet gevonden
r@r-SATELLITE-L50-B:~$

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #10 Gepost op: 2015/05/27, 19:35:48 »
Het staat bij mij in de home en het wordt altijd gevonden. Heb nog nooit gehad dat het niet werd gevonden als ik "up" in de terminal zet.
Ooit van Ron (van hier ja!) over genomen en het werkt gewoon.
Het hoeft dus niet per se in /usr/local/bin
Dat komt omdat je als je terminal start, je automatisch in ~ (= home) komt te staan. Wissel je van map, dan werkt het niet meer. Bovendien moet je dan ./ ervoor tikken, dus ./up. Als je het in /usr/local/bin, werkt dat altijd, vanuit iedere map én hoef je nooit ./ ervoor te tikken.
(dus ja, het hoeft dus niet per se in /usr/local/bin, dat zei ik ook niet, maar het maakt het leven wel makkelijker)

Correctie: ik zie dat je (femke98) aanraadt om het bestand in ~/Bin te zetten. Maar dan klopt het bovenstaande niet en zul je dus altijd (in de terminal) naar ~/Bin moeten gaan (= weer een extra stap) omdat die map niet in het zoekpad zit. Het is overigens aan  te raden om geen hoofdletters te gebruiken in je (technische) bestandsstructuur (= common practice).

Het hoeft dus niet per se in /usr/local/bin
De map bin verplaatst naar /usr/local/
Terminal geeft
r@r-SATELLITE-L50-B:~$ up
up: opdracht niet gevonden
Het pad  /usr/local/  zit niet in het zoekpad.  En /usr/local/bin, die dus juist wél. Je kunt je zoekpad onderzoeken met:

echo $PATH
Wederom correctie: ik zie dat je (RikRik) de map bin verplaatst hebt naar /usr/local. Dat kan alleen maar goed gaan als de map /usr/local/bin nog niet zou bestaan. Aangezien dat wel het geval is, kun je theoretisch de map bin verplaatsen naar /usr/local. Controleer anders de inhoud van /usr/local/bin eens met
ls -laDan zie je of dat bestand er staat én of deze executable is.
« Laatst bewerkt op: 2015/05/27, 19:59:50 door markba »

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #11 Gepost op: 2015/05/27, 19:47:58 »
Heb even de tip van Markba getest hier op Debian 8 , en dat werkt perfect door het bestandje in usr/local/bin  te plaatsen.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #12 Gepost op: 2015/05/27, 20:00:28 »
Het lukt niet op m'n Ubuntu 14.04 pc.
het bestandje up kan ik plaatsten waar ik wil, terminal kan niets met de opdracht up.
r@r-SATELLITE-L50-B:/usr/local/bin$ ls -la
totaal 8
drwxr-xr-x  2 root root 4096 feb 18 20:33 .
drwxr-xr-x 10 root root 4096 feb 18 20:33 ..
r@r-SATELLITE-L50-B:/usr/local/bin$

Als ik up naar terminal sleep en druk op enter gaat het wel goed:
r@r-SATELLITE-L50-B:/usr/local/bin$ '/home/r/.local/bin/up'
[sudo] password for r:

« Laatst bewerkt op: 2015/05/27, 20:17:18 door RikRik »

Offline Mustangman1966

  • Lid
    • rickvandevoort
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #13 Gepost op: 2015/05/27, 20:40:02 »
Weet iemand hoe je er een script van kan maken, dat alles automatisch gaat, zodra je Ubuntu start dat het  script gaat lopen?
Ubuntugnome 16.04 pc, Xubuntu 16.04 laptop HP 530 en Ubuntu Server 16.04
https://mustangman1966.serverthuis.nl/wordpress

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #14 Gepost op: 2015/05/27, 21:39:22 »
Het lukt niet op m'n Ubuntu 14.04 pc.
het bestandje up kan ik plaatsten waar ik wil, terminal kan niets met de opdracht up.
....
Volgende aanpak moet lukken:
- Open Gedit en kopieer en plak dat bestandje van femke 98 en sla het voorlopig gewoon op ergens in je homemap met de naam 'up' /  (lees ook de hulp van femke 98)
- Klik rechts op dat bestandje 'up', ga naar 'eigenschappen'  en vink aan dat de computer het uit mag voeren (onder rechten ) 'toestaan dat bestand wordt uitgevoerd als programma' (daar zet je dat vinkje aan) ./
- Druk te samen Alt + F2 en typ gksudo nautilus  in het veld (ww vereist) . (conditie is dat gksu geïnstalleerd is)
- Ga nu als root naar usr/local/bin en kopieer en plak het bestandje 'up' in deze map  (daarna gewoon alle vensters sluiten)
- Open een terminal en typ  up  en dan zou je een werkend systeem moeten hebben.

Net gedaan met nog een ander bestandje en dat werkt perfect.
joris@Joris:~$ up
[sudo] password for joris:
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie InRelease
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie Release.gpg
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie Release
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie/contrib i386 Packages/DiffIndex
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie/main i386 Packages/DiffIndex
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie/non-free i386 Packages/DiffIndex
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie/contrib Translation-nl_BE
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150426-20:04] jessie/contrib Translation-nl
Genegeerd cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INS ............... enzovoort ...........
« Laatst bewerkt op: 2015/05/27, 21:45:55 door Joshua Orbit »
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #15 Gepost op: 2015/05/27, 21:48:19 »
Weet iemand hoe je er een script van kan maken, dat alles automatisch gaat, zodra je Ubuntu start dat het  script gaat lopen?

Daarvoor kan je best even een nieuw Topic openen met die vraag; we gaan anders héél erg off-topic ............. ;)
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #16 Gepost op: 2015/05/27, 22:06:17 »
@Joris,
Citaat
- Druk te samen Alt + F2 en typ gksudo nautilus  in het veld (ww vereist) . (conditie is dat gksu geïnstalleerd is)
- Ga nu als root naar usr/local/bin en kopieer en plak het bestandje 'up' in deze map  (daarna gewoon alle vensters sluiten)

Super, nu werkt up helemaal perfect!!
Hartelijk bedankt voor je hulp!!

En Femke natuurlijk ook bedankt :-)
« Laatst bewerkt op: 2015/05/27, 22:10:09 door RikRik »

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #17 Gepost op: 2015/05/28, 16:09:34 »
Het lukt niet op m'n Ubuntu 14.04 pc.
het bestandje up kan ik plaatsten waar ik wil, terminal kan niets met de opdracht up.
....
Volgende aanpak moet lukken:
- Open Gedit en kopieer en plak dat bestandje van femke 98 en sla het voorlopig gewoon op ergens in je homemap met de naam 'up' /  (lees ook de hulp van femke 98)
- Klik rechts op dat bestandje 'up', ga naar 'eigenschappen'  en vink aan dat de computer het uit mag voeren (onder rechten ) 'toestaan dat bestand wordt uitgevoerd als programma' (daar zet je dat vinkje aan) ./
- Druk te samen Alt + F2 en typ gksudo nautilus  in het veld (ww vereist) . (conditie is dat gksu geïnstalleerd is)
- Ga nu als root naar usr/local/bin en kopieer en plak het bestandje 'up' in deze map  (daarna gewoon alle vensters sluiten)
- Open een terminal en typ  up  en dan zou je een werkend systeem moeten hebben.
Kijk, zo komen we ergens. Nog een kleine toevoeging: als je het zojuist aangemaakte bestandje up in /usr/local/bin/ zou willen aanpassen, dan kan dat alleen met root-rechten. Zoiets dus:
sudo nano /usr/local/bin/up

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #18 Gepost op: 2015/05/28, 19:15:07 »
mag ik toch nu wel opmerken dat jullie het weer lekker moeilijk maken? Alsof het altijd maar op een andere manier moet dan iemand anders als tip aangeeft.
Mijn tip is gewoon de simpelste manier, en daarom gaf ik die.
Alleen met de extra aanvulling van Joris werkt het op mijn pc.... dus, het is beslist niet een kwestie van je methode lekker moeilijk maken.
En het is ook niet een kwestie van een voorschriftdyslexie, zoiets kan ik mij beroepsmatig niet eens veroorloven, je methode werkt blijkbaar niet op elke Linuxconfiguratie.

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #19 Gepost op: 2015/05/28, 19:23:21 »
Moderator input: het is mede daardoor dat we het maken en toepassen van scripts niet aanmoedigen, het is voer voor vele discussies en werkmethoden etc. In dit voorbeeld is eigenlijk gewoon een update-scriptje gemaakt (onschuldig dus) maar onthou ook dat er scripts zijn die een pak nadeliger kunnen werken.  Op eigen risico te proberen en toe te passen.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Update lukt niet
« Reactie #20 Gepost op: 2015/05/28, 20:11:33 »
Het hoeft dus niet per se in /usr/local/bin
Klopt. Zelfgemaakte scripts kan je in Ubuntu (zonder root rechten) plaatsen in /home/gebruikersnaam/bin (is deze map er nog niet kan je deze aanmaken met mkdir en opnieuw aanmelden om de map in het zoekpad op te laten nemen).

Goede gewoonte, zo beperk je het gebruik van sudo (gebruikt het script een sudo-opdracht, zal bij de uitvoering alsnog om het sudo wachtwoord worden gevraagd).
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: Update lukt niet
« Reactie #21 Gepost op: 2015/05/28, 23:16:28 »
Goede gewoonte, zo beperk je het gebruik van sudo (gebruikt het script een sudo-opdracht, zal bij de uitvoering alsnog om het sudo wachtwoord worden gevraagd).
Dit is niet afhankelijk van de locatie: als het script een sudo-opdracht bevat, dan wordt sowieso het wachtwoord gevraagd, of deze nu in usr/local/bin staat of in ~/bin.

Citaat
opnieuw aanmelden om de map in het zoekpad op te laten nemen)
Dat uitbreiden van het zoekpad gaat natuurlijk niet automatisch, daar zul je iets voor moeten doen:
http://askubuntu.com/questions/60218/how-to-add-a-directory-to-my-path