Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Creative Soundblaster X-Fi HD  (gelezen 709 keer)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Creative Soundblaster X-Fi HD
« Gepost op: 2015/05/19, 22:37:43 »
os= Xubuntu 14.04

Ik overweeg om de externe geluidskaart Creative Soundblaster X-Fi HD aan te schaffen. Heb qua compatibility even wat rondgeneusd op internet en er lijken over het algemeen geen problemen te zijn met de analoge outputs, maar bv wel met de SPDIF.

Voor ik tot daadwerkelijke aanschaf overga ..... is er toevallig iemand die deze kaart heeft en zo ja, werkt hij goed onder 14.04? Thx!
Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #1 Gepost op: 2015/05/21, 20:19:01 »
Inmiddels heb ik de kaart aangeschaft en analoge out- en inputs en headphone werken out-of-the-box prima (fenomenaal geluid en geen ruis!), echter de poorten voor de mic en de digitale in- en uitgang worden niet weergegeven in Pulseaudio.
 
Ik ben nu al een paar uur naar de oplossing aan het zoeken op internet en heb oa libasound2-plugins-extra geinstalleerd (werkt niet), maar ik kom er niet achter hoe voornoemde poorten geactiveerd te krijgen.

Heeft iemand een idee?
Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #2 Gepost op: 2015/05/22, 20:42:13 »
Iemand toevallig?
Een boek doet het altijd...

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #3 Gepost op: 2015/05/22, 21:20:41 »
voer in de terminal uit
pavucontrol
indien niet geinstalleerd:
sudo apt-get install pavucontrol
daarna pavucontrol uitvoeren en de instellingen maken in tab "invoerapparaten".

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #4 Gepost op: 2015/05/23, 23:36:28 »
Die instellingen had ik reeds gecheckt, echter onder de tab 'input devices' tref ik bij 'port' enkel 'analog input' aan en geen 'microphone'.

Ik ben weer een paar uur aan het zoeken geweest op internet naar een oplossing voor het niet verschijnen van de microphone onder de 'input devices', maar de oorzaak noch oplossing is te vinden. Is dit een bug of zo? Ik zal toch niet de enige zijn die hiertegen aanloopt?
« Laatst bewerkt op: 2015/05/24, 00:25:19 door kfboerne »
Een boek doet het altijd...

Offline staf

  • Lid
Re: Creative Soundblaster X-Fi HD
« Reactie #5 Gepost op: 2015/05/24, 09:28:25 »
Ik heb wel een PCI- versie. Ziet er zo uit:

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #6 Gepost op: 2015/05/24, 09:39:31 »
De microfoon zul je in Ubuntu' Geluidsinstellingen tabblad Invoer alleen kunnen zien, wanneer deze daadwerkelijk in de roze microfooningang is ingeplugd. Je zou eventueel ook een USB microfoon, of een USB webcam hebt met ingebouwde microfoon kunnen gebruiken. Bijvoorbeeld mijn Logitech Webcam C170 wordt op tabblad Invoer getoond, als Analoge invoer Webcam C170.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #7 Gepost op: 2015/05/24, 23:57:28 »
@jolo : het gekke is dat de Sennheiser microphone met jack-plug (zo een is het namelijk dus geen usb mic) wel gewoon werd herkend door m'n oude externe geluidskaart (Creative SB mp3+) en er prima onder werkte. Zonder dat ik m'n mic had ingeplugd overigens gaf Pulseaudio  aan dat er sprake was van een mic-ingang. Op de een of andere manier herkens de X-Fi HD dus blijkbaar de mic (en digitale!) poort(en) niet.

Zou het niet zo zijn dat ik aanvullende software moet installeren? Dat idee heb ik namelijk. Alleen welke software weet ik niet. Ik heb in Synaptic al grondig zitten te neuzen of ik iets kan vinden, maar het is toch een beetje zoeken naar de bekende speld...

( opm :Omdat de Sennheiser mic van zeer goede kwaliteit is, wil ik die het liefst gebruiken en dus geen usb mic).

Nog even aanvullend : ik heb net een usb-webcam ingeplugd en daarvan wordt de mic WEL direct herkend en dienovereenkomstig weergegeven.
« Laatst bewerkt op: 2015/05/25, 00:04:21 door kfboerne »
Een boek doet het altijd...

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #8 Gepost op: 2015/05/25, 07:55:37 »
Herkennen is waarschijnlijk bij de jack-plug microfoon niet het juiste woord. Want dat is niet plug en play. In deze Wikipedia Phone connector (audio) wordt getoond dat het fysiek inpluggen van de microfoonplug een schakelaar omschakelt. Werkt dit dan wel in Windows, want de microfooningang zou wellicht defect kunnen zijn.   

De Creative Soundblaster X-Fi HD zou zonder extra drivers te installeren, behoren te werken met Ubuntu. Dat was blijkbaar al het geval met Ubuntu 11.04 lees ik in Ask Ubuntu. Echter zou je, met de externe geluidskaart ingeplugd, voor alle zekerheid de output kunnen posten van
   aplay -l
 
[Enter]

en

   aplay -L
 
[Enter]

Dus de aplay commando zowel met de kleine letter en hoofdletter L. Een andere output die je zou kunnen posten is
  dmesg | grep sound
 
[Enter]
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #9 Gepost op: 2015/05/26, 19:01:57 »
Hierbij de output van :

aplay -l >
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HD [USB Sound Blaster HD], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HD [USB Sound Blaster HD], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HD [USB Sound Blaster HD], device 2: USB Audio [USB Audio #2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L >
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    HDMI Audio Output
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample snooping device
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
sysdefault:CARD=HD
    USB Sound Blaster HD, USB Audio
    Default Audio Device
front:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    Front speakers
surround40:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    Direct sample mixing device
dmix:CARD=HD,DEV=1
    USB Sound Blaster HD, USB Audio #1
    Direct sample mixing device
dmix:CARD=HD,DEV=2
    USB Sound Blaster HD, USB Audio #2
    Direct sample mixing device
dsnoop:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    Direct sample snooping device
dsnoop:CARD=HD,DEV=1
    USB Sound Blaster HD, USB Audio #1
    Direct sample snooping device
dsnoop:CARD=HD,DEV=2
    USB Sound Blaster HD, USB Audio #2
    Direct sample snooping device
hw:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    Direct hardware device without any conversions
hw:CARD=HD,DEV=1
    USB Sound Blaster HD, USB Audio #1
    Direct hardware device without any conversions
hw:CARD=HD,DEV=2
    USB Sound Blaster HD, USB Audio #2
    Direct hardware device without any conversions
plughw:CARD=HD,DEV=0
    USB Sound Blaster HD, USB Audio
    Hardware device with all software conversions
plughw:CARD=HD,DEV=1
    USB Sound Blaster HD, USB Audio #1
    Hardware device with all software conversions
plughw:CARD=HD,DEV=2
    USB Sound Blaster HD, USB Audio #2
    Hardware device with all software conversions

dmesg | grep sound >
[    2.181608] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input6
[    2.181680] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input7
[    2.181722] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input8
[    2.181762] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input9

Weet niet of het belangrijk is, maar ik heb de INTERNE geluidskaart (GF108 High Definition Audio Controller) via Pulseaudio uitgeschakeld door het profiel op 'Off' te zetten. Ik heb deze kaart dus niet in het BIOS uitgeschakeld.

Overigens had ik de Sennheiser mic bij mijn oude externe geluidskaart aangesloten via een verloopje dat van jack-plug naar 3,5mm-plug(je) liep. De X-Fi HD heeft enkel jack-aansluitingen en geen 3,5mm, waardoor het verloopstekkertje dus niet meer nodig is.

Hoop dat je wat met deze info kunt...
 
« Laatst bewerkt op: 2015/05/28, 12:56:47 door TopGear »
Een boek doet het altijd...

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #10 Gepost op: 2015/05/26, 21:08:43 »
Ofschoon het beter is een niet gebruikte onboard geluidskaart in het BIOS uit te schakelen, zouden er ook twee geluidskaarten actief kunnen zijn. In je output zie ik inderdaad twee geluidskaarten actief. Het is me overigens niet duidelijk wat je bedoelt met het uitschakelen via Pulseaudio. Ik ken alleen het blacklisten van de module/driver naam van één van de geluidskaarten. Zie je nu ook in  Geluidsinstellingen bij tabblad Invoer en uitvoer twee keer Poort staan. 

Want dat is wel het geval als ik op één van mijn oude pc's (ongeveer uit het jaar 2001) met een PCI geluidskaart, de onboard geluidskaart in het BIOS inschakel. Zoals te zien is, op onderstaande afbeelding.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #11 Gepost op: 2015/05/27, 15:49:04 »
Nee, er wordt op de tabs 'input devices' en 'output devices' enkel de port 'Analog Input' en 'Analog Output' vermeldt' en verder niets.  Ook de DIGITALE in- en outputs worden nergens vermeld.

Met het uitschakelen via Pulseaudio bedoel ik dat ik op de Configuratietab van de Geluidsinstellingen het profiel van de interne geluidskaart op 'Off' heb ingesteld. Ik heb die interne geluidskaart niet nodig omdat ik de externe enkel wil gebruiken. Veel betere geluidskwaliteit.
Een boek doet het altijd...

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #12 Gepost op: 2015/05/27, 16:38:53 »
Opmerking vooraf: Beide zaken kan ik niet goed op waarde schatten.

1  -  Hierbij de officiele - recente - ubuntu-wiki voor geluidsproblemen : https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Ik lees daar de volgende waarschuwing :
Citaat
Please exercise caution when running these commands! Carefully read and understand what they do. For instance, the  sudo apt-get install  command includes the entire Ubuntu desktop. This will likely create problems for users of the other flavors of Ubuntu -- a Kubuntu user would not want the Unity interface installed. While the outcome of running the suggested command string below may indeed fix certain sound problems, be aware that it is a very blunt approach and could result in unintended consequences.

In normaal nederlands:
de voorgestelde methode kan sommige problemen verhelpen, maar kan leiden tot onbedoelde gevolgen.



2   -  Daarnaast vind ik een aangepaste alsa-driver in de vorm van een PPA uit maart 2012:
    http://askubuntu.com/questions/90230/there-is-no-connector-analog-line-in-on-the-input-tab-of-sound-preferences

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #13 Gepost op: 2015/05/27, 17:27:36 »
Andere suggestie:
  Zit er op het toetsenbord een switch voor het aan/uitzetten van de microfoon ?

Zie ook:  http://askubuntu.com/questions/12100/keyboard-shortcut-command-to-mute-unmute-microphone

En met de terminal kan de microfoon
1 - aangezet worden
amixer set Capture cap
2 - uitgezet worden
amixer set Capture nocap
3 - alle actuele waarden kunnen worden uitgelezen met
amixer

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #14 Gepost op: 2015/05/28, 12:56:15 »
EZ-man bedankt voor je reacties!

Ik heb het nodige uitgeprobeerd met inachtneming van flink wat voorzichtigheid, maar helaas het heeft niet mogen helpen.  Heb de indruk dat 'we' hier niet uit gaan komen op korte termijn. Jammer, maar geen man overboord. De X-fi HD doet de voor mij belangrijkste taken prima (analog output + headphones) dus misschien moeten we het hier voorlopig maar even bij laten. Tenzij iemand zich graag in dit probleem vastbijt en alsnog de oplossing vindt. Dus wie weet 'to be continued'? ;)

 
Een boek doet het altijd...

Offline Erik Meulman

  • Lid
    • http://www.de-meulies.nl
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #15 Gepost op: 2015/05/28, 13:25:16 »

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #16 Gepost op: 2015/05/28, 14:06:59 »
@Erik Meulman :  mooi zoekresultaat. Mijn enige kanttekening: Ik hoop dat het lukt. kfboerne heeft een PCI-versie, terwijl de oplossingen in de bug-report spreken over de usb variant.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Creative Soundblaster X-Fi HD
« Reactie #17 Gepost op: 2015/05/28, 14:50:56 »
Ik heb geen PCI variant hoor. De X-Fi HD is een externe USB geluidskaart.


Oeps, vrij pittig de link van Erik Meulman. Begrijp ik het goed dat ik het volgende moet wijzigen :

1) Deze regel toevoegen aan /etc/pulse/default.pa en PulseAudio herstarten :

load-module module-alsa-sink device=hw:0,1

Waar in het bestand moet ik deze regel precies toevoegen? Helemaal onderaan?

2) Wijzigen van /usr/share/alsa/cards/USB-Audio.conf naar dit :

USB-Audio.pcm.iec958_device { "USB Sound Blaster HD" 1 }

LET OP : ik krijg deze melding inzake USB-Audio.conf :

#  USB-Audio.conf - configuration for USB Audio devices
#
#
#  DO NO EDIT; this is an internal ALSA file.
#  If you want to add your own definitions, put them into /etc/asound.conf or
#  ~/.asoundrc, with "cards." before the "USB-Audio", e.g.:
#
#  cards.USB-Audio.pcm.use_dmix."NoiseBlaster 3000" no
#
#  If your device requires such a definition to work correctly, please report it
#  to <alsa-devel@alsa-project.org>.

Het zou prettig zijn wanneer iemand mij precies zou kunnen aangeven hoe en wat te wijzigen in de voornoemde bestanden, want ik vind dit nogal ingewikkeld en ben bang dat wanneer ik zelf ga lopen 'prutsen' het middel straks erger is dan de kwaal...Alvast bedankt!





« Laatst bewerkt op: 2015/05/28, 15:26:23 door kfboerne »
Een boek doet het altijd...