Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem met nouveau driver  (gelezen 795 keer)

Offline fienie

  • Lid
probleem met nouveau driver
« Gepost op: 2015/05/17, 16:12:22 »
Ik heb mijn nvidia driver 304.125 gedeinstalleerd vanwege, waarschijnlijk door update, plotselinge vertraging in de opstart van ubuntu 14.04.02 naar uiteindelijk slecht  uitziend en onhandelbaar scherm.
Nu verder met de nouveau driver waarmee het wel werkt maar mis daarin mijn 1280 resolutie. Hoe krijg ik die daarin?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #1 Gepost op: 2015/05/17, 16:17:07 »
Eerst eens even kijken wat voor vlees we in de kuip hebben:
https://sites.google.com/site/computertip/samsung-n150

Post de uitkomst hier.

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #2 Gepost op: 2015/05/17, 16:30:37 »
System:    Host: jos-A6JC Kernel: 3.13.0-52-generic i686 (32 bit) Desktop: Gnome Distro: Ubuntu 14.04 trusty
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty main restricted
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty universe
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates universe
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty multiverse
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
           deb http://nl.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu trusty-security main restricted
           deb http://security.ubuntu.com/ubuntu trusty-security universe
           deb http://security.ubuntu.com/ubuntu trusty-security multiverse
           deb http://extras.ubuntu.com/ubuntu trusty main
           deb-src http://extras.ubuntu.com/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/team-xbmc-ppa-trusty.list
           deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-x-swat-x-updates-trusty.list
           deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu trusty main

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #3 Gepost op: 2015/05/17, 16:31:54 »
Doe ik het goed?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #4 Gepost op: 2015/05/17, 16:33:22 »
Nee..... inxi -Fxz

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #5 Gepost op: 2015/05/17, 16:33:48 »
System:    Host: jos-A6JC Kernel: 3.13.0-52-generic i686 (32 bit, gcc: 4.8.2) Desktop: Gnome Distro: Ubuntu 14.04 trusty
Machine:   System: ASUSTeK (portable) product: A6JC version: 1.0
           Mobo: ASUSTeK model: A6JC version: 1.0 Bios: American Megatrends version: A6JCMAS.216 date: 05/10/2006
CPU:       Dual core Intel CPU T2300 (-MCP-) cache: 2048 KB flags: (nx pae sse sse2 sse3) bmips: 6649.64
           Clock Speeds: 1: 996.00 MHz 2: 996.00 MHz
Graphics:  Card: NVIDIA G72M [Quadro NVS 110M/GeForce Go 7300] bus-ID: 01:00.0
           X.Org: 1.15.1 drivers: vesa FAILED: fbdev,nouveau Resolution: 1024x768@0.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits) GLX Version: 2.1 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-52-generic
Network:   Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection driver: iwl3945 ver: in-tree:s bus-ID: 03:00.0
           IF: wlan0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 ver: 2.3LK-NAPI port: c800 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 116.1GB (38.0% used) 1: id: /dev/sda model: HTS541010G9AT00 size: 100.0GB temp: 48C
           2: id: /dev/sdb model: Name n/a size: 16.0GB temp: 0C
Partition: ID: / size: 38G used: 34G (94%) fs: ext4 ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 67.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 212 Uptime: 57 min Memory: 735.8/2015.7MB Runlevel: 2 Gcc sys: 4.8.2
           Client: Shell (bash 4.3.11) inxi: 1.9.17

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #6 Gepost op: 2015/05/17, 16:37:23 »
OK.... Probeer dit eens:
sudo apt-get install nvidia-173
Herstart daarna je computer en geef opnieuw de uitvoer van inxi.

---Aanvulling: je harde schijf is trouwens veel en veel te vol. Een Linuxpartitie moet minimaal 20-25 % vrije ruimte overhouden, anders krijg je enorme bestandfragmentatie en dus grote vertragingen.
« Laatst bewerkt op: 2015/05/17, 16:41:31 door Pjotr »

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #7 Gepost op: 2015/05/17, 16:44:23 »
System:    Host: jos-A6JC Kernel: 3.13.0-52-generic i686 (32 bit, gcc: 4.8.2) Desktop: Gnome Distro: Ubuntu 14.04 trusty
Machine:   System: ASUSTeK (portable) product: A6JC version: 1.0
           Mobo: ASUSTeK model: A6JC version: 1.0 Bios: American Megatrends version: A6JCMAS.216 date: 05/10/2006
CPU:       Dual core Intel CPU T2300 (-MCP-) cache: 2048 KB flags: (nx pae sse sse2 sse3) bmips: 6649.64
           Clock Speeds: 1: 996.00 MHz 2: 996.00 MHz
Graphics:  Card: NVIDIA G72M [Quadro NVS 110M/GeForce Go 7300] bus-ID: 01:00.0
           X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1280x800@50.0hz
           GLX Renderer: GeForce Go 7300/PCI/SSE2 GLX Version: 2.1.2 NVIDIA 173.14.39 Direct Rendering: Yes
Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-52-generic
Network:   Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection driver: iwl3945 ver: in-tree:s bus-ID: 03:00.0
           IF: wlan0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 ver: 2.3LK-NAPI port: c800 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 116.1GB (38.1% used) 1: id: /dev/sda model: HTS541010G9AT00 size: 100.0GB
           2: id: /dev/sdb model: Name n/a size: 16.0GB
Partition: ID: / size: 38G used: 34G (94%) fs: ext4 ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A gpu: 0.0:
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 213 Uptime: 1:08 Memory: 633.4/2015.7MB Runlevel: 2 Gcc sys: 4.8.2
           Client: Shell (bash 4.3.11) inxi: 1.9.17


Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #8 Gepost op: 2015/05/17, 16:46:23 »
Alles doet het weer! Waarom die 173 ipv de aanbevolen 304.125?

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #9 Gepost op: 2015/05/17, 16:48:14 »
Denk je dat ik voor ubuntu nog ruimte kan creeren met gparted?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #10 Gepost op: 2015/05/17, 16:51:02 »
Nou, probleem opgelost, hoop ik.... Ziet er goed uit. =D

Oude apparatuur draait soms beter op oude stuurprogramma's, ook al beweert 't nieuwe stuurprogramma dat 't het oude apparaat ook ondersteunt.

GParted: nee, in dit geval niet. Gooi een wat films e.d. weg, en doe verdere schoonmaak zo:
https://sites.google.com/site/computertip/schoon

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #11 Gepost op: 2015/05/17, 16:53:24 »
Pjotr je bent een kei, hartstikke bedankt!

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #12 Gepost op: 2015/05/17, 18:13:57 »
P.s Alleen vind hij mn tv en externe monitor niet.? Daar nog een trucje voor? :rolleyes:

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #13 Gepost op: 2015/05/17, 18:18:06 »
Hopelijk kun je hier iets mee:
sudo apt-get install nvidia-settings
Start vervolgens nvidia-settings vanuit het menu (of in de terminal: nvidia-settings) en experimenteer eens wat.....
« Laatst bewerkt op: 2015/05/17, 18:20:38 door Pjotr »

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #14 Gepost op: 2015/05/17, 18:27:25 »
nvidiasettings lijkt geinstalleerd maar start niet op: sudo apt-get install nvidia-settings
[sudo] password for jos:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
nvidia-settings is al de nieuwste versie.
Het volgende pakket is automatisch geïnstalleerd en is niet langer nodig:
  libcuda1-304
Use 'apt-get autoremove' to remove it.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 7 niet opgewaardeerd.
jos@jos-A6JC:~$ apt-get autoremove libcudal-304
E: Kon het vergrendelingsbestand '/var/lib/dpkg/lock' niet openen - open (13: Toegang geweigerd)
E: Kan de beheersmap (/var/lib/dpkg/) niet vergrendelen. Heeft u beheerdersrechten?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #15 Gepost op: 2015/05/17, 19:06:38 »
In de terminal:
nvidia-settings

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #16 Gepost op: 2015/05/17, 19:26:28 »
ERROR: Error querying target relations


ERROR: Error querying target relations


ERROR: Error querying target relations


ERROR: Error querying target relations


ERROR: Error querying target relations

The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 59 error_code 1 request_code 158 minor_code 29)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
jos@jos-A6JC:~$


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #17 Gepost op: 2015/05/17, 19:48:00 »
nvidia-settings gaat 'm niet worden, vrees ik....

Als je als zoekterm "scherm" gebruikt in de Snelzoeker, kun je dan iets met de beeldscherminstellingen?

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #18 Gepost op: 2015/05/17, 19:53:31 »
Ik krijg alleen het ingebouwde scherm met de juiste 1280 resolutie. Iets met die nouveau driver is geen optie?

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #19 Gepost op: 2015/05/17, 19:55:18 »
Het rare is dat de 304.125 tot voor 3 dagen geleden altijd zonder problemen heeft gewerkt.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #20 Gepost op: 2015/05/17, 20:20:09 »
Zou je dan met je externe monitor ingeplugd, de output kunnen posten van het terminalcommando
xrandr [Enter]

Als je Arandr installeert kun je daarmee wellicht je  externe monitor activeren. Zie daarover deze Engelstalige hyperlink https://help.ubuntu.com/community/Lubuntu/MultiDisplay
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: probleem met nouveau driver
« Reactie #21 Gepost op: 2015/05/17, 20:24:03 »
Het rare is dat de 304.125 tot voor 3 dagen geleden altijd zonder problemen heeft gewerkt.
Fienie,

Misschien iets te ver gezocht ...
Maar heb je al geprobeerd de nvidia-173 en nvidia-304 te 'purgen'.
Maw, geheel de-installeren inclusief de configuratie bestanden.
sudo apt-get purge nvidia-xxx

Dan opnieuw de nvidia-304 installeren.
MvG,
MauRice
Registered Linux user: 473556

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #22 Gepost op: 2015/05/17, 20:27:14 »
jos@jos-A6JC:~$  xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1280 x 800, maximum 1280 x 800
default connected primary 1280x800+0+0 0mm x 0mm
   1280x800       50.0*
   1024x768       51.0 
   840x525        52.0 
   800x600        53.0 
   800x512        54.0 
   720x450        55.0 
   680x384        56.0     57.0 
   640x512        58.0 
   640x480        59.0     60.0 
   576x432        61.0 
   512x384        62.0 
   400x300        63.0 
   320x240        64.0 

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #23 Gepost op: 2015/05/17, 20:28:31 »
Puge had ik al uitgevoerd zonder result.

Offline fienie

  • Lid
Re: probleem met nouveau driver
« Reactie #24 Gepost op: 2015/05/17, 20:36:13 »
als ik mn laptop  aanzet heb ik tot aan het inlog/wachtwoorscherm v ubuntu  beeld op mn tv, daarna geen signaal en kom hem ook niet tegen bij de beeldscherminstellingen.