Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: kernel crash  (gelezen 610 keer)

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
kernel crash
« Gepost op: 2015/05/08, 19:11:08 »
Linux Mint 17.1 Cinnamon...gisteren crashte mijn computer en ik kan hem niet meer met de laatste kernel (3.13.0.40) opstarten, wel met de vorige (3.13.0.37).
Wat moet ik doen om weer met de nieuwste kernel te kunnen opstarten. Ik heb geen idee wat de oorzaak is geweest, want ik was gewoon aan het werk.

Graag jullie advies.

groet,
Bertha

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: kernel crash
« Reactie #1 Gepost op: 2015/05/08, 19:19:17 »
Allereerst: 3.13.0-40 is niet de nieuwste kernel binnen de 3.13-reeks.

Waarom wil je een nieuwere kernel dan de 3.13.0-37? Voldoet die niet?

Het principe bij Mint is: blijf bij je kernel, tenzij er een duidelijke aanleiding is om een nieuwere te installeren. Bijvoorbeeld omdat een bepaald apparaat het anders niet doet.

Zelfs veiligheids-updates voor de kernel, zijn doorgaans voor thuisgebruik als bureaucomputer, niet of nauwelijks van praktisch belang.
« Laatst bewerkt op: 2015/05/08, 19:21:12 door Pjotr »

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: kernel crash
« Reactie #2 Gepost op: 2015/05/08, 19:22:09 »
Via Synaptic de probleemkernel verwijderen en vervolgens in updatebeheer de niveau's 4 en 5 afvinken (dus geen updates van die niveau's installeren wat standaard was ingesteld) .

Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #3 Gepost op: 2015/05/08, 22:23:12 »
Bedankt voor jullie reactie. Ik weet niet hoe ik die nieuwe kernels krijg...komen ze niet gewoon met de updates binnen?
In ieder geval krijg ik versie 40 niet verwijderd, althans niet volledig. Deze foutmelding krijg ik, als ik de updatemanger  p[robeer te updaten:

E: linux-image-extra-3.13.0-40-generic: subproces installed post-removal script gaf een foutwaarde 1 terug
E: linux-image-3.13.0-40-generic: subproces installed post-removal script gaf een foutwaarde 1 terug

Bij het opstarten van de computer krijg ik over deze kernel ook een foutmelding.

De niveaus 4  en 5 heb ik nu uitgevinkt, hoewel ik meen dat op de site van Pjotr staat dat deze wel aangevinkt kunnen zijn.

Ik hoop dat jullie hier nog iets mee kunnen.

gr. Bertha
 

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #4 Gepost op: 2015/05/09, 14:44:50 »
Ik heb deze kernel:

Linux 3.13.0-40-generic #69-Ubuntu SMP Thu Nov 13 17:53:56 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

En deze is inderdaad niet de nieuwste. In Mint kan je nu zelf nieuwe kernels installeren. Voorheen kwamen ze met niveau 4 4n 5 mee, maar dat is veranderd.
Dus die niveaus kan je makkelijk aan laten staan.

Als je wel eentje terug kan opstarten, dan is dat toch goed. Dan kan je daarna toch gewoon doorwerken.

Wil je dan toch evengoed proberen om de 3.13.0-40-generic  te installeren, dan kan je dat doen via het menu wat je tegenwoordig hebt in updatebeheer en dan tabblad Tonen en dan Linuxkernels.
Ik wil hem niet installeren, maar juist de├»nstalleren. Bij het opstarten krijg ik nu  een menu waarin ik eerst een oudere kernel moet kiezen om door te kunnen gaan. Dat is niet prettig. Maar bij het verwijderen krijg ik foutmeldingen zoals ik hierboven al heb aangegeven.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: kernel crash
« Reactie #5 Gepost op: 2015/05/09, 14:48:17 »
Maak dan eens een sprong voorwaarts? De nieuwste kernel voor de 3.13-serie is 3.13.0-52.

Installeren doe je zo: https://sites.google.com/site/computertip/mint-cinnamon-directdoen#TOC-Installeer-kernel-updates
(punt 1.2.3, linkerkolom)

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #6 Gepost op: 2015/05/09, 18:13:00 »
Ik heb deze kernel:

Linux 3.13.0-40-generic #69-Ubuntu SMP Thu Nov 13 17:53:56 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

En deze is inderdaad niet de nieuwste. In Mint kan je nu zelf nieuwe kernels installeren. Voorheen kwamen ze met niveau 4 4n 5 mee, maar dat is veranderd.
Dus die niveaus kan je makkelijk aan laten staan.

Als je wel eentje terug kan opstarten, dan is dat toch goed. Dan kan je daarna toch gewoon doorwerken.

Wil je dan toch evengoed proberen om de 3.13.0-40-generic  te installeren, dan kan je dat doen via het menu wat je tegenwoordig hebt in updatebeheer en dan tabblad Tonen en dan Linuxkernels.
Ik wil hem niet installeren, maar juist de├»nstalleren. Bij het opstarten krijg ik nu  een menu waarin ik eerst een oudere kernel moet kiezen om door te kunnen gaan. Dat is niet prettig. Maar bij het verwijderen krijg ik foutmeldingen zoals ik hierboven al heb aangegeven.

Ik schreef al:
Citaat
Wil je dan toch evengoed proberen om de 3.13.0-40-generic  te installeren, dan kan je dat doen via het menu wat je tegenwoordig hebt in updatebeheer en dan tabblad Tonen en dan Linuxkernels.

En daar kan je ook kernels verwijderen!
Klopt, maar daar had ik ook proberen te verwijderen, maar daar kreeg ik die foutmeldingen.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #7 Gepost op: 2015/05/09, 18:14:10 »
Maak dan eens een sprong voorwaarts? De nieuwste kernel voor de 3.13-serie is 3.13.0-52.

Installeren doe je zo: https://sites.google.com/site/computertip/mint-cinnamon-directdoen#TOC-Installeer-kernel-updates
(punt 1.2.3, linkerkolom)
Dat zal ik zeker eerst proberen. Dank je.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #8 Gepost op: 2015/05/09, 18:20:15 »
Maak dan eens een sprong voorwaarts? De nieuwste kernel voor de 3.13-serie is 3.13.0-52.

Installeren doe je zo: https://sites.google.com/site/computertip/mint-cinnamon-directdoen#TOC-Installeer-kernel-updates
(punt 1.2.3, linkerkolom)
Ik heb het geprobeerd, maar  het lukt ook niet om 52 te installeren, want ik blijf de foutmelding over de 40 krijgen.  Ook bij het upgraden van Updatebeheer zelf.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: kernel crash
« Reactie #9 Gepost op: 2015/05/09, 19:49:52 »
Probeer dit eens:
sudo apt-get purge linux-image-3.13.0-40*
Gevolgd door:
sudo update-grub
Daarna computer herstarten.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #10 Gepost op: 2015/05/09, 20:23:44 »
Probeer dit eens:
sudo apt-get purge linux-image-3.13.0-40*
Gevolgd door:
sudo update-grub
Daarna computer herstarten.
Gedaan, dan krijg ik in de terminal de volgende foutmeldingen:
Removing linux-image-extra-3.13.0-40-generic (3.13.0-40.69) ...
depmod: FATAL: could not load /boot/System.map-3.13.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
Error! echo
Your kernel headers for kernel 3.13.0-40-generic cannot be found at
/lib/modules/3.13.0-40-generic/build or /lib/modules/3.13.0-40-generic/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-40-generic
grep: /boot/config-3.13.0-40-generic: Bestand of map bestaat niet
WARNING: missing /lib/modules/3.13.0-40-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.13.0-40-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
Warning: No support for locale: nl_NL.utf8
depmod: WARNING: could not open /tmp/mkinitramfs_IZPAbe/lib/modules/3.13.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /tmp/mkinitramfs_IZPAbe/lib/modules/3.13.0-40-generic/modules.builtin: No such file or directory
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic


Mod.edit: even tags geplaatst om die grote flappen tekst te reduceren.
« Laatst bewerkt op: 2015/05/12, 22:09:35 door Joris Donders »

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #11 Gepost op: 2015/05/09, 20:27:41 »
Probeer dit eens:
sudo apt-get purge linux-image-3.13.0-40*
Gevolgd door:
sudo update-grub
Daarna computer herstarten.
Gedaan, dan krijg ik in de terminal de volgende foutmeldingen:
Removing linux-image-extra-3.13.0-40-generic (3.13.0-40.69) ...
depmod: FATAL: could not load /boot/System.map-3.13.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
Error! echo
Your kernel headers for kernel 3.13.0-40-generic cannot be found at
/lib/modules/3.13.0-40-generic/build or /lib/modules/3.13.0-40-generic/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-40-generic
grep: /boot/config-3.13.0-40-generic: Bestand of map bestaat niet
WARNING: missing /lib/modules/3.13.0-40-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.13.0-40-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
Warning: No support for locale: nl_NL.utf8
depmod: WARNING: could not open /tmp/mkinitramfs_IZPAbe/lib/modules/3.13.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /tmp/mkinitramfs_IZPAbe/lib/modules/3.13.0-40-generic/modules.builtin: No such file or directory
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic

Toevoegen: er is inderdaad in de map lib/modules geen map 3.13.0-40, maar ergens wordt er blijkbaar wel naar verwezen.
« Laatst bewerkt op: 2015/05/12, 22:10:28 door Joris Donders »

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
Re: kernel crash
« Reactie #12 Gepost op: 2015/05/14, 22:15:37 »
Ook Softwarebeheer werd geblokkeerd en ik heb vandaag Mint maar opnieuw geinstalleerd! Bedankt voor alle hulp.