Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Linux installeert niet.  (gelezen 436 keer)

Offline scheurleer

  • Lid
  • Steunpunt: Nee
Linux installeert niet.
« Gepost op: 2015/05/05, 13:46:05 »
Goedemiddag allemaal.
Wat normaal gesproken in een uurtje klaar zou moeten zijn gaat steeds mis: het lukt niet om Linux te installeren.

Wat ik probeer is simpel: Linux installeren naast Windows 7 64bit. Ik heb een aparte partitie aangemaakt (met een partitiemanager) waar Linux op moet komen. Ik heb Ubuntu 14.04 64bit gedownload en gebrand. Hash en integrity check uitgevoerd, geen probleem gevonden.

Opstarten met de DVD lukt prima (duurt wel lang) en ik kom gewoon in de 'probeer-sessie'. Maar installatie loopt vast, zowel vanuit de 'probeer-sessie' als rechtstreeks vanuit het menu. Foutmelding: [0030] read-only filesystem /home. (ik heb de / en /home partitie op ext4 gezet).

Heb gekeken met de partitiemanager en met GParted naar de partities, maar geen probleem gevonden. Staat ook niet op read-only of hidden. Heb ook geprobeerd om te installeren op ntfs maar dat geeft hetzelfde resultaat. Maakt ook niet uit of ik primaire of logische partities maak. En het maakt ook niet uit of ik de partities vooraf maak of dit tijdens de installatieprocedure laat doen. Ik heb ook Fedora geprobeerd, Ubuntu 15.04 voor AMD, Mint verschillende versies  maar helaas: zelfde resultaat. Melding: de installatieprocedure loopt vast.

Gegevens systeem: AMD Athlon X4 met ATI Radeon HD5450 en een standaard 500GB schijf. BIOS settings staan goed.

Iemand enig idee wat ik nog kan doen?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #1 Gepost op: 2015/05/05, 21:13:02 »
Scheurleer,

Om een of andere duistere reden is de partitie(s) read-only.
Reden, een groot vraagteken.

Wat je kan doen is deze partitie(s) verwijderen zodat er een niet toegewezen on-gepartioneerd blok heb.
En bij de installatie, deel partioneren, neem de onderste optie als ik me niet vergis -> iets anders.
Ga je deze niet toegewezen on-gepartioneerd blok, partioneren, aankoppellen en formatteren ext4.

Ik hoop dan het dan wel lukt, een ander oplossing heb ik zo 123(45) niet.
MvG,
MauRice
Registered Linux user: 473556

Offline scheurleer

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #2 Gepost op: 2015/05/05, 22:30:41 »
Helaas MauRice2, dat had ik ook al geprobeerd maar werkt ook niet.

Offline FrSu

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #3 Gepost op: 2015/05/05, 22:53:08 »
Toen je de tip van Maurice deed had je toen een deel "Unallocated space"? Als je dat hebt zou de installatie die ruimte automatisch moeten kiezen om de installatie op te zetten.
Van Dos>Win 3.11>Win 95>Win 98>Win 2000>Win XP >Vista (Oeps, was foutje)>Win 7>Win 8>geheel gestopt met Win (behalve op de HP Touch)>Elementary Loki.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #4 Gepost op: 2015/05/06, 05:25:20 »
Direct naar installeren gaan met de livecd,
dan de partities met de hand maken via de installer(livecd).
Daar je 2 partities maken,
misschien eerst wissen, dan de nieuwe maken.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #5 Gepost op: 2015/05/06, 08:49:15 »
Misschien is het een fout op de harde schijf, die foutmelding zet me op dat spoor.
Kan je de computer weer opstarten via de LiveCD , de schijf aankoppelen en dan reparaties uitvoeren aan het filesystem?

Hierbij een overzicht van terminal instructies voor reparaties aan het filesystem .
Case 2 lijkt me het meest aannemelijke geval, dat er sprake is van een "dirty bit".

Offline scheurleer

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #6 Gepost op: 2015/05/06, 09:06:00 »
Allemaal vast bedankt voor de suggesties en het meedenken. Voor de duidelijkheid: het probleem zit hem niet in het alloceren van ruimte of het kopiëren van bestanden naar de ext3/ext4 partitie. Maar de procedure loopt vast tijdens de verdere  installatie op schijf. Dat vastlopen is enkele keren gebeurd tijdens de automatische hardwareherkenning, maar ik weet niet of dat er direct iets mee te maken heeft.

Aan een 'bad cluster' heb ik ook al gedacht. Maar ik controleer de schijfintegriteit vooraf, en er lijkt dan niets mis te zijn. Dus ik zou niet weten wat er dan te repareren valt. Ik heb gisteren de betreffende partitie in NTFS geformatteerd en Windows10 Preview geïnstalleerd. Geen enkel probleem geweest.

 Ik ga vandaag weer verder knutselen.

Edit: Open Suse 13.2 installeert wel.
« Laatst bewerkt op: 2015/05/06, 15:28:49 door scheurleer »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #7 Gepost op: 2015/05/06, 18:40:37 »
.......
Edit: Open Suse 13.2 installeert wel.
Scheurleer,

Dat is toch al een distro die wel wil installeren.
Nu nog erachter komen waarom de andere niet willen.

OpenSuSE is ook een goede disro en over KDE valt nu eenmaal niet te twisten.
De gustibus (et coloribus) non disputandum est.

MvG,
MauRice
Registered Linux user: 473556

Offline scheurleer

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet.
« Reactie #8 Gepost op: 2015/05/06, 19:03:13 »
Helemaal waar, MauRice2. Open Suse is een prima distro. Die draait ook. En wat betreft Ubuntu/Mint: ik weet niet waardoor de installatie vastloopt. Het lijkt op een probleem met de harde schijf (gecheckt met fsck) maar ook na herstel lukt de installatie niet. Dus ga ik maar virutaliseren. Acta fabula est!

Offline scheurleer

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet (update).
« Reactie #9 Gepost op: 2015/05/09, 19:51:20 »
Update

Probleem gevonden. Het zat 'm niet in de Linux partities maar er zat een fout in /dev/sda. Schrijven van de bootloader mislukte telkens. Nadat ik dat had hersteld installeerde het systeem verder vlekkeloos.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Linux installeert niet (update).
« Reactie #10 Gepost op: 2015/05/09, 19:58:12 »
Update

Probleem gevonden. Het zat 'm niet in de Linux partities maar er zat een fout in /dev/sda. Schrijven van de bootloader mislukte telkens. Nadat ik dat had hersteld installeerde het systeem verder vlekkeloos.
Scheurleer,

Eind goed, al goed.
MvG,
MauRice
Registered Linux user: 473556