Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: swap probleem  (gelezen 720 keer)

Offline tjjoost

  • Lid
  • Steunpunt: Nee
swap probleem
« Gepost op: 2007/03/31, 19:50:16 »
Hallo allemaal,

Ik heb een dualboot van Redhat Enterprise Linux 5 en Ubuntu Feisty Fawn Beta.

Tijdens het opstarten van redhat geeft hij de volgende melding: UNABLE TO ACCESS SWAP. Hij start verder normaal op maar hij maakt dus geen gebruik van de swap.

Mijn /etc/fstab van Redhat ziet er als volgt uit:

LABEL=/                                         /                                ext3        defaults                               1 1
devpts                                           /dev/pts                  devpts    gid=5,mode=620              0 0
tmpfs                                             /dev/shm                 tmpfs     defaults                               0 0
proc                                                /proc                         proc       defaults                                0 0
LABEL=/store                               /store                        ext3       defaults                                 1 2
sysfs                                              /sys                           sysfs      defaults                                0 0
LABEL=SWAP-hdd6                    swap                         swap      defaults                                0 0
 
                                               let op swap zonder "/"

mijn /etc/fstab van ubuntu feisty fawn beta:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/hdd7
UUID=1547a5bc-4131-4996-b554-76caceb9b4a0 /               ext3    defaults,errors=remount-ro 0       1
# /dev/hdc1
UUID=65136fc9-cf32-4c4c-985a-0d8b23efe898 /media/hdc1     ext3    defaults        0       2
# /dev/hdd5
UUID=18206dfb-0ded-4d07-99d9-9edd77ee08eb /media/hdd5     ext3    defaults        0       2
# /dev/hdd8
UUID=b9a721af-af87-4043-af31-e4ca035bb475 /store          ext3    defaults        0       2
# /dev/hdd6
UUID=c1a1bc95-8fba-43bc-9609-dc2a340fcce9 none            swap    sw              0       0
/dev/hdb        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hda        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0


Kan dit komen doordat tijdens de installatie van ubuntu de swap partitie automatisch geformateerd word?
Pc1=Centos5-desktop
Pc2=Fedora10-server
Pc3=Ubuntu810-desktop
Pc4=Test distributies
Laptop=F10+U810+C5+S11

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap probleem
« Reactie #1 Gepost op: 2007/03/31, 19:55:31 »
Verander deze regel in de fstab van Red Hat:
LABEL=SWAP-hdd6                    swap                         swap      defaults                                0 0

Maak hier van:
/dev/hdd6                    swap                         swap      defaults                                0 0


Ik denk dat door de installatie van Ubuntu het label veranderd is, en dat het daardoor niet meer werkt.

Offline tjjoost

  • Lid
  • Steunpunt: Nee
swap probleem
« Reactie #2 Gepost op: 2007/03/31, 20:10:52 »
Dat is niet gelukt. deze regel werd automatisch verder verandert naar:

/dev/hdd6                /dev/hdd6                            swap                             defaults            0 0

Zou ik de 0 0  nog moeten veranderen in             1 1     , net zoals de "/"
Pc1=Centos5-desktop
Pc2=Fedora10-server
Pc3=Ubuntu810-desktop
Pc4=Test distributies
Laptop=F10+U810+C5+S11

Offline tjjoost

  • Lid
  • Steunpunt: Nee
swap probleem
« Reactie #3 Gepost op: 2007/03/31, 20:14:06 »
Als ik /dev/hdd6 handmatig mount geeft hij de volgende melding:

UNKNOWN FILESYSTEM TYPE"SWAP"
Pc1=Centos5-desktop
Pc2=Fedora10-server
Pc3=Ubuntu810-desktop
Pc4=Test distributies
Laptop=F10+U810+C5+S11

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap probleem
« Reactie #4 Gepost op: 2007/03/31, 20:14:37 »
Welk programma verandert automatisch die regel?

Werkt Red Hat niet met /dev/ aanduidingen in fstab?
Dan zou je moeten kijken wat het label is van die schijf.
Ik heb alleen geen idee hoe je dat doet in Red Hat.

Die 0 0 moet je zo laten staan.
Dat heeft alleen invloed op ext3 partities en zo, en swap is dat niet.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap probleem
« Reactie #5 Gepost op: 2007/03/31, 20:16:19 »
Citaat van: tjjoost
Als ik /dev/hdd6 handmatig mount geeft hij de volgende melding:

UNKNOWN FILESYSTEM TYPE"SWAP"
Je kan een swap partitie ook niet mounten.
Een swap partitie is namelijk nooit geformatteerd.
Het is een apart file systeem.

In Ubuntu kan je het aanzetten met het commando swapon, ik heb geen idee hoe dat werkt in RH.

Offline tjjoost

  • Lid
  • Steunpunt: Nee
swap probleem
« Reactie #6 Gepost op: 2007/03/31, 20:27:27 »
De regel werd verder automatisch aangepast nadat ik LABEL=SWAP-hdd6 had verandert in /dev/hdd6. Door welk programma dit is gebeurd weet ik niet. Redhat gebruikt ook /dev aanduidingen.

Waarom formatteerde ubuntu dan de swap partitie tijdens de installatie? Ik heb mij er toen al over verwonderd dat hij dat deed. Ik ga nog even kijken of de partities aanduidingen niet zijn veranderd.
Pc1=Centos5-desktop
Pc2=Fedora10-server
Pc3=Ubuntu810-desktop
Pc4=Test distributies
Laptop=F10+U810+C5+S11

Offline tjjoost

  • Lid
  • Steunpunt: Nee
swap probleem
« Reactie #7 Gepost op: 2007/03/31, 20:34:10 »
Een programma in redhat "logical volume management" zegt dat de swappartitie (inderdaad /dev/hdd6) unmounted is en currently in use.
Dit is vreemd.  Waarom is de swap partitie in gebruik terwijl hij niet gemounted is?
Pc1=Centos5-desktop
Pc2=Fedora10-server
Pc3=Ubuntu810-desktop
Pc4=Test distributies
Laptop=F10+U810+C5+S11

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap probleem
« Reactie #8 Gepost op: 2007/03/31, 20:42:14 »
Een swap partitie wordt niet op dezelfde manier gemount als bijvoorbeeld een ext3, ntfs, fat of reiser partitie.

Open /etc/fstab in RH met gedit, nano, of iets dergelijks.
Zorg dat de swap regel er zo uit komt te zien:
/dev/hdd6                    swap                         swap      defaults                                0 0

Daarna opslaan en opnieuw starten.

Citaat van: Site van Red Hat
### LET OP, andere aanduiding, maar het lijkt me duidelijk
To enable the swap partition immediately, type the following command:

swapon /dev/hdb2

#

To enable it at boot time, edit /etc/fstab to include:

/dev/hdb2               swap                    swap    defaults        0 0

The next time the system boots, it will enable the new swap partition.
#

After adding the new swap partition and enabling it, make sure it is enabled by viewing the output of the command cat /proc/swaps or free
http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/custom-guide/s1-swap-adding.html