Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: USB 2.0 PCI-kaart  (gelezen 849 keer)

Offline Karel Brits

  • Lid
    • http://www.brits.name
  • Steunpunt: Nee
USB 2.0 PCI-kaart
« Gepost op: 2007/03/31, 10:06:26 »
Ik heb een tijd geleden een USB 2.0 kaart gekocht, met 4 USB 2.0-poorten.  Deze heb ik ge├»nstalleerd via een PCI-slot.

Nu ik mezelf onlangs een USB 2.0-stick gekocht heb, wou ik die testen via die kaart, maar daar reageert hij niet.  Op de gewone USB-poorten reageert hij wel.
Ik ga er dus vanuit dat die PCI-kaart niet herkend wordt.  Hoe kan ik dit controleren en eventueel aanpassen?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
USB 2.0 PCI-kaart
« Reactie #1 Gepost op: 2007/03/31, 12:40:40 »
Voer het volgende commando uit in de terminal:
sudo lspci

Plaats de regels tekst die je dan te zien krijgt hier.

Stop de usbstick in het nieuwe kaartje, waar het dus niet werkt.
Voer dan het volgende commando uit in de terminal:
dmesg

Plaats die (de laatste regels, niet alles!) hier.

Offline Karel Brits

  • Lid
    • http://www.brits.name
  • Steunpunt: Nee
USB 2.0 PCI-kaart
« Reactie #2 Gepost op: 2007/03/31, 13:46:13 »
De uitkomst van het lspci-commando:

Citaat
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
00:09.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
00:09.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 04)
00:09.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
dmesg gaf het volgende (waarvan ik dacht dat het interssantste stuk begon):

Citaat
[17179581.920000] uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
[17179581.920000] uhci_hcd 0000:00:07.2: irq 11, io base 0x0000c400
[17179581.920000] usb usb1: configuration #1 chosen from 1 choice
[17179581.920000] hub 1-0:1.0: USB hub found
[17179581.920000] hub 1-0:1.0: 2 ports detected
[17179582.024000] ACPI: PCI Interrupt 0000:00:07.3[D] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[17179582.024000] uhci_hcd 0000:00:07.3: UHCI Host Controller
[17179582.024000] uhci_hcd 0000:00:07.3: new USB bus registered, assigned bus number 2
[17179582.024000] uhci_hcd 0000:00:07.3: irq 11, io base 0x0000c800
[17179582.024000] usb usb2: configuration #1 chosen from 1 choice
[17179582.024000] hub 2-0:1.0: USB hub found
[17179582.024000] hub 2-0:1.0: 2 ports detected
[17179582.236000] Attempting manual resume
[17179582.264000] usb 1-1: new full speed USB device using uhci_hcd and address 2
[17179582.272000] kjournald starting.  Commit interval 5 seconds
[17179582.272000] EXT3-fs: mounted filesystem with ordered data mode.
[17179582.416000] usb 1-1: configuration #1 chosen from 1 choice
[17179582.420000] hub 1-1:1.0: USB hub found
[17179582.420000] hub 1-1:1.0: 4 ports detected
[17179583.116000] usb 1-1.1: new low speed USB device using uhci_hcd and address 3
[17179583.140000] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00023c01510807bd]
[17179583.252000] usb 1-1.1: configuration #1 chosen from 1 choice
[17179583.460000] usb 1-1.2: new full speed USB device using uhci_hcd and address 4
[17179583.700000] usb 1-1.2: configuration #1 chosen from 1 choice
[17179583.904000] usb 1-1.3: new full speed USB device using uhci_hcd and address 5
[17179584.036000] usb 1-1.3: configuration #1 chosen from 1 choice
[17179584.040000] hub 1-1.3:1.0: USB hub found
[17179584.040000] hub 1-1.3:1.0: 2 ports detected
[17179584.348000] usb 1-1.4: new low speed USB device using uhci_hcd and address 6
[17179584.488000] usb 1-1.4: configuration #1 chosen from 1 choice
[17179584.696000] usb 1-1.3.1: new full speed USB device using uhci_hcd and address 7
[17179584.828000] usb 1-1.3.1: configuration #1 chosen from 1 choice
[17179585.036000] usb 1-1.3.2: new full speed USB device using uhci_hcd and address 8
[17179585.168000] usb 1-1.3.2: configuration #1 chosen from 1 choice
[17179593.776000] Linux agpgart interface v0.101 (c) Dave Jones
[17179593.780000] agpgart: Detected VIA Twister-K/KT133x/KM133 chipset
[17179593.784000] agpgart: AGP aperture is 64M @ 0xe0000000
[17179595.148000] parport_pc: VIA 686A/8231 detected
[17179595.148000] parport_pc: probing current configuration
[17179595.148000] parport_pc: Current parallel port base: 0x378
[17179595.148000] parport0: PC-style at 0x378 (0x778), irq 7, using FIFO [PCSPP,TRISTATE,COMPAT,ECP]
[17179595.248000] parport_pc: VIA parallel port: io=0x378, irq=7
[17179595.380000] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[17179595.400000] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[17179595.484000] gameport: EMU10K1 is pci0000:00:09.1/gameport0, io 0xe000, speed 1242kHz
[17179595.820000] 8139too Fast Ethernet driver 0.9.27
[17179595.824000] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
[17179595.824000] ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 11
[17179595.824000] eth0: RealTek RTL8139 at 0xd09c2000, 00:48:54:6f:27:36, IRQ 11
[17179595.824000] eth0:  Identified 8139 chip type 'RTL-8139B'
[17179595.856000] 8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
[17179595.900000] ACPI: PCI Interrupt 0000:00:07.5[C] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 11
[17179595.900000] PCI: Setting latency timer of device 0000:00:07.5 to 64
[17179596.636000] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
[17179596.636000] ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[17179596.640000] Installing spdif_bug patch: Audigy 2 ZS [SB0350]
[17179596.732000] Floppy drive(s): fd0 is 1.44M
[17179596.744000] input: PC Speaker as /class/input/input1
[17179596.804000] FDC 0 is a post-1991 82077
[17179597.476000] input: ImExPS/2 Generic Explorer Mouse as /class/input/input2
[17179598.376000] eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
[17179598.680000] nvidia: module license 'NVIDIA' taints kernel.
[17179598.976000] input: Wacom Graphire3 as /class/input/input3
[17179598.984000] usbcore: registered new driver wacom
[17179598.984000] drivers/usb/input/wacom.c: v1.45:USB Wacom Graphire and Wacom Intuos tablet driver
[17179599.104000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 8 if 0 alt 0 proto 2 vid 0x043D pid 0x0069
[17179599.104000] usbcore: registered new driver usblp
[17179599.104000] drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
[17179599.148000] ts: Compaq touchscreen protocol output
[17179599.224000] usbcore: registered new driver hiddev
[17179599.352000] input: Logitech Logitech RumblePad 2 USB as /class/input/input4
[17179599.352000] input: USB HID v1.10 Joystick [Logitech Logitech RumblePad 2 USB] on usb-0000:00:07.2-1.4
[17179599.352000] usbcore: registered new driver usbhid
[17179599.352000] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[17179599.364000] Linux video capture interface: v1.00
[17179599.376000] drivers/media/video/stv680.c: [stv680_probe:1378] STV(i): STV0680 camera found.
[17179599.376000] drivers/media/video/stv680.c: [stv680_probe:1418] STV(i): registered new video device: video0
[17179599.376000] usbcore: registered new driver stv680
[17179599.376000] drivers/media/video/stv680.c: [usb_stv680_init:1495] STV(i): usb camera driver version v0.25 registering
[17179599.376000] drivers/media/video/stv680.c: STV0680 USB Camera Driver v0.25
[17179599.396000] ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[17179599.396000] NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-9631  Thu Nov  9 17:38:10 PST 2006
[17179599.424000] NET: Registered protocol family 17
[17179600.532000] NET: Registered protocol family 10
[17179600.532000] lo: Disabled Privacy Extensions
[17179600.532000] IPv6 over IPv4 tunneling driver
[17179601.224000] lp0: using parport0 (interrupt-driven).
[17179601.292000] SCSI subsystem initialized
[17179601.300000] ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
[17179601.300000] ieee1394: sbp2: Try serialize_io=0 for better performance
[17179601.396000] Adding 2096472k swap on /dev/disk/by-uuid/471c0235-6621-414d-aec0-95e5f122a89b.  Priority:-1 extents:1 across:2096472k
[17179601.540000] EXT3 FS on hda2, internal journal
[17179601.944000] NTFS driver 2.1.27 [Flags: R/O MODULE].
[17179601.992000] NTFS volume version 3.0.
[17179602.024000] NTFS volume version 3.0.
[17179609.624000] ACPI: Power Button (FF) [PWRF]
[17179609.624000] ACPI: Power Button (CM) [PWRB]
[17179609.624000] ACPI: Sleep Button (CM) [SLPB]
[17179609.880000] ibm_acpi: ec object not found
[17179609.936000] pcc_acpi: loading...
[17179610.692000] powernow: No powernow capabilities detected
[17179611.192000] eth0: no IPv6 routers present
[17179614.272000] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
[17179614.272000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
[17179614.272000] agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
[17179616.604000] apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
[17179616.604000] apm: overridden by ACPI.
[17179637.708000] /dev/vmmon[4523]: Module vmmon: registered with major=10 minor=165
[17179637.712000] /dev/vmmon[4523]: Module vmmon: initialized
[17179637.844000] /dev/vmnet: open called by PID 4548 (vmnet-bridge)
[17179637.848000] /dev/vmnet: hub 0 does not exist, allocating memory.
[17179637.848000] /dev/vmnet: port on hub 0 successfully opened
[17179637.848000] bridge-eth0: enabling the bridge
[17179637.848000] bridge-eth0: up
[17179637.848000] bridge-eth0: already up
[17179637.848000] bridge-eth0: attached
[17179637.896000] /dev/vmnet: open called by PID 4561 (vmnet-netifup)
[17179637.896000] /dev/vmnet: hub 1 does not exist, allocating memory.
[17179637.896000] /dev/vmnet: port on hub 1 successfully opened
[17179637.912000] /dev/vmnet: open called by PID 4559 (vmnet-netifup)
[17179637.912000] /dev/vmnet: hub 8 does not exist, allocating memory.
[17179637.912000] /dev/vmnet: port on hub 8 successfully opened
[17179637.976000] /dev/vmnet: open called by PID 4564 (vmnet-natd)
[17179637.980000] /dev/vmnet: port on hub 8 successfully opened
[17179638.268000] /dev/vmnet: open called by PID 4590 (vmnet-dhcpd)
[17179638.268000] /dev/vmnet: port on hub 1 successfully opened
[17179638.376000] /dev/vmnet: open called by PID 4589 (vmnet-dhcpd)
[17179638.376000] /dev/vmnet: port on hub 8 successfully opened
[17179638.512000] Bluetooth: Core ver 2.8
[17179638.512000] NET: Registered protocol family 31
[17179638.512000] Bluetooth: HCI device and connection manager initialized
[17179638.512000] Bluetooth: HCI socket layer initialized
[17179638.560000] Bluetooth: L2CAP ver 2.8
[17179638.560000] Bluetooth: L2CAP socket layer initialized
[17179638.644000] Bluetooth: RFCOMM socket layer initialized
[17179638.648000] Bluetooth: RFCOMM TTY layer initialized
[17179638.648000] Bluetooth: RFCOMM ver 1.7
[17179648.032000] vmnet8: no IPv6 routers present
[17179648.380000] vmnet1: no IPv6 routers present
[17179652.964000] eth0: no IPv6 routers present
Voor zover ik het kan ontcijferen wordt de usb 2.0-kaart dus niet ontdekt of aangestuurd, klopt dat?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
USB 2.0 PCI-kaart
« Reactie #3 Gepost op: 2007/03/31, 14:05:38 »
Er gebeurt zo te zien helemaal niks als je je usb stick in de usb poort stopt.

Heb je opgestart zonder usb stick in die poort, heb je daarna de usb stick er in gedaan, en weer daarna dmesg uitgevoerd?


Ik zie bij de tekst van lspci ook niet een extra pci-usbkaartje staan.

Welk merk usb kaart is het eigenlijk?

Offline Karel Brits

  • Lid
    • http://www.brits.name
  • Steunpunt: Nee
USB 2.0 PCI-kaart
« Reactie #4 Gepost op: 2007/03/31, 14:30:15 »
Citaat van: Johanvd
Er gebeurt zo te zien helemaal niks als je je usb stick in de usb poort stopt.

Heb je opgestart zonder usb stick in die poort, heb je daarna de usb stick er in gedaan, en weer daarna dmesg uitgevoerd?


Ik zie bij de tekst van lspci ook niet een extra pci-usbkaartje staan.

Welk merk usb kaart is het eigenlijk?
Ik heb inderdaad opgestart zonder usb stick in de poort en die daarna erin gedaan voor ik dmesg heb uitgevoerd.
Het merk van de kaart weet ik niet meer uit het hoofd.  Ik denk dat het Belkin of Hama moet geweest zijn.  Ik heb ze al van voor ik Ubuntu gebruikte, maar ik heb ze onder Windows ook nooit getest.  Ik heb een vermoeden dat ze daar ook niet gedetecteerd werd.