Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: URL herschrijven  (gelezen 330 keer)

Offline Flak

  • Lid
URL herschrijven
« Gepost op: 2015/03/25, 13:54:50 »
Ik wil graag de Joomla "URL herschrijven" optie gebruiken (aanzetten).

Hiervoor moet iets gebeuren met de configuratie van Apache2. (Ubuntu 14.04 LTS Virtual Private Server)

Ik heb de htaccess.txt veranderd in .htaccess maar dat is niet de oplossing.

Kan iemand mij vertellen hoe ik dit moet doen?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: URL herschrijven
« Reactie #1 Gepost op: 2015/03/25, 14:27:15 »
Voer het volgende in, op een terminalscherm:
sudo a2enmod rewrite
sudo service apache2 restart

Als het goed geïnstalleerd is, is dat alles.....
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline Flak

  • Lid
Re: URL herschrijven
« Reactie #2 Gepost op: 2015/03/25, 17:47:44 »
Dat heb ik geprobeerd maar er staat nog steeds een uitroepteken bij de optie URL herschrijven.
Als ik de URL herschrijven probeer in te schakelen dan weigert Joomla dat en als ik het nog een keer probeer krijg ik een foutmelding.
Ik heb .htaccess verwijderd.
Maar hoe los ik dit op?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline Flak

  • Lid
Re: URL herschrijven
« Reactie #4 Gepost op: 2015/03/25, 22:38:49 »
Ik moet in sites-enabled/000-default.conf zetten:

<Directory />
    AllowOverride All
</Directory>

Kan dit zo maar? Dit staat er namelijk niet in.

Ik denk dat ik in de 000-default.conf file het volgende toe moet voegen:

<Directory /var/www/>
  AllowOverride All
</Directory>

Is het dan opgelost?
« Laatst bewerkt op: 2015/03/25, 22:42:08 door Flak »

Offline Flak

  • Lid
Re: URL herschrijven
« Reactie #5 Gepost op: 2015/03/26, 14:19:31 »
Stap 1) sudo vi /etc/apache2/apache2.confStap 2) # AccessFilename .htacces verwijder '#'
Stap 3) <Directory ....>
AllowOverride All
Require all granted
</Directory>
Doe dit bij alle drie de <Directory> regels.

En dan werkt het.