Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: /etc/rc.local werkt niet tijdens boot, wel via terminal  (gelezen 324 keer)

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
/etc/rc.local werkt niet tijdens boot, wel via terminal
« Gepost op: 2015/03/24, 10:13:42 »
Onlangs heb ik een nieuwe SSD aangeschaft, echter zag ik tot mijn verbazing dat hij wel erg warm werd.....na een chekc in Windows bleek het niet aan de SSD te liggen maar aan Linux: ca 10grC warmer dan in Windows.
Na wat onderzoek met oa Powertop kwam ik erachter dat SATA Link Power Management de boosdoener was; die staat standaard op max_power. Als ik dat aanpas daalt de SSD temp van ca 40grC naar 30grC (tijdens normaal gebruik). Vervolgens wilde ik dat permanent maken via /etc/rc.local.
Echter tijdens boot voert hij de commando's niet uit.....via sudo /etc/rc.local wel...   ???

Dit is mijn rc.local:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# SATA Link Power Mangement
echo "min_power" > /sys/class/scsi_host/host0/link_power_management_policy
echo "min_power" > /sys/class/scsi_host/host1/link_power_management_policy
echo "min_power" > /sys/class/scsi_host/host2/link_power_management_policy
echo "min_power" > /sys/class/scsi_host/host3/link_power_management_policy
#echo 0 > /proc/sys/kernel/nmi_watchdog
echo 'auto' > '/sys/bus/pci/devices/0000:00:1b.0/power/control'
echo Y > /sys/module/snd_hda_intel/parameters/power_save_controller
echo 10 > /sys/module/snd_hda_intel/parameters/power_save
ethtool -s eth0 wol d

exit 0

Ik snap niet waarom dit tijdens boot niet werkt...wie wel?
Of is er een andere manier om SATA Link Power Management in te stellen tijdens boot?


Update:
Ik kom op het web ook een /etc/init.d/rc.local tegen, maar die heb ik niet...?
Volledig path gebruikt: helpt niet
« Laatst bewerkt op: 2015/03/24, 12:28:26 door VuurVosje »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #1 Gepost op: 2015/03/24, 10:41:54 »
Geen rechtstreeks antwoord, want ik weet het niet. Maar heb je al geprobeerd of je het ook kunt oplossen via de opstarttoepassingen? Zodat het dus pas na aanmelding wordt uitgevoerd?

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #2 Gepost op: 2015/03/24, 10:52:32 »
Nee, werkt ook niet.
sudo /etc/rc.local
« Laatst bewerkt op: 2015/03/24, 10:58:10 door VuurVosje »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #3 Gepost op: 2015/03/24, 11:09:48 »
OK..... Kun je misschien iets met /etc/hdparm.conf of met /etc/hddtemp.db ?

Ik heb bijvoorbeeld een overmatig "klikkende" (in- en uitparkerende) harde schijf via een ingreep in /etc/hdparm.conf kunnen "genezen". Was ook een instelling van het energiebeheer voor de schijf.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #4 Gepost op: 2015/03/24, 11:40:38 »
Gevonden: is een timing probleem!
(is natuurlijk ook retesnel met mijn nieuwe SSD  ;) )
sleep 30toegevoegd


#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

sleep 30

# SATA Link Power Mangement
/bin/echo "min_power" > /sys/class/scsi_host/host0/link_power_management_policy
/bin/echo "min_power" > /sys/class/scsi_host/host1/link_power_management_policy
/bin/echo "min_power" > /sys/class/scsi_host/host2/link_power_management_policy
/bin/echo "min_power" > /sys/class/scsi_host/host3/link_power_management_policy
#/bin/echo 0 > /proc/sys/kernel/nmi_watchdog
/bin/echo 'auto' > '/sys/bus/pci/devices/0000:00:1b.0/power/control'
/bin/echo Y > /sys/module/snd_hda_intel/parameters/power_save_controller
/bin/echo 1 > /sys/module/snd_hda_intel/parameters/power_save
/sbin/ethtool -s eth0 wol d

exit 0
« Laatst bewerkt op: 2015/03/24, 11:44:52 door VuurVosje »

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #5 Gepost op: 2015/03/24, 12:30:12 »
Hmmm....
Werkt goed, alleen na een pauzestand is het weer weg...
Iemand een idee voor een plek die ook na een pauze stand blijft?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #6 Gepost op: 2015/03/24, 13:40:15 »
Het makkelijkste is waarschijnlijk TLP: http://linrunner.de/en/tlp/tlp.html
http://askubuntu.com/questions/285434/is-there-a-power-saving-application-similar-to-jupiter?lq=1

Deze tool kan ook de andere regels uit je rc.local vervangen.

Persoonlijk zou ik de opties voor je geluidskaart handmatig invoeren in een nieuw bestand: /etc/modprobe.d/snd-intel.conf
options snd_hda_intel power_save_controller=Y
options snd_hda_intel power_save=1

Als je TLP niet wil kan je ook zelf wat scripten via pm-utils of laptop-mode, maar dat lijkt me een stuk ingewikkelder.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: /etc/rc.local werkt niet tijdens boot, wel via terminal
« Reactie #7 Gepost op: 2015/03/26, 06:28:29 »
Thanx!
TLP geïnstalleerd en dat lijkt goed te werken. Wel een paar settings (zoals dirty pages) aangepast omdat ik die wat risicovol achtte en het is een desktop; hoeft niet tot de laatste mW. Mijn doel was vooeral de temp omlaag zodat de fan niet aanslaat (het is een USFF).
Ik ga TLP ook op mijn netbook proberen; moet toch een nieuwe LM 17 op.