Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: perl: warning: Setting locale failed.  (gelezen 580 keer)

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
perl: warning: Setting locale failed.
« Gepost op: 2015/03/18, 18:12:24 »
Ik ben wat aan het testen met "sendEmail"

Het kommando
sendEmail -f henk@oegema.com -t henkoegema@gmail.com -u "Message test" -m "Dit is een test" -s smtp.gmail.com:25 -xu username  -xp passwordwerkt  goed op m'n pc met Ubuntu 14.04    :).



Op m'n RaspberryPi (Raspbian), krijg ik:
pi@raspberrypi ~ $ sendEmail -f henk@oegema.com -t henkoegema@gmail.com -u "Message test" -m "Dit is een test" -s smtp.gmail.com:25 -xu username -xp password
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_PAPER = "nl_NL.UTF-8",
LC_ADDRESS = "nl_NL.UTF-8",
LC_MONETARY = "nl_NL.UTF-8",
LC_NUMERIC = "nl_NL.UTF-8",
LC_TELEPHONE = "nl_NL.UTF-8",
LC_IDENTIFICATION = "nl_NL.UTF-8",
LC_MEASUREMENT = "nl_NL.UTF-8",
LC_TIME = "nl_NL.UTF-8",
LC_NAME = "nl_NL.UTF-8",
LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Mar 18 18:04:00 raspberrypi sendEmail[2334]: ERROR => Timeout while connecting to smtp.gmail.com:25  There was no response after 60 seconds.

en dan werkt het niet.    :(

Ik heb toen de file "/etc/default/locale" over gezet van m'n Ubuntu naar de RPi, maak ook dat helpt niet.

Wie kan mij helpen?



Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: perl: warning: Setting locale failed.
« Reactie #1 Gepost op: 2015/03/18, 19:37:25 »
Ik zou het volgende eens proberen:

LANGUAGE=nl_NL.UTF-8 LC_ALL=nl_NL.UTF-8  sendEmail -f henk@oegema.com -t henkoegema@gmail.com -u "Message test" -m "Dit is een test" -s smtp.gmail.com:25 -xu username  -xp password

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: perl: warning: Setting locale failed.
« Reactie #2 Gepost op: 2015/03/18, 21:08:55 »
Ik zou het volgende eens proberen:

LANGUAGE=nl_NL.UTF-8 LC_ALL=nl_NL.UTF-8  sendEmail -f henk@oegema.com -t henkoegema@gmail.com -u "Message test" -m "Dit is een test" -s smtp.gmail.com:25 -xu username  -xp password

Dank je wel.    =D       Dat werkt inderdaad.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino