Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba instellen  (gelezen 429 keer)

Offline carlof

  • Lid
Samba instellen
« Gepost op: 2015/03/16, 12:54:38 »
Wat is het probleem:

Problemen met wegschrijven van documenten via Samba. Op mijn desktop sinds april van vorig jaar Ubuntu werkt als een speer.

Mijn laptop gebruik ik als typemachine. Het betreft hier een Dell Latidude D520 die nu draait op xubuntu 14.04.2. Op deze computer had ik eerst windows XP.  Door de Samba op mijn desktop kon ik op mijn windows machine documenten binnenhalen bewerken en weer wegschrijven op mijn desktop. So far so good.

Nu heb, uit veiligheidsoverwegingen, ik op mijn laptop xubuntu 14.04.2 gezet. Om nu weer met mijn desktop documenten te kunnen delen heb ik op de laptop Samba gezet. Na enig geetter Samba aan de praat gekregen. Ik nu vanuit mijn laptop naar documenten op mijn desktop. Maar dan, na bewerken van een document wil ik deze weer op de desktop aangepast terugplaatsen. Dat gaat niet. Ik krijg de volgende mededeling:
Fout bij het opslaan van (het onderhavige document) Object bestaat niet. Pad naar bestand niet gevonden.

Gevoelsmatig is er ergens in de instellingen niet goed.

Kan iemand mij hierbij helpen?

Alvast bedankt.

Gerlof.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba instellen
« Reactie #1 Gepost op: 2015/03/16, 13:32:29 »
Wat heb je ingesteld?
Controleer de rechten!

Offline carlof

  • Lid
Re: Samba instellen
« Reactie #2 Gepost op: 2015/03/17, 12:11:08 »
Dank voor de reactie!
Volgens mij heb ik zo ongeveer overal de rechten op gegeven. Het gaat tenslotte over twee compueter die naast elkaar op mijn bureau staan.

Er moet mijns inziens inderdaad iets zijn met de rechten, maar wat???

Ik hoop dat iemand mij verder kan helpen, alvast bedankt.

Gerlof.

Offline carlof

  • Lid
Re: Samba instellen
« Reactie #3 Gepost op: 2015/03/20, 16:48:59 »
Hoop dat iemand mij toch verder kan helpen,

Het blijft vanaf mijn xubuntu 14.04.2 op mijn Dell latitude D520 maar niet lukken. Wel bestanden ophalen van mijn Ubuntu 14.04 desktop maar wanneer na bewerken wegschrijven ho maar. Het vreemde is namelijk dat wanneer ik de computer van mijn echtgenoot gebruik die draait op Mint 16 en daar één van mijn bestandjes vanaf mijn Ubuntu machine ga bewerken ik dat bestand wel vanaf haar computer kan wegschrijven op mijn desktop, rara... Voor alle volledigheid ik heb, op alle computers samba het zelfde ingesteld, dus zowel op de mint machine als op de ubuntu als de xubuntu.

Ligt het soms aan de DEll computer???

Hopelijk dat iemand mij verder kan helpen

Alvast dank

Gerlof.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba instellen
« Reactie #4 Gepost op: 2015/03/20, 21:52:40 »
Misschien heb je hier iets aan:
Hoe samba instellen,(zoals ik het doe).

Indien je al met instellingen gespeelt hebt, verwijder alles(tav samba) en reboot,
om zo schoon te beginnen.

Samba installeren,in "software center" zoeken op
samba(SMB/CIFS file, print, and login server for Unix).

Indien je meerdere users gebruikt, dus bijv 3 users die verschillend zijn,
op 3 verschillende pc's.
Dan op elke pc alle users als extra users aanmaken(later als alles werkt kun je de
extra users de rechten beperken, zodat ze minder kunnen, dit hoeft niet maar mag).
Dus je hebt dan de gewone user(die met installatie tot stand is gekomen) en nog 2 extra users.

Dan samba starten,(system-samba in xubuntu).
De map maken die je wilt gaan delen, zorg dat je gebruiker daar rechten voor heeft, dan pas de map gaan delen.
De share maken,
server instellen, zoals group naam,
security(niks veranderen),
samba users instellen(eigenschappen van je samba map, in de samba programma),
aanvinken die toegang krijgen(nu weet je ook waarom je meerdere users moet
ingeven, want dan zie je alle users, ook die van de andere pc).
Je kan ook extra users ingeven, maar dat heb ik nog niet gebruikt.

-Ook bij ubuntu, bij users kijken of de user ook bij de groep sambashare zit, dus aanvinken.

Nu zou het moeten werken, wel even rebooten.
Vaker moet je langer wachten totdat er verbinding komt, dus denk niet te snel dat het verkeerd is.!!!!!



Dit is normaal niet nodig!
Je kan nog in je host file de namen van de pc's ingeven,
dit zijn ipnummers met de naam van de pc, zodat deze beter
te vinden is op het netwerk, hoeft niet, maar als het niet goed werkt,
het vinden van de pc's dus.(bij pc's met vaste ip nummers is dit ook beter).
File naam is
hosts
Voorbeeld:
127.0.0.1 localhost  (dit is standaard)
127.0.1.1 jan        (dit is de pc waar samba op staat)
10.16.9.9        ba2        (dit is een andere pc op het netwerk)
10.16.9.99       download   (dit is een andere pc op het netwerk)


# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

De naam van de pc staat in de file hostname,
hier staat alleen een naam.

Indien het vinden van de pc's nog steeds slecht is,(bijv vaste ip nummers en zonder router)
probeer dan met gigolo(even installeren) de andere pc's te vinden,
vaak gaat het dan heel vlug om de pc's te vinden.

Veiligheid,

Nooit iedereen toegang geven, dit omdat als er een fout in een beveiliging/programma/router zit, dan kan iedereen in je files kijken.
Dus altijd een wachtwoord en user erop zetten.

In de samba config file kun je nog,
netwerk interface vastzetten, indien je 2 netwerkkaarten hebt,
zodat samba alleen over bepaalde netwerkkaart gaat.

Hetzelfde geld voor ip nummers, dit kun je ook vastzetten.
10.0.0.0/8 eth0
dit betekend netwerkkaart eth0, alleen hier gaat samba over werken.
en de ip range 10.0.0.0/8 gaat samba werken.

En je kunt nog met de firewall ip adressen en samba blokkeren of open zetten.

Testen netwerk,
40 Gb aan geparde files maken en dit in een ruk kopieren.
dan aan de andere kant parren, dan zie je of alles ook aankomt.
(in windows heb ik een keer gezien dat 1 op de 10 files beschadigd
waren met kopieren, lag aan de firewall, en geen foutmelding).
Bij geen fouten niks doen.
Bij fouten, dan dit gaan wijzigen in samba config(kan soms helpen)
# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY
socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
Grootte van deze 2 files wijzigen en weer testen.(klein is vaak beter maar ook langzamer).
Kan natuurlijk ook driver zijn, of netwerkkabels.
Zelf heb ik meerdere keren problemen ondervonden, en door te testen merk je opeens
dat niet alles zomaar werkt.
Na het kopieren ook met ifconfig kijken in de terminal,
daar kun je ook problemen/fouten zien.
--------------------------------------------------------------------------------------------------
Indien het nog niet werkt kun je dit nog proberen,
(bij werkte het opeens niet meer(eerste dus wel), oorzaak onbekend, toen dit erbij gezet en het werkte)
Volgend wijzigen in je samba config file(/etc/samba.smb.conf),
Dit erbij zetten,
name resolve order = bcast host

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = workgroup
        name resolve order = bcast host