Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Keepass2 werkt niet meer in Mint 17.1 Mate  (gelezen 189 keer)

Offline dellkubuntu

  • Lid
  • Steunpunt: Nee
Keepass2 werkt niet meer in Mint 17.1 Mate
« Gepost op: 2015/02/14, 15:43:38 »
Ik heb deze vraag ook al op het Mint forum gezet,maar zet hem ook maar even hier neer. ;)

Ik heb op mijn Mint 17.1 Mate het vervelende probleem dat Keepass2 helemaal niet meer wil opstarten.Heb alles al geherinstalleerd en nog wil het niet.Meer mensen die hier last van hebben?Dit is de foutmelding in de terminal die ik krijg bij het opstarten van Keepass2:

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: Keepass2 werkt niet meer in Mint 17.1 Mate
« Reactie #1 Gepost op: 2015/02/14, 16:19:03 »
Zijn alle dependencies wel geïnstalleerd (zou eigenlijk wel moeten als je keepass2 via apt hebt geinstalleerd)? Dat System.Windows.Forms lijkt me uit dit pakket te komen: http://packages.ubuntu.com/trusty/libmono-system-windows-forms4.0-cil Heb je dat geïnstalleerd staan?
apt-cache policy libmono-system-windows-forms4.0-cil

Het kan ook best een bug zijn natuurlijk, heb het programma zelf niet om te testen. Heb je ergens anders nog een goed werkende Keepass2? Anders kun je altijd nog je database exporteren naar .kdb formaat zodat deze met KeepassX is te openen en je bij de wachtwoorden kunt.




Offline JvH

  • Lid
  • Steunpunt: Nee
Re: Keepass2 werkt niet meer in Mint 17.1 Mate
« Reactie #2 Gepost op: 2015/02/14, 16:26:16 »
In Ubuntu MATE 14.10 heb ik vandaag nog KeePass2 gebruikt zonder problemen. Ik heb het ook (via het Softwarecentrum) geïnstalleerd in Mint 17.1 MATE, wat ik in VirtualBox heb draaien. Ook daar start het programma zonder problemen op bij mij.

Hoe lang speelt dit probleem al? Zoals erik1984 al aangeeft, lijkt het erop alsof er iets is gebeurd met Mono, waar keepass2 afhankelijk van is.
Je zegt dat je 'alles hebt geherinstalleerd' - kun je dat verder toelichten? Hoe heb je dat precies gedaan, en welke pakketten heb je geherinstalleerd?

Offline dellkubuntu

  • Lid
  • Steunpunt: Nee
Re: Keepass2 werkt niet meer in Mint 17.1 Mate
« Reactie #3 Gepost op: 2015/02/14, 16:39:43 »
Ik zit nu even op een andere laptop met mint 17.1 xfce te werken en daar doet keepass2 het prima.is ook dezelfde versie als die in mate(225)
@Eric1984:Ik had al een oudere mono geprobeerd,maar jouw tip zal ik wel uitvoeren als ik weer op die laptop zit.
@JvH:Probleem heb ik sinds 1 week.Ik gebruik keepass2 niet zo vaak.Ik heb dus keepass2 gedeïnstalleerd via terminal,daarna autoremove.toen weer alles erop.Gebeurde niks.Weer alles eraf,autoremove.Toen via Synaptic geprobeerd,ook niks helaas.Kan Keepass2 ook niet opstarten,alleen via de terminal krijg ik desbetreffende foutmelding te zien.Heb Mono ook opnieuw erbij geïnstalleerd,maar dat pakt hij automatisch mee bij een verse install.

apt-cache policy libmono-system-windows-forms4.0-cilDeze uitkomst krijg ik,dus is aanwezig.



Heb ook nog de gehele Mono-complete geïnstalleerd,maar dat gaf conflicten.Alles er weer af en Keepassx erop gezet.Kan alleen niet vanuit Keepass2 de databases importeren.Dat schijnt onder windows te moeten.Dus dan maar handmatig een nieuwe kdb database gaan vullen. :D

Ik zet het maar op opgelost,ik ga weer terug naar KeepassX.Iedereen bedankt voor het meedenken. :)
« Laatst bewerkt op: 2015/02/15, 16:30:25 door dellkubuntu »