Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache2 start niet meer  (gelezen 544 keer)

Offline molly w

  • Lid
Apache2 start niet meer
« Gepost op: 2015/02/05, 12:48:22 »
Onlangs heb ik een nieuwe "site" toegevoegd aan mijn VirtualHost (Localhost) (Apache2). Daartoe heb ik wijzingen aangebracht in het bestand /etc/apache2/site-available/default. Gewoon regels van een bestaande site kopiëren, plakken en de betreffende namen wijzigen in die van de nieuwe site.
Nadat ik de pc opnieuw inschakelde, kreeg ik de melding "KAN GEEN VERBINDING MAKEN".
Als ik in Terminal het commando/etc/init.d/apache2 restartinvoeg, krijg de volgende meldingen:
/usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Syntax error on line 237 of /etc/apache2/apache2.conf: Syntax error on line 95 of /etc/apache2/sites-enabled/000-default: </VirtualHost> without matching <VirtualHost> section
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!
Ga ik naar het bestand /usr/sbin/apache2ctl: regel 87 dan snap ik niets van wat daar staat. Ik ben dan ook maar een gebruiker, geen kenner.
Ga ik naar het bestand /etc/apache2/sites-enabled/000-default, (verwijst overigens naar het bestand waarin ik heb gewerkt) dan zie ik niet wat daar fout is. Volgens mij moet ik hier toch zijn, want dat is de enige wijziging die ik aangebracht.
Het bestand luidt:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

# VANAF HIER GEPLAKT CODE VAN WAMP

<Directory /var/www/oblimon/intranet>
    Options Indexes FollowSymLinks
    AllowOverride all

#   onlineoffline tag - don't remove
    Order allow,deny
    Allow from all
</Directory>
<Directory /var/www/oblimon/intranet>
# ServerAdmin webmaster@intranet
# DocumentRoot
#   ServerName intranet
#    ServerAlias intranet
# ErrorLog "logs/intranet-error.log"
# CustomLog "logs/intranet-access.log" common
</Directory>

<Directory /var/www/oblimon/website/>
    Options Indexes FollowSymLinks
    AllowOverride all

#   onlineoffline tag - don't remove
    Order allow,deny
    Allow from all
</Directory>
<Directory /var/www/oblimon/website>
#    ServerAdmin webmaster@website
#    DocumentRoot
#    ServerName website
# ErrorLog "logs/website-error.log"
# CustomLog "logs/website-access.log" common
</Directory>

<Directory /var/www/nieuwesite/>
    Options Indexes FollowSymLinks
    AllowOverride all

#   onlineoffline tag - don't remove
    Order allow,deny
    Allow from all
</Directory>
<Directory /var/www/nieuwesite>
# ServerAdmin webmaster@nieuwesite
# DocumentRoot
#   ServerName nieuwesite
#    ServerAlias nieuwesite
# ErrorLog "logs/nieuwesite-error.log"
# CustomLog "logs/nieuwesite-access.log" common
</Directory>

# EINDE INGEVOEGDE CODE WAMP

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
Wie kijkt met mij mee en ziet waar de fout zit. Waar zit de syntax error?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Apache2 start niet meer
« Reactie #1 Gepost op: 2015/02/05, 13:04:59 »
Jij geeft het commando:
/etc/init.d/apache2 restartMaar hoort daar geen sudo voor?
Zelf doe ik dat met:
sudo service apache2 restarten dat gaat goed .......

De andere vragen kan ik helaas niet beantwoorden .......
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #2 Gepost op: 2015/02/05, 14:18:33 »
Jij geeft het commando:
/etc/init.d/apache2 restartMaar hoort daar geen sudo voor?
Zelf doe ik dat met:
sudo service apache2 restarten dat gaat goed .......

Geprobeerd, maar het maakt geen verschil. Daar zit 't 'm dus niet in.

Citaat
De andere vragen kan ik helaas niet beantwoorden .......
We wachten op anderen

Offline tomatito

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #3 Gepost op: 2015/02/06, 19:13:24 »
Hier ook al weer geen kenner  ;)

Maar... heb je hier al in gekeken:
The Apache error log may have more information.
Dual boot: Elementary OS 0.3.2 Freya (64-bit) built on UBUNTU 14.04  |  Windows 10

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)

Offline JohPoe

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #4 Gepost op: 2015/02/07, 12:07:01 »
</VirtualHost> without matching <VirtualHost> section
Action 'configtest' failed.

Het bestandje begint wel met <VirtualHost> dus ergens in het bestand leest het systeem ergens een end tag.
Het valt mij op dat de <Directory> soms is aangevuld met een padnaam zonder en soms met aanhalingstekens.  Misschien <Directory /> wijzigen in >Directory "/"> als voorbeeld.


Offline tomatito

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #5 Gepost op: 2015/02/07, 19:29:14 »
Dit gaat mij nu al boven de pet  :-[ Sorry.

Anders met deze foutmelding (letterlijke tekst) even Googelen.
Dual boot: Elementary OS 0.3.2 Freya (64-bit) built on UBUNTU 14.04  |  Windows 10

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)

Re: Apache2 start niet meer
« Reactie #6 Gepost op: 2015/02/07, 19:43:33 »
Ik had het zelfde probleem als jij beschrijft.
Vervolgens heb ik de default aangepast als volgt en het werkt naar behoren.
Let wel dat je nog even de log verwijzingen moet definieren.
<VirtualHost *:80>
ServerName sitea.nl
ServerAlias www.sitea.nl
DocumentRoot /var/www/sitea
        //hier je error log
 </VirtualHost>
 <VirtualHost *:80>
ServerName siteb.nl
ServerAlias www.siteb.nl
DocumentRoot /var/www/siteb
        //hier je error log
 </VirtualHost>

<VirtualHost *:80>
        //externe host binnen je netwerk
ProxyPreserveHost On
ProxyPass / http://192.168.2.100/
ProxyPassReverse / http://192.168.2.100/
ServerName www.sitec.nl
        ServerAlias www.sitec.com
</VirtualHost>

Offline JohPoe

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #7 Gepost op: 2015/02/07, 19:53:02 »
Dit gaat mij nu al boven de pet  :-[ Sorry.

Mijn excuses.

Bij XML kun je op 2 manieren iets configureren/aangeven.

1)
<sectie 1>
       <sectie 2>
             doe het dingetje
       </sectie 2>
</sectie 1>

2)
<sectie 1>
        <sectie 2 doe het dingetje />
</sectie 1>


Als je 1 en 2 gaat mixen dan gaat het fout dus:
<sectie 1>
         <sectie 2 doe het dingetje />
         </sectie 2>
</sectie 1>      <---- geeft de foutmelding dat er geen <sectie 1> geopend is.


« Laatst bewerkt op: 2015/02/07, 19:56:26 door JohPoe »

Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #8 Gepost op: 2015/02/08, 16:40:29 »
Dank aan de bijdragers. Ik dacht met hun bijdragen het probleem te kunnen oplossen, helaas, het blijft mij voor raadsels stellen.
Ik heb gesleuteld aan het bestand 'default'. (eerst het originele bewaard als 'default oud')
Vervolgens heb ik van alles geprobeerd, maar het lukt niet. De eerste drie regels zien er nu zó uit:
<VirtualHost *:80>
ServerAdmin webmaster@localhost
</VirtualHost>
Echter, als ik in terminal de opdracht "start" geef, krijg ik de melding dat </VirualHost> geen match heeft:
Syntax error on line 3 of /etc/apache2/sites-enabled/000-default: </VirtualHost> without matching <VirtualHost> section
Ik snap er nu niets meer van?  Waar is die onzichtbare end-tag??? Er staat nu in de sectie VirtualHost helemaal niets meer dan wat tekst. Hoezo dan geen match met VirtualHost sectie? wat zie ik over het hoofd?

Offline JohPoe

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #9 Gepost op: 2015/02/08, 17:08:58 »
Dit klink misschien gek maar maak eens een geheel nieuw bestand zonder knippen en plakken en geef aan het einde een extra lege regel.
Voor de inspringing geen tab gebruiken maar spaties.

Toevoeging:
als ik je 3 regel code met hexedit bekijk bevat het een aantal tabs. Voor ServerAdmin staat er 1 maar ook na localhost zit nog een tab verborgen.

Tip. stel je editor zo in dat er spaties worden geplaatst in plaats van verborgen tab tekens.
In gedit doe je dat onder Bewerken-Voorkeuren-Editor.
« Laatst bewerkt op: 2015/02/08, 17:33:31 door JohPoe »

Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #10 Gepost op: 2015/02/09, 13:34:09 »
Dank voor deze tips.

(1)
Ik heb het nu zover dat Apache2 start, maar ....
Het bestand 'default' ziet er nu zó uit:
<VirtualHost *:80>

  DocumentRoot /var/www/intranet
  ServerName intranet
  ServerAlias intranet

  <directory /var/www/intranet>
    Options Indexes FollowSymLinks
  </directory>

</VirtualHost>
De regels over Errorlogs kan ik nergens kwijt, ik krijg steeds te lezen dat ze op die plek niet zijn toegestaan.

(2)
Maar nu werkt het nog niet. Als ik de naar de site Intranet wil gaan, kan die niet gevonden worden.
Citaat
Not Found

The requested URL /intranet/intranet_login.php was not found on this server.
Apache/2.2.22 (Ubuntu) Server at localhost Port 80
De complete url luidt:
http://localhost/intranet/intranet_login.phpTerwijl het bestand intranet_login.php daar toch echt wel staat. Is er soms nóg een bestand waarin instellingen geregeld moeten worden? (zoiets herinner ik me van apache in een windowsomgeving)

Offline JohPoe

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #11 Gepost op: 2015/02/09, 18:18:27 »
probeer eens
http://localhost/intranet_login.php
mooier zou zijn
http:/intranet/intranet_login.phpomdat te kunnen doen moet je aan het bestand /etc/hosts de regel
127.0.0.1        intranet toevoegen.

Is het niet zo dat het standaard is om met een index.html of zoiets de site te openen?

Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #12 Gepost op: 2015/02/10, 14:34:06 »
Mijn dank. Het werkt!
Ook de suggestie om in etc/hosts regels met hostnamen toe te voegen, heb ik toegepast.

Citaat
Is het niet zo dat het standaard is om met een index.html of zoiets de site te openen?
Ja, dat klopt, maar hier word je automatisch doorgezet naar een login-bestand.

Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #13 Gepost op: 2015/02/10, 14:37:00 »
Nog een vraagje:
Waar vind ik (nderlandstalige) info over regels als AllowOverride None, Options Indexes FollowSymLinks, en zo meer.
Ik neem dat wel braaf over van het oude bestand default met het idee dat ze ergens goed voor zijn, maar heb geen idee wat dan en wat er zou kunnen gebeuren als ik ze weglaat.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: Apache2 start niet meer
« Reactie #14 Gepost op: 2015/02/10, 17:38:25 »
info over regels als AllowOverride None, Options Indexes FollowSymLinks, en zo meer.
Je bedoeld http .htaccess ?

engels       http://corz.org/server/tricks/htaccess.php
nl                 http://www.wphandleiding.nl/wordpress-blog/2014/09/12/verbeter-de-wordpress-beveiliging-met-deze-htaccess-snippets/


Offline molly w

  • Lid
Re: Apache2 start niet meer
« Reactie #15 Gepost op: 2015/02/13, 16:42:24 »
Dank. Ik heb de url's bewaard zodat ik een en ander kan bestuderen