Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: installeren drivers voor USB netwerkadapter in Ubuntu/Xbuntu/Lubuntu 14.04 LTS  (gelezen 2486 keer)

 Ik wil graag 2 USB netwerkadapters installeren onder Ubuntu/Xbuntu en Lubuntu

USB netwerkadapter 1: TP-Link TL-WN822-V2
Identificatie van TP-Link met het commando lsusb op de terminal van Xbuntu / Linux levert op:
ID 0cf3:7015 Atheros Communicatios, Inc. TP-Link TL-WN821 v3 802.11n [Atheros AR7010 + AR9287]
Atheros AR9271, AR7010 devices (ath9k_htc)
ath9k_htc is a Linux kernel driver supporting Atheros 802.11n USB chipsets, introduced at Linux 2.6.35.

Installeren is een probleem. Hoe moet dat nu?
Er is ook nog eens firmware voor nodig, dat maakt het installeren nog moeilijker.
Een goede duidelijke eenduidige installatieprocedure kan ik helaas nergens vinden op het internet.
Wie kent de juiste procedure?
In het Ubuntu-software centrum is onder Atheros niets te vinden.
Met NDISWrapper krijg ik foutmeldingen. Daarmee lukt het dus ook niet.


USB netwerkadapter 2: ICIDU NI707518
Identificatie van ICIDU met het commando lsusb op de terminal van Xbuntu / Linux levert op:
ID Ocf3: 9271 Atheros Communications AR9271 802.11n; dit is dus de chipset die in deze USB-netwerkadapter zit ;
ath9k_htc is a Linux kernel driver supporting Atheros 802.11n USB chipsets, introduced at Linux 2.6.35.

Installeren is een probleem. Hoe moet dat nu?
Er is ook nog eens firmware voor nodig, dat maakt het installeren nog moeilijker.
Een goede duidelijke eenduidige installatieprocedure kan ik helaas nergens vinden op het internet.
Wie kent de juiste procedure?
In het Ubuntu-software centrum is onder Atheros niets te vinden.

Graag jullie hulp bij de installatie van de Linux-driver voor deze USB netwerkkaarten /-adapters Bij voorbaat dank.


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Doen ze 't niet meteen dan? Atheros-chipsets horen uit-de-doos te werken....

Als de USB-netwerkadapters het meteen zouden doen was ik niet hier. Ze worden wel door Xbuntu herkend (lampje gaat branden) maar ze werken niet onder Xbuntu. Ze zijn zeker niet defect en werken wel onder Windows 7.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
USB netwerkadapter 1: TP-Link TL-WN822-V2 

output van lsusb:
      ID 0cf3:7015 Atheros Communicatios, Inc. TP-Link TL-WN821 v3 802.11n [Atheros AR7010 + AR9287]
      Atheros AR9271, AR7010 devices (ath9k_htc)
      ath9k_htc is a Linux kernel driver supporting Atheros 802.11n USB chipsets, introduced at Linux 2.6.35.

Kan je meer vertellen over de manier waarop je drivers installeert?

Info over wifi drivers:
    http://wireless.kernel.org/en/users/Drivers/Atheros#Atheros_Linux_wireless_drivers

Bedankt voor je reactie.

Ik ben nieuw en dus nog  onbekend met Linux/Xbuntu en weet dus eigenlijk niet op welke manier je drivers moet installeren.
Ik ben dus op zoek naar een min of meer universele installatieprocedure voor ontbrekende drivers indien die er is.

Wellicht is de procedure die jij gebruikt voor mij ook effectief.

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Gezien ik hier ook zo'n ICIDU heb die overal op werkt, mijn vraag welke, de 32 of 64bit, Xubuntu 14.04 LTS gebruik je, kan ik een test doen.
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
DeBaas +1

Het lijkt me sowieso geen stuurprogrammaprobleem, omdat het om Atheros gaat. Er moet iets anders aan de hand zijn.

Probeer eens wat dingen op deze pagina (punt 2.3 en verder):
https://sites.google.com/site/computertip/geendraadloosinternet
« Laatst bewerkt op: 2015/01/19, 00:04:49 door Pjotr »

Offline DeBaas

  • Lid
  • Steunpunt: Ja
xubuntu-14.04.1-desktop-i386.iso
xubuntu-14.04.1-desktop-amd64.iso
beide iso's gelijke resultaten.

Opstart USB gemaakt met: sudo dd if=xubuntu-14.04.1-desktop-X.iso of=/dev/sde BS=4M
Opgestart vanaf deze USB
Klik op het netwerk-icoon rechtsbovenin
Steek de ICIDU NI707518 USB, chipset AR9271, in de USB poort, 2 seconden wachten, lijst met WiFi toegangspunten.
Steek de Sweex LW053 USB, chipset rt073, in de USB poort, 2 seconden wachten, lijst met WiFi toegangspunten. (Sweex LW053 is gelijk aan Sitecom WL172 v1 001, chipset rt073)
TP-Link TL-WN822-V2 USB, chipset AR7010 + AR9287, maakt gebruik van dezelfde ath9k_htc als de ICIDU, deze heb ik niet om te testen, zou ook direct moeten werken.

Ook getest:
Humax 150N Wireless Lan USB, chipset RT2870/RT3070, gelijk aan de
Logilink WL0049A WLAN N USB, chipset RT2870/RT3070, 2 seconden wachten, lijst met WiFi toegangspunten.

Maxxter ACT-WNP-UA-005 USB, chipset RTL8192EU, gelijk aan de
Gembird ACT-WNP-UA-005 USB, chipset RTL8192EU, software op https://forum.ubuntu-nl.org/index.php?topic=86081.msg930664#msg930664, te downloaden http://users.telenet.be/x86_64/Debian/dkms_rtl8192eu_4.3.1.1.11320.20140505_all.deb
aangeklikt voor download/installatie, 1 minuut installatie, WiFi stick in de USB poort, 2 seconden wachten, lijst met WiFi toegangspunten.

Al deze verbindingen 10 minuten getest op stabiliteit, geen probleem ondervonden.

Ik maak mij toch ernstig zorgen om de kwaliteit van de spanning, stroom en data op je USB poorten. De door jou gevraagde drivers zitten al in de Xubuntu 14.04.1 installatie.
De TP-Link en ICIDU maken gebruik van dezelfde driverset en zouden binnen een paar seconden moeten werken, evenals de in je bezit zijnde Sweex.

Probeer in de BIOS van je PC/Notebook of je Legacy USB uit (of in) kunt schakelen, mogelijk geeft dat verbetering. Zijn de USB poorten wel USB2 ? Probeer de andere USB poorten.
« Laatst bewerkt op: 2015/01/19, 11:54:00 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Misschien heeft het te maken met USB 1.1 versus USB 2.0, zoals DeBaas al aangeeft?

Bedankt voor jullie reacties. De Sweex USB-adapter met de Ralink chipset werkt inmiddels weer. Deze werkte ook meteen na installatie van de 32-bits versie van Xbuntu (deze Sweex/ Ralink was aangesloten op een USB-poort bij de installatie van Xbuntu 14.04 LTS 32 bits middels een vaste internetverbinding ; de draadloze netwerkverbinding met deze Sweex/Ralink is wel vrij mager / instabiel.

De ICIDU USB-netwerkadapter (met de Atheros chipset) werkt nu gelukkig ook!
Bij de installatie van Xbuntu was de Sweex (Ralink chipset) dus aangesloten. Later heb ik de de ICIDU USB netwerkadapter voor het eerst aangesloten op een USB-poort van de al opgestarte Xbuntu PC. Het lampje van de ICIDU-adapter ging en bleef toen continu branden. Dat  continu branden is volgens mij een teken dat de hardware in principe moet werken. De adapter werkte echter niet.
De volgende morgen startte ik de PC op met de ICIDU-adapter in een USB-poort. Toen bleek de ICIDU adapter wel te werken: het lampje flikkerde nu (in plaats van continu branden). Ik denk dat de computer dus opnieuw opgestart had moeten worden. Dat was ook vaak noodzakelijk na de installatie van Windows drivers.
Als er driver problemen zijn kan het dus wel eens heel nuttig zijn om de computer opnieuw op te starten.

De TP-Link USB-netwerkadapter (ook met een Atheros chipset) heb ik nog niet aan de praat gekregen. Dat moet volgens mij ook nog lukken. Het lampje daarvan heeft immers ook continu gebrand toen die adapter via een USB-poort was verbonden met een al opgestarte Xbuntu PC

Wellicht is het mogelijk de Sweex USB-netwerkadapter beter te laten werken. Installatie met Wrapper / Windows? Weet iemand hoe dat dan precies moet?