Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ter info: (dkms) rtl8192eu / rtl8812au  (gelezen 409 keer)

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Ter info: (dkms) rtl8192eu / rtl8812au
« Gepost op: 2015/01/14, 15:04:30 »
Ter info.

Ik gebruik normaal gezien geen tussen versie dan alleen de LTS.

Maar nood breekt wet...
Om voor een andere probleempje had ik een hogere versie van ghostscript nodig.
Dus installeer op een laptop *buntu 14.10.

Blijkt ook dat de C-compiler is verhoogt in versie nummer.
Deze valt namelijk over zijn eigen ingebakken macro's voor 'Datum en Tijd'.
Maw, er zal geen kernel-module worden gecompeleerd met deze source-code.

Een eenvoudige oplossing is, de Makefile aantepassen.
Het vet gedrukte er tussen zetten.
Citaat
EXTRA_CFLAGS += -Wno-unused-variable
EXTRA_CFLAGS += -Wno-unused-value
EXTRA_CFLAGS += -Wno-unused-label
EXTRA_CFLAGS += -Wno-unused-parameter
EXTRA_CFLAGS += -Wno-unused-function
EXTRA_CFLAGS += -Wno-unused
EXTRA_CFLAGS += -Wno-date-time

#EXTRA_CFLAGS += -Wno-uninitialized

Gebruik je de dkms versie pas dan de Makefile aan in: /usr/src/<rtl-source-code-versie>/Makefile
Herstart en dkms zal de rest doen.

Gebruike je de aangepaste source-code in je HOME-folder, pas de Makefile aan waar deze staat.
Compileer en installeer zoals voorheen.

MvG,
MauRice
Registered Linux user: 473556