Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Kan NAS niet benaderen  (gelezen 1248 keer)

Offline svv1972

  • Lid
Kan NAS niet benaderen
« Gepost op: 2015/01/06, 15:49:52 »
Hallo,

Sinds kort van Windows overgestapt naar Ubuntu 14.04 LTS en nu bezig met mijn NAS te benaderen gewoon thuis.
Situatie is als volgt:
NAS (192.168.1.177) waar ik mijn bestanden op heb kan ik meestal niet benaderen met mijn laptop als ik draadloos verbonden ben met netwerk.
Ik kan de locatie wel zien maar wanneer ik deze selecteer krijg ik " KAN DE LOCATIE NIET BENADEREN. Kon lijst van gedeelde mappen niet van server opvragen: Verbinding is geweigerd."

Alleen heel soms kan ik de locatie wel openen en zie ik alle bestanden die erin staan.

Wanneer ik ping krijg ik gewoon "64 bytes from 192.168.1.177: icmp_seq=477 ttl=32 time=1.98 ms" te zien.

Wanneer ik een Windows laptop pak kan ik wel de NAS benaderen.

Kan iemand mij helpen wat te doen?
Dank

 

Online MKe

  • Lid
  • Steunpunt: Nee
Re: Kan NAS niet benaderen
« Reactie #1 Gepost op: 2015/01/06, 20:17:46 »
Belangrijk is het protocol waarmee je de mount doet. Onder windows is dat standaard onder smb protocol. Veel Nassen zijn dan ook ingesteld om via smb(samba) de shares te maken. Bij linux is het standaard protocol nfs. Je kunt dit op twee manieren oplossen. Je kunt op de nas nfs sharing aanzetten of je kunt smb op linux activeren door cifs te installeren.

Een andere minder bekende manier is om verbinding te zoken via ftp of ssh. De standaard filebrowser in Ubuntu, Nautilus kan dit prima voor je doen. Er is ergens een optie dat je kunt verbinden met een remote server. Voorwaarde is wel dat je een user hebt die met ssh of ftp verbinding kan maken met de NAS.

Offline svv1972

  • Lid
Re: Kan NAS niet benaderen
« Reactie #2 Gepost op: 2015/01/08, 19:25:06 »
Hallo,

Ik heb een aanpassing gedaan in fstab maar krijg geen toegang tot NAS.
fstab ziet er nu als volgt uit:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=df10a77e-81f5-4103-9c0a-b9e26a508dff /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=5dfce5ed-c425-4cdf-abf3-79f9b8743aae none            swap    sw              0       0

//192.168.1.177/SVV_FND/VEGHEL /media/NAS/VEGHEL cifs username=sander,password=xxxxxxxx,
rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0

Wanneer ik nu naar die betreffende schijf ga krijg ik de volgende melding:
Geen toegang tot 'VEGHEL'
mount: alleen root kan //192.168.1.177/SVV_FND/VEGHEL aankoppelen op /media/NAS/VEGHEL

Weet iemand wat nu te doen?

Alvast bedankt.




Offline svv1972

  • Lid
Re: Kan NAS niet benaderen
« Reactie #3 Gepost op: 2015/01/13, 10:29:09 »
Hoi,

@Femke:
Ik heb gedaan wat jij in je bericht hebt aangegeven. Wat je precies bedoelt met die nummertjes is voor mij nu nog te moeilijk.
Ik zal je de fstab file toevoegen. Misschien kun je daar wat meer op zien. (Tenminste zou fijn zijn als jij me weer wat verder kan helpen)

Offline McVries

  • Lid
  • Steunpunt: Nee
Re: Kan NAS niet benaderen
« Reactie #4 Gepost op: 2015/01/13, 10:51:18 »
//servernaam.local/share/DataG$ /media/dataG cifs users,credentials=/home/username/.creds/.creds,rw,noperm 0 0

Om de "alleen root mag..." melding op te lossen kun je iig de onderstreepte optie "users" toe voegen. de rw opie maakt de share read write, noperm gebruik ik om dat het hier om een windows server gaat die niks snapt van linux file permissies
« Laatst bewerkt op: 2015/01/13, 10:54:53 door McVries »
_________________________________
Ubuntu Gnome