Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: opnieuw installeren digikam  (gelezen 295 keer)

Offline miel

  • Lid
  • Steunpunt: Nee
opnieuw installeren digikam
« Gepost op: 2014/12/25, 15:18:59 »
Vorige versie van digikam mbv synaptic package manager verwijderd. Daarna nieuwe versie digikam 4.6.0 download met bedoeling te installeren. Dat proces hapert en levert mededeling: you have broken packages.
In synaptic P. manager gekeken welke broken packages. Levert 'digikam'als broken package. Dit verwijderd. Maar installatie digikam 4.6.0  blijft op zelfde mededeling hangen.

Bestaat er een oplossing anders dan UBUNTU opnieuw te installeren?
Miel 

Offline Ramana

  • Lid
  • Steunpunt: Nee
Re: opnieuw installeren digikam
« Reactie #1 Gepost op: 2014/12/25, 15:31:50 »
Zijn alle oude bestanden van digikam verwijderd? Kijk eens wat sudo apt-get autoremove toont.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: opnieuw installeren digikam
« Reactie #2 Gepost op: 2014/12/25, 16:16:38 »
Houd er wel rekening mee dat het om een experimentele versie gaat. https://launchpad.net/~philip5/+archive/ubuntu/extra
Het installeren van Digikam 4.6 staat beschreven op http://linuxg.net/how-to-install-digikam-4-6-0-on-ubuntu-14-10-ubuntu-14-04-and-derivative-systems/

Daar staat echter ook
Citaat
DigiKam 4.6.0 can be also installed on non-KDE Ubuntu 14.10, Ubuntu 14.04 derivatives like Elementary OS 0.3 Freya, Peppermint Five, Deepin 2014, Linux Lite 2.0, Deepin 2014, LXLE 14.04, Pinguy OS 14.04 via the ppa:philip5/extra PPA, but will install a lot of KDE libraries, so it is not recommended.


Dus geen echte aanrader. Desalniettemin heb ik dit even uitgeprobeerd met Ubuntu 14.10. Hier heb ik geen "broken packages" meldingen gezien. Digikam 4.6 start wel gewoon op.

Voor die gebroken pakketten check je bijvoorbeeld deze hyperlink http://iasptk.com/ubuntu-fix-broken-package-best-solution/

« Laatst bewerkt op: 2014/12/25, 16:19:59 door jolo »
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline miel

  • Lid
  • Steunpunt: Nee
Re: opnieuw installeren digikam
« Reactie #3 Gepost op: 2014/12/27, 09:09:51 »
Hallo, Ramana en jolo,

om ook de laatste resten van digikam te verwijderen heb ik alle adviezen en tips, inclusief jullie tips uitgevoerd. Ook heb ik de ppa van Philip Johnsson waarin verschillende versies van digikam verwijderd. Voorts heb ik het zg broken package van digikam handmatig verwijderd en toch krijg ik nog steeds de zelfde melding wanneer ik probeer om een nieuw gedownloade versie van digikam te installeren.

>Package dependencies cannot be resolved<

>This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time. <

Wanneer ik "showfoto"tracht te installeren zie ik de zelfde melding:
>details: showfoto: Depends: digikam (= 4:4.6.0-trusty~ppa1kde414) but 4:4.6.0-trusty~ppa1kde414 is to be installed
          Depends: libqtcore4 (>= 4:4.7.0~beta1) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed
          Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed<

Ik ga nu proberen die dependencies te vinden en te installeren.
Als het lukt en ik slaag er in om Digikam weer op de rails te krijgen zal ik het laten weten.
groet, Miel