Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Libreoffice Calc koppelingen tussen werkbladen verdwijnen  (gelezen 509 keer)

Offline Bieuwe

  • Lid
    • Bieuwe en Rudy's Place on the web
  • Steunpunt: Nee
Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Gepost op: 2014/12/24, 09:36:39 »
Beste mensen,

sinds enige tijd heb ik regelmatig het probleem dat de koppelingen tussen werkbladen in libreoffice calc in eens helemaal verdwenen zijn. Wat ik bedoel is dat ik in werkblad2 een waarde overneem van werkblad1, dit staat in de cel van werkblad2 dus als: =werkblad1.c76 zo ver is er niks aan de hand, maar ik heb nu al verschillende keren gehad dat bij het opnieuw openen van het bestand in werkblad2 in eens alleen nog maar staat =c76, dus zonder verwijzing naar werkblad1. De waarde staat er nog wel, maar die verdwijnt zodra ik iets op werkblad2 ga wijzigen en wordt natuurlijk ook niet geupdate als ik de cel in werkblad1 aanpas.

Heeft iemand enig idee waar dit probleem het gevolg van kan zijn?

Alvast bedankt voor de hulp.

groeten Bieuwe

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #1 Gepost op: 2014/12/24, 09:48:32 »
Misschien is er een refresh(verversen) knop ergens, om de waardes door te sturen.

Offline JohPoe

  • Lid
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #2 Gepost op: 2014/12/24, 10:33:35 »
Een gok.
Als ik in een werkblad de formule =Blad1.A1 ga invoeren en het bestand ga opslaan wijzigt LO de formule in $Blad1.A1.  Het dollarteken komt er dus voor. Er is dus een autocorrectie bij het opslaan en misschien is die correctie bij jou de oorzaak dat de formule =A1 is geworden. Probeer het eens met het dollarteken in de formule te plaatsen.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #3 Gepost op: 2014/12/24, 12:25:31 »
Welke versie van LibreOffice? Kan ik niet reproduceren op LO 4.3.3.2 (standaard versie van Ubuntu 14.10).

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #4 Gepost op: 2014/12/24, 12:32:08 »
Ik had het natuurlijk kunnen denken: je bewaart als Microsoft xls of xlsx. Bij het uitschrijven naar die formaten wordt de verwijzing omgezet naar een absoluut adres. Of dat een bug is dan wel een beperking in de vertaalslag weet ik niet. Ik kan echter niet reproduceren dat hij ook de werkbladverwijzing verliest.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #5 Gepost op: 2014/12/24, 12:40:51 »
Dan toch heb je mogelijk te maken met een bug die niet te maken heeft met het vertalen naar een ander bestandsformaat: https://www.libreoffice.org/bugzilla/show_bug.cgi?id=87231. Zou moeten opgelost zijn via https://www.libreoffice.org/bugzilla/show_bug.cgi?id=87231 (waar het over sorteren gaat). Nogal kritische bug vind ik die de kernfunctionaliteit van het rekenblad treft. Als het dat is, zal je moeten upgraden via de PPA's van libreoffice.

Offline Bieuwe

  • Lid
    • Bieuwe en Rudy's Place on the web
  • Steunpunt: Nee
Re: Libreoffice Calc koppelingen tussen werkbladen verdwijnen
« Reactie #6 Gepost op: 2014/12/25, 11:50:59 »
Beste mensen,

bedankt voor de reacties. Ik krijg nu net een update van LO binnen, dus ik ga nog weer even afwachten of dat werkt, anders ga ik inderdaad eerst eens met de dollartekens proberen. Het heeft in elk geval zeker niets met Excel bestanden te maken, aangezien ik deze bestanden alleen in LO open en dus opsla als Open Document.

Als het probleem op is gelost of alsnog voor blijft komen, dan hou ik jullie op de hoogte.

groeten Bieuwe