Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 403 Forbidden You don't have permission to access ...na update Kubuntu 12  (gelezen 753 keer)

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Hallo

Ik had eerst Kubuntu 12.04. IK had hier een webserver op ge├»nstalleerd voor ontwikkelingen.  Alles ging goed.
Ik heb deze geupgraded naar Kubuntu 14.04.
Als ik nu naar mijn localhost wil gaan krijg ik:
Forbidden

You don't have permission to access / on this server.

Mijn webbestanden staan onder: /media/sdb1/website/

Waarom werkt dit niet meer na upgrade en hoe kan ik dit oplossen?

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Ik heb gekeken onder /var/log/apache2/error.log. De laatste 2 regels zijn:
[Tue Dec 23 16:10:51.133488 2014] [authz_core:error] [pid 5056] [client 127.0.0.1:49992] AH01630: client denied by server configuration: /media/sdb1/website/
[Tue Dec 23 16:10:58.877539 2014] [authz_core:error] [pid 5057] [client 127.0.0.1:49993] AH01630: client denied by server configuration: /media/sdb1/website/

Kan dit al meer duidelijkheid brengen?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Joris,

Controlleer eens of de configuratie bestand voor Apache niet veranderd is.
Standaard is de map waarin Apache kijk "/var/www/html" en niet "/media/sdb1/website".

Mocht deze configuratie bestand toch goed staan, controlleer ook of de rechten en gebruiker/groep goed staan op "/media/sdb1/website"
MvG,
MauRice
Registered Linux user: 473556

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Joris,

Controlleer eens of de configuratie bestand voor Apache niet veranderd is.
Standaard is de map waarin Apache kijk "/var/www/html" en niet "/media/sdb1/website".

Ik had dit in de vorige versie van kubuntu zelf al veranderd naar /media/sdb1/website, de instellingen van apache aangepast, en het wekte!!! En nu na upgrade niet meer!

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Joris,

Controlleer eens of de configuratie bestand voor Apache niet veranderd is.
Welk bestand is dit juist?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Joris,

Controlleer eens of de configuratie bestand voor Apache niet veranderd is.
Welk bestand is dit juist?
Joris,

Tja, voor mij is het een tijdje geleden maar die configuratie bestand voor apache kan zitten in:
/etc/httpd/...
of
/etc/apache2/...

Blijkbaar heb je die eerder ook eens aangepast:
Citaat
Ik had dit in de vorige versie van kubuntu zelf al veranderd naar /media/sdb1/website, de instellingen van apache aangepast, en het wekte!!! En nu na upgrade niet meer!
Kijk eens of je in de map geen httpd.conf.bak of httpd.conf.backup heb met de instellingen van voor de upgrade.



« Laatst bewerkt op: 2014/12/23, 17:24:53 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Kijk eens of je in de map geen httpd.conf.bak of httpd.conf.backup heb met de instellingen van voor de upgrade.

Ik vind deze bestanden helaas niet terug! :-(

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Kijk eens of je in de map geen httpd.conf.bak of httpd.conf.backup heb met de instellingen van voor de upgrade.

Ik vind deze bestanden helaas niet terug! :-(
Joris,

De httpd.conf die je wel vind, staat daarin nog dat Apache moet kijken naar "/media/sdb1/website".
Als dat goed staat, dan vermoed ik dat de rechten van "/media/sdb1/website" niet goed staan.
Maw de gebruiker - groep staan niet goed en/of de toegang om te lezen(schrijven) staan niet goed.
« Laatst bewerkt op: 2014/12/23, 19:37:58 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
De configuratie van Apache is tussen versie 2.2 en 2.4 (Ubuntu 12.04 en 14.04) op verschillende manieren aangepast.
Als extra veiligheid geeft Apache nu geen toegang meer tot alles buiten /var/www en verder zijn er een aantal configuratiebestanden omgegooid.

Het makkelijkste is om een symlink of bind-mount naar /media/sdb1/website te maken zodat die bereikbaar wordt als een map in /var/www

Zo niet, dan zal je de apache configuratie (apache2.conf en een aparte virtualhost) aan moeten passen.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Ik heb deze geupgraded naar Kubuntu 14.04.
Zie de releasnotes 14.04 https://wiki.ubuntu.com/TrustyTahr/ReleaseNotes#Known_issues

Er is een upgrade van Apache 2.2 naar 2.4, zie de releasenotes van Apache 2.4
Citaat van: apache2.NEWS
We did change the security model for Apache in our default configuration. We do not allow access to the file system outside /var/www and /usr/share.
If you are running virtual hosts or scripts outside these directories, you need to whitelist them in your configuration to grant access through HTTP.
Kan dit er mee te maken hebben?
Edit: post van Johan 3 minuten eerder niet gezien. :)
« Laatst bewerkt op: 2014/12/23, 21:14:21 door testcees »
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Re: 403 Forbidden You don't have permission to access ...na update Kubuntu 12
« Reactie #10 Gepost op: 2014/12/23, 20:49:31 »
Dit:

Zo niet, dan zal je de apache configuratie (apache2.conf en een aparte virtualhost) aan moeten passen.
Zou ik het lietst willen doen maar weet nog niet hoe.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: 403 Forbidden You don't have permission to access ...na update Kubuntu 12
« Reactie #11 Gepost op: 2014/12/23, 21:04:00 »
apache2.conf aanpassen:
<Directory /media/sdb1/website/>
       Options Indexes FollowSymLinks
       AllowOverride None
       Require all granted
</Directory>
Dit stukje toevoegen op de plek waar ook de andere directory's staan.

Verder moet je in /etc/apache/sites-enabled je bestaande configuratie aanpassen. Hoe je dat in moet stellen hangt af van hoe je het nu ingesteld hebt. Je moet in ieder geval wel opletten dat het bestand eindigt op .conf.

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
Re: 403 Forbidden You don't have permission to access ...na update Kubuntu 12
« Reactie #12 Gepost op: 2014/12/23, 21:15:51 »
Bedankt Johan van Dijk! Nu werkt het!