Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gebroken pakketten in MINTCinnamon 17.1  (gelezen 1746 keer)

Offline seghele

  • Lid
  • Steunpunt: Nee
Gebroken pakketten in MINTCinnamon 17.1
« Gepost op: 2014/12/15, 15:34:20 »
Heb heel waarschijnljk iets gedaan dat niet moest!
Krij nu volgende errors:
$ sudo apt-get -f install
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... mislukt.
De volgende pakketten hebben niet-voldane vereisten:
 liblcms2-2 : Breekt: liblcms2-2:i386 (!= 2.6-3+b3) maar 2.5-0ubuntu4 is geïnstalleerd
 liblcms2-2:i386 : Breekt: liblcms2-2 (!= 2.5-0ubuntu4) maar 2.6-3+b3 is geïnstalleerd
E: Fout, pkgProblemResolver::Resolve maakte scheidingen aan, dit kan veroorzaakt worden door vastgehouden pakketten.
E: Kan vereisten niet corrigeren

 $ sudo dpkg --configure -a
[sudo] password for seghers:
dpkg: error processing package liblcms2-2:amd64 (--configure):
 package liblcms2-2:amd64 2.6-3+b3 cannot be configured because liblcms2-2:i386 is at a different version (2.5-0ubuntu4)
dpkg: error processing package liblcms2-2:i386 (--configure):
 package liblcms2-2:i386 2.5-0ubuntu4 cannot be configured because liblcms2-2:amd64 is at a different version (2.6-3+b3)
Fouten gevonden tijdens behandelen van:
 liblcms2-2:amd64
 liblcms2-2:i386
 :-X
Kan dus ook geen updates meer bekomen.
Graag een oplossing aub.
 ???

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #1 Gepost op: 2014/12/15, 15:35:48 »
Gebruik je de standaard-spiegelserver? Zo niet, alsnog doen en opnieuw proberen.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #2 Gepost op: 2014/12/15, 20:18:35 »
Had volgende topic aangemaakt op Linux-Mint forum.
Citaat
Zou een update van simple-scan willen installeren.
Namelijk: 3.14.0.
Blijkbaar heb ik een update nodig van "libcolord2".
Mag ik dan libcolord2_1.2.1-1ubuntu1_amd64.deb installeren, zonder problemen?
Kreeg als antwoord:
Citaat
Bericht Re: Mint 17 Simple-scan
Je mag alles installeren zonder problemen.
Heb dan terug volgende aangegeven:
Citaat
Maar..."libcolord2_1.2.1" heeft op zijn beurt een andere "liblcms2" nodig, enz...
:o
Citaat
En anders start je je pc op, in de grub kies je voor recovery en daar kan je weer kiezen voor gebroken pakketten repareren.
Dit heb ik gedaan zonder resultaat!!!
Citaat
ga naar Synaptic en kies voor Aangepaste filters en kijk of daar pakketten staan die defect zijn. Vink die aan en klik op Toepassen.
Sorry, dit is niet duidelijk genoeg voor mij!
Mag ik hopen dat het voor de helpers op dit forum nu een beetje duidelijker wordt.
 :-[
Veronderstel dat ik een TE nieuwe versie op de pc heb van liblcms2 enz... en dat er nog enkele andere libs een nieuwere versie nodig hebben.
Of kan ik terug een stap achteruit doen???

Offline loti

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #3 Gepost op: 2014/12/15, 21:32:58 »
Heeft het soms met het volgende probleem te maken?

http://blog.linuxmint.com/?p=2737

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #4 Gepost op: 2014/12/16, 10:31:24 »
loti,
De settings staan juist. Ik krijg nog steeds de errors.
 ;)
Hopelijk kan een "steunpunt" mij toch nog helpen?
 ???

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #5 Gepost op: 2014/12/16, 13:49:56 »
Citaat
Gebruik je de standaard-spiegelserver? Zo niet, alsnog doen en opnieuw proberen.
Dit is voor mij chninees...wat is een standaard-spiegelserver?
Citaat
Edit: wat probeer je te installeren eigenlijk?
Wazt ik probeerde te installeren was de nieuwe simple-scan.
Citaat
Open synaptic en zie dan aan de linkerkant een rijtje staan, Onderdelen, Status etc. en klik dan op Aangepaste filters. Dan zie je daarboven verschijnen in een rijtje Defect.
Bedankt, gevonden. Er staan twee bestanden:
liblcms2-2 ... 2.6-3+b3
liblcms2-2:i386 ... 2.5-0ubuntu4
Beiden hebben een rode knop.
Wat moet ik hier dan doen?
Citaat
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get clean
Dit geeft ERROR:
De volgende pakketten hebben niet-voldane vereisten:
 liblcms2-2 : Breekt: liblcms2-2:i386 (!= 2.6-3+b3) maar 2.5-0ubuntu4 is geïnstalleerd
 liblcms2-2:i386 : Breekt: liblcms2-2 (!= 2.5-0ubuntu4) maar 2.6-3+b3 is geïnstalleerd
E: Er zijn vereisten waaraan niet voldaan is. Probeer -f te gebruiken.
 :(
Hopelijk is mijn uitleg al iets duidelijker!
 ;)


Offline staf

  • Lid
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #6 Gepost op: 2014/12/16, 14:47:58 »
Je bent 32 en 64 bits aan het vermengen, verwijder wat je niet nodig hebt.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #7 Gepost op: 2014/12/16, 18:37:47 »
Citaat
Je bent 32 en 64 bits aan het vermengen, verwijder wat je niet nodig hebt.
Als ik in Synaptic de liblcms2-2:i386 ... 2.5-0ubuntu4 aanklik om te verwijderen dan krijg ik een venster met te verwijderen: Wine 1.7.
Dit is toch niet wat ik wens!!!
 :(
De zaak is veel moeilijker dan dat het lijkt.
Moet ik dan inderdaad de twee bestanden verwijderen, met nieuwe gevolgen.... ?
En wat moet ik dan opnieuw installeren?
 :(

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #8 Gepost op: 2014/12/17, 16:22:01 »
Mag ik toch nog hopen op een expert van Linux op dit forum?
Ik kan wel begrijpen dat het hier niet om een eenvoudige topic gaat.  ???
Daar ik geen updates meer kan doen is dit een vervelende zaak.
!!!
Ik hoop dat ik niet verplicht word om MINT terug te moeten installeren.
 ;)

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #9 Gepost op: 2014/12/17, 17:14:29 »
Hallo seghele,
misschien dat het volgende je probleem zal oplossen:
 Ga naar... softwarebronnen/ onderaan staat Onderhoud / verwijder achtergebleven instellingen
Ik heb nooit dergelijke foutmeldingen gehad, maar ik ga voor je zoeken naar een oplossing..

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #10 Gepost op: 2014/12/18, 11:27:45 »
Eindelijk een kleine oplossing.
BEDANKT.
Citaat
Ga naar... softwarebronnen/ onderaan staat Onderhoud / verwijder achtergebleven instellingen
Heb ik gedaan en kan nu zonder error sudo apt-get update en sudo apt-get dist-upgrade.
 :)
MAAR ... nu is "Wine" verdwenen, en deze heb ik nodig voor enkele windows-exe's.
 :'(
Heb volgende gedaan:
$ sudo apt-get install wine winetricks
[sudo] password for seghers:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 wine : Vereisten: wine1.6 maar het zal niet geïnstalleerd worden of
                   wine1.7 maar het zal niet geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
...
en
...
$ sudo apt-get install wine1.7
[sudo] password for seghers:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 wine1.7 : Vereisten: wine1.7-i386 (= 1:1.7.32-0ubuntu1~ppa1)
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
Mag ik sterk hopen dat je hiervoor een oplossing bestaat?
 ;)



Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #11 Gepost op: 2014/12/18, 17:54:49 »
Je kan Wine ook via softwarebeheer installeren
Echter, er zit volgens mij een bug in Mint 17.1

Versie: 1:1.6.2-0ubuntu4

Grootte: 16MB om binnen te halen, 121MB schijfruimte nodig

Gevolg voor pakketten:
De volgende pakketten zouden worden geïnstalleerd: ocl-icd-libopencl1, wine1.6-i386, wine1.6

De volgende pakketten zouden worden verwijderd: nvidia-libopencl1-331 Dit is volgens mij een bug

De volgende oplossing geeft deze verwijder melding  niet:
sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.7
« Laatst bewerkt op: 2014/12/18, 17:56:36 door RikRik »

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #12 Gepost op: 2014/12/18, 18:39:48 »
$ sudo add-apt-repository ppa:ubuntu-wine/ppa
Dit ging normaal.
$ sudo apt-get update
Dit ging normaal.
[$ sudo apt-get install wine1.7
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:
De volgende pakketten hebben niet-voldane vereisten:
 wine1.7 : Vereisten: wine1.7-i386 (= 1:1.7.32-0ubuntu1~ppa1)
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
Dus, dit werkt niet!!!

Citaat
Je kan Wine ook via softwarebeheer installeren
Met mijn beperkte kennis was ik toch al op de hoogte van deze mogelijkheid.
Maar ... daar staat:
Citaat
Gebruik a.u.b. apt-get om dit pakket te installeren. Niet beschikbaar.   
:o
Mag ik nogmaals duidelijk maken voor de mensen die mij trachten te helpen dat deze zaak NIET eenvoudig is op te lossen.
Misschien kan een van de experten op dit forum een vraag stellen aan de "makers" van MINT of dit wel degelijk een BUG is of niet.
 ???


Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #13 Gepost op: 2014/12/18, 19:00:39 »
Had je wel eerst met bestandsbeheer de map .wine  verwijderd? Je zou als laatste optie, als het echt niet gaat lukken, Linux Mint opnieuw kunnen installeren. De installatie van een Linux systeem gaat snel en gemakkelijk.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketten in MINTCinnamon 17.1
« Reactie #14 Gepost op: 2014/12/19, 12:09:58 »
Bedankt voor de reactie.
Heb alles gedaan wat ik kon, echter zonder positief resultaat.
Zal Mint terug moeten installeren.
 :rolleyes: