Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstartproblemen Grub Xubuntu  (gelezen 424 keer)

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Opstartproblemen Grub Xubuntu
« Gepost op: 2014/12/12, 13:48:26 »
Met enige regelmatig wil of Windows 7 of Xubuntu 12 niet doorstarten tijdens het opstarten.
Omdat ik soms wel drie tot vier keer moet opstarten voordat er wat doorstart heb ik Grup gerepareerd via de terminal, aanvankelijk met succes maar nu is het weer mis: er start helemaal niks meer op.
Daarom ik er een CD met Boot Repair Disk Ubuntu op losgelaten en nu werkt alles weer probleemloos, maar....

In het Grub menu is er nu een opstartregel bijgekomen en dat snap ik niet  8-)

Stond er eerst als onderste opstartregel: Windows 8 (loader) on (dev/sda1)
Nu is er bij gekomen: Windows 8 (loader) on (dev/sda2)
Maakt niet uit welke ik nu kies, ze doen het beiden  :P
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline PKing

  • Lid
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #1 Gepost op: 2014/12/12, 14:22:00 »
Het lijkt erop dat de loader nu ook op de tweede schijf/partitie staat, volgens mij hoort dat niet, maar als het werkt zou ik me er niet erg druk om maken?
Hoofdmachine AMD t1055 6core 8gb mem 1333DDR3 Xubuntu 14.04 64bit/HP SFF desktop Xubuntu 14.04 32bit/HP Pavilion 2 core 2GB Xubuntu 16.04

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #2 Gepost op: 2014/12/12, 15:50:28 »
Nee, ik maak me er niet druk om maar wil het wel proberen te begrijpen  O0
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline PKing

  • Lid
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #3 Gepost op: 2014/12/12, 22:56:29 »
lol je heb waarschijnlijk bootrepair gestart en de bovenste knop ingedrukt.
Dat gaat bootrepair waarschijnlijk dat doen waar het voor gemaakt is, op elke HD waar het een OS vind een bootsector aanmaken en die in de GRUB zetten :evil:
Hoofdmachine AMD t1055 6core 8gb mem 1333DDR3 Xubuntu 14.04 64bit/HP SFF desktop Xubuntu 14.04 32bit/HP Pavilion 2 core 2GB Xubuntu 16.04

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #4 Gepost op: 2014/12/13, 10:41:12 »
Juist, dat heb ik gedaan!
Krijg ik die extra opstartregel weer weg ?
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Opstartproblemen Grub Xubuntu
« Reactie #5 Gepost op: 2014/12/13, 17:58:31 »
Welke optie was dan? In deze hyperlink zie ik niet zo snel een optie, die 2 Windows opstartregels kan veroorzaken.

Ik zou in ieder geval de output willen zien van
sudo os-prober
Als in die output slechts één  Windows opstartregel toont, kun je het volgende commando uitvoeren
sudo update-grub
Post eventueel de output van
sudo fdisk -l
en

sudo parted -l
Als het goed is zou maar één opstart/boot flag moeten zijn per harddisk. Ook zouden de boot bestanden van Windows maar op één partitie behoren te staan. Deze dus
Boot  bootmgr  BOOTSECT.BAK  System Volume Information
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #6 Gepost op: 2014/12/13, 18:10:56 »
Het is precies die afbeelding met de bovenste optie (Nederlands) jolo.

De output van  sudo os-prober is:
/dev/sda1:Windows 8 (loader):Windows:chain
/dev/sda2:Windows 8 (loader):Windows1:chain

De opdrachtregel:  Boot  bootmgr  BOOTSECT.BAK  System Volume Information
Begrijpt de terminal niet.

Om misverstanden te voorkomen. Het systeem is voorzien geweest van een OS Windows 8, maar dat was ik na drie maanden zo verschrikkelijk beu dat ik OS windows 7 er weer op heb gezet en dat Windows 8 (loader) is om voor mij duistere reden erin gebleven.
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Opstartproblemen Grub Xubuntu
« Reactie #7 Gepost op: 2014/12/13, 20:25:47 »
Die code was geen opdracht regel, maar  Windows 7 boot bestanden van die 100 MiB grote systeem partitie. Of eigenlijk alleen die bootmgr en die Boot map.

Ik heb het op mijn testpc kunnen reproduceren. Ook hier krijg ik 2 Windows opstartregels. Blijkbaar kopieert die tool boot bestanden naar de Windows partitie, waarop onder andere de Program Files map op staat. Die bootmgr en Boot map kun je gewoon verwijderen vanuit Xubuntu' Bestandsbeheer Thunar.

Dan doe weer
sudo os-prober
en

sudo update-grub
Ik heb dit getest. Weliswaar met Windows 7 Home Premium. Alleen zal Windows bij de eerste start daarna chkdsk willen uitvoeren. Sta dit gewoon toe.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Opstartproblemen Grub Xubuntu
« Reactie #8 Gepost op: 2014/12/13, 23:44:44 »
Gedaan zoals je vroeg en het resultaat is prachtig. Ik ben je erkentelijk voor je hulp !
Helemaal gefixt. Windows 7 heeft overigens niet om een chkdsk gevraagd.
Morgen maar gauw een systeem image maken en dan ben ik weer helemaal bij en blij :)
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.