Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: intellipark uitschakelen bij WD Green  (gelezen 396 keer)

Offline Allard

  • Lid
  • Steunpunt: Nee
intellipark uitschakelen bij WD Green
« Gepost op: 2014/12/04, 13:59:36 »
Ik heb zojuist een nieuwe interne hard disk in laten bouwen en een schone installatie gedaan van Ubuntu 14.04. Echter lees ik nu achteraf dat de Western Digital Green harde schijven over een bepaalde functie beschikt dat in Linux niet optimaal werkt daardoor de Load Cycle Count in een rap tempo oploopt.

Ik heb daarvoor de volgende fix uitgevoerd zodat de Load Cycle Count niet zo snel meer oploopt:
https://wiki.manjaro.org/index.php?title=Western_Digital_Green_-_Drive_Fix_-_Linux

Zijn er hier meerdere mensen die zo'n WD Green hebben in Linux?

Edit: Deze ingreep is niet geheel zonder waarschuwing, deze fix verandert in feite een functie in de firmware van de schijf zodat intellipark uitgeschakeld wordt.
« Laatst bewerkt op: 2014/12/04, 21:07:03 door Allard »
PC: MSI H110M PRO-VD,   Intel Core i5 6600,  8GB DDR4,  MSI GTX 960 4GB Gaming,  Crucial BX100 250GB, Samsung 850 EVO 500GB  -- Ubuntu 16.04 LTS 64-bit --
Acer Aspire V3-771:  Intel Core i5 3230M,  6GB DDR3,  Intel HD 4000 Graphics,  Crucial BX100 500GB  -- Ubuntu 16.04 LTS 64-bit --

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #1 Gepost op: 2014/12/04, 15:01:26 »
De "parkeerklik des doods"....
https://sites.google.com/site/computertip/fouten#TOC-Sommige-laptops:-parkeerklik-slijtage-vermijden
(punt 15, rechterkolom)

Die oplossing op mijn webstek, heb ik bij de meeste van mijn flaptops en netboekjes moeten gebruiken.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #2 Gepost op: 2014/12/04, 18:58:25 »
Ik weet niet of dit hetzelfde probleem is; volgens mij is het WD Green issue een apart geval.
Jouw oplossing werkt wel, maar dan moet je waarschijnlijk hdparm -B 255 instellen en dan schakel je het PM helemaal uit. Terwijl dat niet hoeft; zie de link van Allard.

De "parkeerklik des doods"....
https://sites.google.com/site/computertip/fouten#TOC-Sommige-laptops:-parkeerklik-slijtage-vermijden
(punt 15, rechterkolom)

Die oplossing op mijn webstek, heb ik bij de meeste van mijn flaptops en netboekjes moeten gebruiken.

Offline Allard

  • Lid
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #3 Gepost op: 2014/12/04, 20:04:03 »
Oh trouwens en wordt wel enigszins gewaarschuwd voor deze "fix". Je verandert namelijk met idle3ctl een instelling in de firmware. Net zoals je op Windows een speciaal bestand moet gebruiken van WD zelf om dit probleem op te lossen. Echter zegt hij dat ie nu keurig uitstaat dus ik ga er vanuit dat het ook zo is.

http://manpages.ubuntu.com/manpages/saucy/man8/idle3ctl.8.html
https://forum.manjaro.org/index.php?topic=16265.0

Citaat
Next step is to shutdown and power off your computer. Rebooting isn't enough! You need to power off, so the drive will turn on with the new settings.

Now check again:

$ sudo idle3ctl -g /dev/sda
and it should say disabled.

allard@ubuntu-pc-allard:~$ sudo idle3ctl -g /dev/sdb
[sudo] password for allard:
Idle3 timer is disabled

Zo te zien heeft het bij mij wel gewerkt.

Volgens mij heeft dit ook niks te maken met de "klik des doods". Dit is puur een geval van WD die iets in hun Green schijven hebben ingebouwd waardoor het op Linux niet helemaal goed zou werken. :(
« Laatst bewerkt op: 2014/12/04, 20:12:05 door Allard »
PC: MSI H110M PRO-VD,   Intel Core i5 6600,  8GB DDR4,  MSI GTX 960 4GB Gaming,  Crucial BX100 250GB, Samsung 850 EVO 500GB  -- Ubuntu 16.04 LTS 64-bit --
Acer Aspire V3-771:  Intel Core i5 3230M,  6GB DDR3,  Intel HD 4000 Graphics,  Crucial BX100 500GB  -- Ubuntu 16.04 LTS 64-bit --

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #4 Gepost op: 2014/12/04, 21:29:48 »
Ik heb hier ook een Western Digital Green harddisk. Namelijk een WD Green WD15EARX, 1.5TB. in de hoofd pc uit mijn onderschrift. Ubuntu 14.04.1 staat geïnstalleerd op mijn 240 GB SSD schijf, en functioneert die WD harddisk als een data schijf. Deze heeft inderdaad een hoge Load Cycle Count.
jolo@hoofd-pc:~$ sudo smartctl -A /dev/sda | grep "^193"
[sudo] password for jolo:
193 Load_Cycle_Count        0x0032   107   107   000    Old_age   Always       -       281496
De TS van deze topic beweert dat 300.000 het maximum is, waarna de harddisk aan vervanging toe is. De hoofd pc dus ook die WD harddisk, die ik dagelijks gebruik, kocht ik in september 2011. Ik heb tot nu toe geen workaround uitgevoerd voor die WD harddisk.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #5 Gepost op: 2014/12/05, 11:56:39 »
@Allard: En op Windows ook niet goed zou werken. In jou link van de Manjaro-wiki staat namelijk dat het ook op Windows kan voorkomen.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: intellipark uitschakelen bij WD Green
« Reactie #6 Gepost op: 2014/12/05, 12:27:37 »
Dat klopt: de WD Green problemen zijn niet specifiek Linux.