Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [14.04] Geluid werkt niet? Installeer veilig PulseAudio opnieuw!  (gelezen 639 keer)

Dit topic is voor mezelf bedoeld eigenlijk omdat ik dit graag ergens wou opslaan, om later eventueel er opnieuw gebruik van te kunnen maken. Maar misschien zijn anderen ook wel geïnteresseerd.

Eerst en vooral pulse verwijderen:
sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get clean && sudo apt-get autoremove
Dan herstarten of opnieuw aanmelden. Vervolgens:
rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload
pavucontrol
Eventueel terug opnieuw herstarten of aanmelden.

Nu is helaas de icoon kwijt die in de tray staat, maar kan weer makkelijk terug gehaald worden:
sudo apt-get install unity-control-centerNa herstarten of opnieuw aanmelden heb je de icoon terug.

Als het geluid nog steeds niet werkt, kijk dan even of alle plugins voor pulse zijn verwijderd. Voorbeeld: PulseAudio Equalizer

Getest op ubuntu 14.04.1
Niet getest op xubuntu, lubuntu, mint, opensuse, etc.
Werkt waarschijnlijk wel op xubuntu, maar icoon terug halen in de tray moet je sowieso met een andere regel gebruiken omdat dit alleen voor unity is.
« Laatst bewerkt op: 2014/11/21, 13:52:31 door ubuntunoob »

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: [14.04] Geluid werkt niet? Installeer veilig PulseAudio opnieuw!
« Reactie #1 Gepost op: 2014/11/21, 09:55:39 »
Dat is een mooie gift :)  maar werkt dit (vraag) voor alle Ubuntu varianten, zoals Xubuntu en Mint ?
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline PKing

  • Lid
  • Steunpunt: Ja
Re: [14.04] Geluid werkt niet? Installeer veilig PulseAudio opnieuw!
« Reactie #2 Gepost op: 2014/11/21, 11:54:27 »
Zover ik weet zat een verhaal van deze strekking al eens in een link gegeven door Femke in een topic over mijn geluids problemen.

Uiteindelijk heeft het niet geholpen, de truc bij mij is zo min mogelijk opstarten:)
Hoofdmachine AMD t1055 6core 8gb mem 1333DDR3 Xubuntu 14.04 64bit/HP SFF desktop Xubuntu 14.04 32bit/HP Pavilion 2 core 2GB Xubuntu 16.04

Re: [14.04] Geluid werkt niet? Installeer veilig PulseAudio opnieuw!
« Reactie #3 Gepost op: 2014/11/21, 13:50:37 »
Damned! Ik was een paar belangrijke regels vergeten die je moest  uitvoeren in terminal, anders zal het geluid uiteraard nog niet werken! Ik heb dit nu aangepast.
En uiteraard is dit alleen getest op ubuntu.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: [14.04] Geluid werkt niet? Installeer veilig PulseAudio opnieuw!
« Reactie #4 Gepost op: 2014/11/21, 13:51:23 »
Sowieso werkt het minus de laatste stap ook alleen op Ubuntu want Ubuntu is de enige die unity-control-center heeft. De rest van de stappen werken op elk systeem dat PulseAudio gebruikt, oftewel de meeste (in ieder geval op Ubuntu- of Arch-gebaseerde) distro's.