Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: KToon en QT4  (gelezen 839 keer)

pdedecker

  • Gast
KToon en QT4
« Gepost op: 2007/03/26, 15:34:41 »
Ik probeerde zonet KToon te installeren, maar tijdens het uitvoeren van ./configure kreeg ik dit te zien:
Citaat
*  You're using Qt 3
 *  Please install Qt >= 4.1 or set QTDIR to Qt4 installation path
Wat nu? libqt4-core, libqt4-dev, libqt4-gui, libqt4-qt3support en libqt4-sql zijn al geïnstalleerd.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
KToon en QT4
« Reactie #1 Gepost op: 2007/03/27, 04:12:17 »
Zit Ktoon niet in de repositories?
Zet de universe en multiverse repo's eens aan, en zoek in adept/synaptic of het programma er tussen staat.

pdedecker

  • Gast
KToon en QT4
« Reactie #2 Gepost op: 2007/03/28, 11:46:43 »
apt-get geeft een foutmelding als ik het probeer op te halen.
Citaat
pdedecker@BETAubuntu:~$ sudo apt-get install ktoon
Password:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
Reading state information... Klaar
Pakket ktoon is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket ktoon heeft geen installeerbare kandidaat
pdedecker@BETAubuntu:~$

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
KToon en QT4
« Reactie #3 Gepost op: 2007/03/28, 12:16:59 »
Van hun forum:
Citaat
(2) If you want to compile KToon 0.8, you have to ensure that you have installed Qt 4.1.4 before, if you have Qt 4.2.* the compilation process will fail...
Welke versies heb jij geïnstalleerd, en heb je daarvan ook de -dev pakketten geïnstalleerd?

Zie ook hier
Hier is het ook niet gelukt.

pdedecker

  • Gast
KToon en QT4
« Reactie #4 Gepost op: 2007/03/28, 13:05:50 »
Dit is een overzicht van pakketten beginnend met 'libqt' die op mijn systeem staan:
Citaat
pdedecker@BETAubuntu:~$ dpkg -l libqt*
Gewenst=(U)Onbekend/Installeren/Remove/Purge/Hold
| Status=Niet/geInstalleerd/Config/Uitgepakt/(F)config-mislukt/Half-geinst
|/ Fout?=(geen)/Hold/Reinst nodig/X=beide (Status,Fout: hoofdlett=ernstig)
||/ Naam                         Versie                       Omschrijving
+++-============================-============================-========================================================================
un  libqt-dev                                           (geen beschrijving beschikbaar)
un  libqt-mt-dev                                       (geen beschrijving beschikbaar)
un  libqt-perl                                         (geen beschrijving beschikbaar)
un  libqt0-ruby1.8                                     (geen beschrijving beschikbaar)
un  libqt3                                             (geen beschrijving beschikbaar)
un  libqt3-compat-headers                               (geen beschrijving beschikbaar)
un  libqt3-dev                                         (geen beschrijving beschikbaar)
un  libqt3-emb                                         (geen beschrijving beschikbaar)
ii  libqt3-headers               3.3.6-3ubuntu3               Qt3 header files
un  libqt3-helper                                       (geen beschrijving beschikbaar)
un  libqt3-i18n                                         (geen beschrijving beschikbaar)
ii  libqt3-mt                    3.3.6-3ubuntu3               Qt GUI Library (Threaded runtime version), Version 3
ii  libqt3-mt-dev                3.3.6-3ubuntu3               Qt development files (Threaded)
un  libqt3-mt-mysql                                     (geen beschrijving beschikbaar)
un  libqt3-mt-odbc                                     (geen beschrijving beschikbaar)
un  libqt3-mt-psql                                     (geen beschrijving beschikbaar)
un  libqt3-plugins-headers                             (geen beschrijving beschikbaar)
un  libqt3c-mt                                         (geen beschrijving beschikbaar)
un  libqt3c102-mt                                       (geen beschrijving beschikbaar)
ii  libqt4-core                  4.2.0-1ubuntu6               Qt 4 core non-GUI functionality runtime library
un  libqt4-designer                                     (geen beschrijving beschikbaar)
ii  libqt4-dev                   4.2.0-1ubuntu6               Qt 4 development files
ii  libqt4-gui                   4.2.0-1ubuntu6               Qt 4 core GUI functionality runtime library
ii  libqt4-qt3support            4.2.0-1ubuntu6               Qt 3 compatibility library for Qt 4
ii  libqt4-sql                   4.2.0-1ubuntu6               Qt 4 SQL database module
ii  libqthreads-12               1.6.8-3                      QuickThreads library for Guile
Citaat van: "Johanvd"
Zie ook hier
Die persoon heeft een ander probleem volgens mij: hij had gewoon g++ niet geïnstalleerd.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
KToon en QT4
« Reactie #5 Gepost op: 2007/03/28, 21:30:51 »
Citaat van: Johanvd
Van hun forum:
Citaat
(2) If you want to compile KToon 0.8, you have to ensure that you have installed Qt 4.1.4 before, if you have Qt 4.2.* the compilation process will fail...
Citaat van: pdedecker
ii  libqt4-core                  4.2.0-1ubuntu6               Qt 4 core non-GUI functionality runtime library
un  libqt4-designer                                     (geen beschrijving beschikbaar)
ii  libqt4-dev                   4.2.0-1ubuntu6               Qt 4 development files
ii  libqt4-gui                   4.2.0-1ubuntu6               Qt 4 core GUI functionality runtime library
ii  libqt4-qt3support            4.2.0-1ubuntu6               Qt 3 compatibility library for Qt 4
ii  libqt4-sql                   4.2.0-1ubuntu6               Qt 4 SQL database module
ii  libqthreads-12               1.6.8-3                      QuickThreads library for Guile
[
Je hebt de verkeerde versies.
Het is wel mogelijk om oudere versies te installeren, maar dat wil ik je sterk afraden, omdat je daar meestal weer andere problemen van krijgt.

pdedecker

  • Gast
KToon en QT4
« Reactie #6 Gepost op: 2007/03/29, 08:06:41 »
Dus ik moet eigenlijk op zoek gaan naar een oudere versie van de 4.1-tak en die compileren? Kan ik die gewoon in een map laten staan, niet installeren en mijn PATH daar tijdelijk naar laten wijzen?