Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: printer problemen brother DCP-115c op lubuntu  (gelezen 1802 keer)

printer problemen brother DCP-115c op lubuntu
« Gepost op: 2014/11/13, 14:45:31 »
ik ben kortgeleden overgestapt van XP naar Lubuntu. Ik loop nu tegen het probleem aan dat de printer het niet wil doen, het betreft een brother dcp-115c. Het systeem heeft m wel herkent en als ik een testprint wil doen geeft de printer aan "receiving data" - verbinding is er dus wel, echter hij print niets uit. ik heb hier op de forum gekeken en gelijksoortige problemen gezien, alleen de bij behorende links in zo'n thread werken niet meer, ik loop dus vast..... heeft iemand een idee hoe ik dit kan oplossen.

bvd

arno

Offline PKing

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #1 Gepost op: 2014/11/13, 14:50:01 »
Je zou op de site van Brother een Linux driver kunnen proberen?
Hoofdmachine AMD t1055 6core 8gb mem 1333DDR3 Xubuntu 14.04 64bit/HP SFF desktop Xubuntu 14.04 32bit/HP Pavilion 2 core 2GB Xubuntu 16.04

Re: printer problemen brother DCP-115c op lubuntu
« Reactie #2 Gepost op: 2014/11/14, 09:14:06 »
ik heb op de site van brother gekeken en heb driver gedownload vervolgens heb ik onderstaande stappen getracht te doorlopen, tot stap 5 wil het nog, in de LXterminal krijg ik dan het volgende te zien: bestand of map bestaat niet. Ik heb wel 15 verschillende manieren geprobeerd om het apparaat te omschrijven maar krijg telkens hetzelfde bericht.



Step1
. Download the tool.(linux-brprinter-installer-*.*.*-*.gz)

The tool will be downloaded into the default "Download" directory.
(The directory location varies depending on your Linux distribution.)
e.g. /home/(LoginName)/Download

Step2.
Open a terminal window and go to the directory you downloaded the file to in the last step.

Step3
. Enter this command to extract the downloaded file:

Command: gunzip linux-brprinter-installer-*.*.*-*.gz

Step4
. Get superuser authorization with the "su" command or "sudo su" command.

Step5. Run the tool:

Command: bash linux-brprinter-installer-*.*.*-* Brother machine name

Step6.
The driver installation will start. Follow the installation screen directions.
 

When you see the message "Will you specify the DeviceURI ?",

For USB Users: Choose N(No)
For Network Users: Choose Y(Yes) and DeviceURI.

The install process may take some time. Please wait until it is complete.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #3 Gepost op: 2014/11/14, 16:15:07 »
@ariedebouwer : 
  - Wordt de printer ook correct weergegeven in:   Systeeminstellingen > Hardware > Afdrukbeheer
  - Vervolgens Eigenschappen (van de printer).
  - Klik achter  merk en model ,  op Veranderen... 
  - Selecteer een printer uit de database

Wat is er dan te zien, lijkt het op het onderste plaatje "stuurprogramma wijzigen" ? 

Ik weet niet of ik verder kan helpen, maar ik heb  ( in Linux Mint17 ) via Synaptic de brother printermodules opgehaald. Heb je die installatie-route (in een eerder stadium) zelf ook bewandeld - via Synaptic ?

[edit] : vervolgvraag - is CUPS goed geïnstalleerd ?
« Laatst bewerkt op: 2014/11/14, 16:25:15 door EZ-man »

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #4 Gepost op: 2014/11/14, 17:06:37 »
Bij stap 5 ging het mis bij jou.

Ik heb een Brother MFC-J6920DW en moest toen als commando invullen:
bash linux-brprinter-installer-2.0.0-1 MFC-J6920DWEn toen ging de installatie bij mij weer verder.
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #5 Gepost op: 2014/11/14, 19:38:33 »
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Re: printer problemen brother DCP-115c op lubuntu
« Reactie #6 Gepost op: 2014/11/15, 10:52:04 »
beste frederik, ik ben aan de slag gegaan met de link die jij vermeld had, krijg vervolgens onderstaande te zien in de terminal bij stap 5:

root@arno-desktop:/home/arno# bash linux-brprinter-installer-*.*.*-* dcp-115c
bash: linux-brprinter-installer-*.*.*-*: Bestand of map bestaat niet



ik loop weer vast.....

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #7 Gepost op: 2014/11/15, 11:21:09 »
Omdat het een .deb bestand is zou deze gewoon door het softwarecentrum geopend en geïnstalleerd moeten worden. Althans zo werkte het bij mijn Brother DCP-J552DW. Wil je vanuit de terminal werken dat moet je er voorzorgen dat je de terminal opstart als je in de map zit waar het bestand staat opgeslagen.
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #8 Gepost op: 2014/11/15, 11:26:51 »
Als je via de terminal werkt, wat vul je nu precies in?

Bij stap 5 staat:
Command: bash linux-brprinter-installer-*.*.*-* Brother machine name

Dan moet je de dus het volgende commando invoeren in de terminal:
linux-brprinter-installer-2.0.0-1 DCP-115CLukt dit niet ?
Uiteraard moet je wel ook in de juiste directory staan.
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Re: printer problemen brother DCP-115c op lubuntu
« Reactie #9 Gepost op: 2014/11/16, 21:47:15 »
hoe moeilijk zou het zijn zou je denken.....

met de regel van wowo linux-brprinter-installer-2.0.0-1 DCP-115C krijg ik weer het volgende te zien :

root@arno-desktop:/home/arno# linux-brprinter-installer-2.0.0-1 DCP-115C
linux-brprinter-installer-2.0.0-1: opdracht niet gevonden

gr
arno

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #10 Gepost op: 2014/11/17, 00:03:41 »
Ok. Niet ok eigenlijk, maar we blijven volhouden.
Ik heb nu ook deze printer driver geïnstalleerd en dat lukt mij zonder problemen.

Wat heb ik gedaan:
1) Ik heb de Driver Install Tool genaamd: linux-brprinter-installer-2.0.0-1.gz gedownload in de map Downloads in de persoonlijke map
2) Open de terminal (bv met ctrl+alt+t of zoek via de bash) en voer het volgende commando in
cd DownloadsJe zit dan in de map Downloads
3) Pak het gedownloade bestand uit met:
gunzip linux-brprinter-installer-2.0.0-1.gz4) Krijg de juiste rechten met:
sudo su enter en vul je wachtwoord in
5) Voer het volgende commando in:
bash linux-brprinter-installer-2.0.0-1 DCP-115C
Dan krijg je als antwoord in de terminal te zien:
You are going to install following packages.
   mfc410cnlpr-1.0.2-1.i386.deb
   cupswrapperMFC410CN-1.0.2-3.i386.deb
   brscan2-0.2.5-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->

Het kan zijn dat jij wat anders ziet want dat kan afhangen van welke computer je hebt (32 of 64 bit)

Volg verder de rest van de stappen.
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Re: printer problemen brother DCP-115c op lubuntu
« Reactie #11 Gepost op: 2014/11/21, 15:36:52 »
nou het "ging" hel lekker totdat:

****** ERROR: csh is required. ******
csh/tcsh is required

root@arno-desktop:/home/arno/Downloads#

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #12 Gepost op: 2014/11/21, 16:10:53 »
****** ERROR: csh is required. ******
csh/tcsh is required
Ik draai ubuntu en daar heb ik csh of tcsh ook niet geïnstalleerd.
Ik zal in virtualbox lubuntu installeren en dan de drivers van deze printer helemaal proberen te installeren.
Alle stappen zal ik noteren en deze terugkoppelen.
Wordt vervolgd.....
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: printer problemen brother DCP-115c op lubuntu
« Reactie #13 Gepost op: 2014/11/21, 20:04:07 »
Het is mij (denk ik) gelukt.
Ik heb alles uitgevoerd in VirtualBox Lubuntu 12.04 LTS 64 AMD.

Ook ik kreeg na een tijdje de melding:
****** ERROR: csh is required. ******
csh/tcsh is required

Ik heb toen via synaptic deze twee pakketten: csh en tcsh geïnstalleerd.

Toen heb ik in de terminal terwijl ik in de Downloads directory stond nogmaals:
sudo suen
bash linux-brprinter-installer-2.0.0-1 DCP-115Cuitgevoerd.

De installatie liep toen verder:
You are going to install following packages.
  mfc410cnlpr-1.0.2-1.i386.deb
  cupswrapperMFC410CN-1.0.2-3.i386.deb
  brscan2-0.2.5-1.amd64.deb
  brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->  y
y
De terminal gaf het volgende te zien:
dpkg -x mfc410cnlpr-1.0.2-1.i386.deb /
dpkg -x cupswrapperMFC410CN-1.0.2-3.i386.deb /
dpkg-deb: bouwen van pakket ‚mfc410cnlpr:i386' in ‚mfc410cnlpr-1.0.2-1a.i386.deb’.
dpkg -b ./brother_driver_packdir mfc410cnlpr-1.0.2-1a.i386.deb
dpkg-deb: bouwen van pakket ‚cupswrappermfc410cn:i386' in ‚cupswrapperMFC410CN-1.0.2-3a.i386.deb’.
dpkg -b ./brother_driver_packdir cupswrapperMFC410CN-1.0.2-3a.i386.deb
dpkg -i --force-all mfc410cnlpr-1.0.2-1a.i386.deb
(Database inlezen ... 127452 files and directories currently installed.)
Voorbereiden om mfc410cnlpr:i386 1.0.2-1 te vervangen (door mfc410cnlpr-1.0.2-1a.i386.deb) ...
Uitpakken van vervangende mfc410cnlpr:i386 ...
Instellen van mfc410cnlpr:i386 (1.0.2-1) ...
mkdir: kan map ‘/var/spool/lpd/MFC410CN’ niet aanmaken: Bestand of map bestaat niet
chown: kan geen toegang krijgen tot ‘/var/spool/lpd/MFC410CN’: Bestand of map bestaat niet
chgrp: kan geen toegang krijgen tot ‘/var/spool/lpd/MFC410CN’: Bestand of map bestaat niet
chmod: kan geen toegang krijgen tot ‘/var/spool/lpd/MFC410CN’: Bestand of map bestaat niet
ln: kan geen symbolische koppeling ‘/usr/lib/libbrcompij2.so.1.0’ aanmaken: Bestand bestaat al
ln: kan geen symbolische koppeling ‘/usr/lib/libbrcompij2.so.1’ aanmaken: Bestand bestaat al
ln: kan geen symbolische koppeling ‘/usr/lib/libbrcompij2.so’ aanmaken: Bestand bestaat al
dpkg -i --force-all cupswrapperMFC410CN-1.0.2-3a.i386.deb
(Database inlezen ... 127452 files and directories currently installed.)
Voorbereiden om cupswrappermfc410cn:i386 1.0.2-3 te vervangen (door cupswrapperMFC410CN-1.0.2-3a.i386.deb) ...
lpadmin: The printer or class does not exist.
cups stop/waiting
cups start/running, process 7629
Uitpakken van vervangende cupswrappermfc410cn:i386 ...
Instellen van cupswrappermfc410cn:i386 (1.0.2-3) ...
rm -f /usr/lib/cups/filter/brlpdwrapperMFC410CN
cups stop/waiting
cups start/running, process 7680
#
ln -s /usr/lib/libbrcompij2.so.1.0.2 /usr/lib32/libbrcompij2.so.1.0.2
ln -s /usr/lib/libbrcompij2.so /usr/lib32/libbrcompij2.so
ln -s /usr/lib/libbrcompij2.so.1 /usr/lib32/libbrcompij2.so.1
ln -s /usr/lib/libbrcompij2.so.1.0 /usr/lib32/libbrcompij2.so.1.0
Will you specify the Device URI? [Y/n] ->

Deze vraag kan je beantwoorden met de volgende uitleg op de Brother site:
When you see the message „Will you specify the DeviceURI ?“,
For USB Users: Choose N(No)
For Network Users: Choose Y(Yes) and DeviceURI.

Ik heb 'n' geantwoord (=usb printer driver)

In de terminal kwam toen te staan:
Test Print? [y/N] ->Omdat ik deze printer niet heb antwoord ik N (overigens kan dat later ook nog wel)

Terminal:
You are going to install following packages.
  brscan2-0.2.5-1.amd64.deb

This Agreement provides terms and conditions for license grant for use of the software that is distributed with this Agreement („Software“) from Brother Industries, Ltd. („Brother“) to recipients thereof („You“).

Note:
Please click on „I Accept“ while holding down „Shift“ or right click on „I Accept“ and select „Save Target As,,,“ from the menu.

1.The Software is comprised of the following software modules:

(1) Certain software modules that is the subject of GNU GENERAL PUBLIC LICENSE („GPL Modules“), and
(2) Other software modules („Non-GPL Modules“)

You may distinguish each of GPL Modules by downloading source files of the Software as Brother separately makes available and reading such files.

2.Your use of all GPL Modules shall be subject to the terms and conditions of GNU GENERAL PUBLIC LICENSE Version 2, June 1991 („GPLv2“). Please see http://www.brother.com/agreement/English_gpl/agree.html. You shall use GPL Modules in accordance with the terms and conditions of GPLv2. Your use of GPL Modules shall be deemed as your agreement to the terms and conditions of GPLv2.

3.You have the right to use all Non-GPL Modules only in accordance with the following terms and conditions. Your use of Non-GPL Modules shall be deemed as your agreement to the following terms and conditions:
(1) Brother retains any and all copyrights to Non-GPL Modules. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to you any copyrights or other intellectual property rights to whole or any part of Non-GPL Modules.

(2) Brother grants you a non-exclusive license to reproduce and/or distribute (via Internet or in any other manner) Non-GPL Modules. Brother further grants you a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of Non-GPL Modules and to reproduce and/or distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works of Non-GPL Modules.

(3) When you distribute (via Internet or in any other manner) Non-GPL Modules or any modification, alteration, translation or other derivative works thereof under the license granted in accordance with subparagraph 3(2) above, you must expressly grant any and all recipient thereof the license equivalent to this Agreement which applies to Non-GPL Modules.

(4) The license of Non-GPL Modules from Brother hereunder is granted „AS IS. BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO NON-GPL MODULES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT.

(5) To the extent allowed by applicable laws, Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in Non-GPL Modules even if Brother has been advised of the possibility of such loss or damage.

(6) The form in which Non-GPL Modules is distributed is subject to Brothers sole discretion. Brother does not have any obligation to distribute or disclose Non-GPL Modules in source code form. In no case shall this Agreement be deemed as Brothers express or implied agreement to disclose source code of Non-GPL Modules.
Do you agree? [Y/n] ->
Y antwoorden.

Terminal:
You are going to install following packages.
  brscan-skey-0.2.4-1.amd64.deb

=========================================
Brother License Agreement

Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.

Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.

The license of the Software from Brother hereunder is granted „AS IS.“ BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT.
Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage.
Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother’s implied agreement or undertakings to disclose and/or distribute the source cord of the Software.
=========================================
Do you agree? [Y/n] ->
Y antwoorden.

Volgens mij is nu alles goed maar vind het wel vreemd dat er een ander modelnaam stond bij de drivers maar die zal wel dezelfde driver hebben?

Je kan als laatste nog even met het volgende commando in de terminal controleren welke drivers correct geïnstalleerd zijn:
dpkg -l | grep Brother
Ik kreeg als antwoord:
ii  brscan-skey         0.2.4-1      Brother Linux scanner S-KEY tool
ii  brscan2            0.2.5-1      Brother Scanner Driver
ii  cupswrappermfc410cn:i386   1.0.2-3      Brother MFC410CN CUPS wrapper driver
ii  mfc410cnlpr:i386         1.0.2-1      Brother lpr Inkjet Printer Definitions

Volgens mij is alles ok nu.
Bij afdruk-beheer zie ik nu de volgende printer staan MFC410CN. 
Je kan deze evt via eigenschappen ook instellen als standaard en ook de naam veranderen in DCP-115C.

Hopelijk werkt je printer nu met deze drivers. Indien niet zal je toch met Brother contact moeten opnemen.

Ik heb trouwens geen enkel idee wat de pakketten csh en tcsh precies doen.
Misschien kan je beter later, na eerst wat advies ingewonnen te hebben van iemand die daar meer verstand van heeft, deze 2 pakketten weer verwijderen.

Succes!



Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD