Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xubuntu dode toetsen niet werkend  (gelezen 671 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
Xubuntu dode toetsen niet werkend
« Gepost op: 2014/11/13, 09:27:02 »
Deze week ben ik op mijn Vaio Laptop (zie onderschrift) vanuit Ubuntu 14.04 overgestapt naar Xubuntu 14.04. Nu werken de dode toetsen echter niet meer (zoals ik gewend ben). Ik heb e.e.a. volgens mij ingesteld zoals het zou moeten (zie plaatje). Wat zie ik over het hoofd?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #1 Gepost op: 2014/11/13, 09:49:16 »
Bij mij staat een vinkje bij standaardinstellingen gebruiken.
Voor de rest staan de settings gelijk als bij jou.
mvg,  Peter
Desktop: xubuntu 16.04.3 / xubuntu-minimal 16.04.3
Laptop: xubuntu-minimum 16.04.3
"No windows in the house but somehow there's more light..."

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #2 Gepost op: 2014/11/13, 10:43:10 »
Stond-ie standaard op ingesteld, maar werkte niet. Vandaar dat ik de handmatige instelling probeerde. Tevergeefs...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #3 Gepost op: 2014/11/13, 10:45:15 »
Wat is er nu anders dan eerst, met die dode toetsen?

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #4 Gepost op: 2014/11/13, 11:02:28 »
Leestekens worden meteen weergegeven. Ik ben gewend een spatie of een letter te moeten typen daarna. Daarmee wordt bepaald of het een los leesteken moet zijn of een letter met accent. Als ik me niet vergis is dat ook het principe van de dode toetsen.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #5 Gepost op: 2014/11/13, 11:17:23 »
Merkwaardig.... Stel het eens in via een ingreep "onder de motorkap":
https://sites.google.com/site/computertip/toetsenbord#TOC-Toetsenbord-wijzigen-onder-de-motorkap
(punt 8, rechterkolom)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #6 Gepost op: 2014/11/13, 11:31:36 »
Zeer merkwaardig. Vanaf Ubuntu 8.04 (in diverse flavours) ben ik dit euvel nog nooit tegen gekomen...
Anyway, ik heb sudo dpkg-reconfigure keyboard-configuration uitgevoerd en alle opties conform mijn wensen ingesteld. Deze waren overigens al allemaal voorgekozen. Het werkt echter niet...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #7 Gepost op: 2014/11/13, 16:35:04 »
En de twee bestanden die verderop onder punt 8 staan maken geen deel meer uit van deze distro...  :'(
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #8 Gepost op: 2014/11/13, 16:43:53 »
Wat gebeurt er als je de toetsenbordindeling 'Nederlands (Sun dode toetsen)' gebruikt? Mogelijk doet 'Nederlands (Standaard)' het ook, qua dode toetsen.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #9 Gepost op: 2014/11/13, 16:46:25 »
Wat gebeurt er als je de toetsenbordindeling 'Nederlands (Sun dode toetsen)' gebruikt? Mogelijk doet 'Nederlands (Standaard)' het ook, qua dode toetsen.
Helaas bij beiden geen dode toetsen. Ook de keymap is niet helemaal juist...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #10 Gepost op: 2014/11/13, 16:46:58 »
Wat gebeurt er als je de toetsenbordindeling 'Nederlands (Sun dode toetsen)' gebruikt? Mogelijk doet 'Nederlands (Standaard)' het ook, qua dode toetsen.
Dat is geen goed idee, bij een Amerikaans toetsenbord. Bijzondere tekens staan op andere plekken.

@10o: maak eens een xorg.conf aan, zoals beschreven in de eerdere webkoppeling? Alleen natuurlijk niet "gb", maar "us". Doe daarna een herstart van je computer.
« Laatst bewerkt op: 2014/11/13, 16:48:37 door Pjotr »

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #11 Gepost op: 2014/11/13, 17:07:39 »
Met indeling Engels (internationaal AltGr dode toetsen) heb ik nog steeds geen dode toetsen, maar kan ik m.b.v. de AltGr-toets wél tekens met accenten tevoorschijn toveren. Dit werkt echter verre van intu...i...í...ï...tief..  ;)
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline JvH

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #12 Gepost op: 2014/11/14, 08:48:23 »
Met indeling Engels (internationaal AltGr dode toetsen) heb ik nog steeds geen dode toetsen, maar kan ik m.b.v. de AltGr-toets wél tekens met accenten tevoorschijn toveren. Dit werkt echter verre van intu...i...í...ï...tief..  ;)
Ik neem aan dat je bedoelt dat je bijv. met AltGr+J een ï maakt enz.?

In de toetsenbordindeling die jij noemt zijn die dode toetsen wel aanwezig, alleen krijg je die alleen (zoals de naam van de indeling al aangeeft) in combinatie met de AltGr-toets.
Dus bijv. AltGr+' gevolgd door e geeft é.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #13 Gepost op: 2014/11/14, 09:23:15 »
Juist!
Maar dat werkt ontzettend "counter intuitive" omdat de variëteiten aan accenten verstopt zitten onder diverse letters.
Als ik dit met de huidige Xubuntu niet werkend krijg op m'n laptop, dan switch ik gewoon weer terug naar de gnome-fallback-session (Metacity) in Ubuntu 14.04.1. Of ik ga de Mate uitvoering eens een kans geven...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Xubuntu dode toetsen niet werkend
« Reactie #14 Gepost op: 2014/11/14, 10:00:10 »
.... Ik ben gewend een spatie of een letter te moeten typen daarna. Daarmee wordt bepaald of het een los leesteken moet zijn of een letter met accent. Als ik me niet vergis is dat ook het principe van de dode toetsen.

Zoals je het nu omschrijf klopt het bij mij precies zo, ook de eerste afbeelding die je hebt bijgevoegd heb ik zo ingesteld en de dode toetsen werken! Ik denk daarom dat er een instelling in die laptop toetsenbord zit die dode toetsen blokkeert. Het zou namelijk gewoon moeten werken.
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #15 Gepost op: 2014/11/14, 10:04:02 »
Ubuntu 14.04(.1) blokkeert de dode toetsen niet. Curieus dat het in Xubuntu niet werkt, terwijl de kernel (neem ik aan) dezelfde is. Of is er een andere laag die dit regelt?
Overigens werkt de touchpad aan/uit knop (Fn+F1) ook niet in Xubuntu.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #16 Gepost op: 2014/11/14, 14:50:05 »
Ik heb hiervoor een scriptje aangemaakt met de volgende inhoud
#!/bin/sh
setxkbmap -model pc105 -layout us_intl
xmessage us_intl -center -timeout 1
Dat heb ik keyb-us-intl genoemd en in /usr/bin/ gekopieerd. *)
Dat scriptje start ik met het opstarten van XFCE mee en alles werkt.

*) Ik neem aan dat je weet hoe dit moet.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #17 Gepost op: 2014/11/14, 15:57:27 »
Ik heb hiervoor een scriptje aangemaakt met de volgende inhoud
#!/bin/sh
setxkbmap -model pc105 -layout us_intl
xmessage us_intl -center -timeout 1
Dat heb ik keyb-us-intl genoemd en in /usr/bin/ gekopieerd. *)
Dat scriptje start ik met het opstarten van XFCE mee en alles werkt.

*) Ik neem aan dat je weet hoe dit moet.

Bedankt voor de tip! Maar helaas werkt het bij mij niet...  :'(
Er komt eventjes een pop-up, maar het gedrag van mijn toetsenbord blijft ongewijzigd. Ik heb nog gespeeld met het settingsscherm (standaard aan/uit enz.), maar ook dat maakt geen verschil.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #18 Gepost op: 2014/11/14, 21:16:37 »
Heb je x11-xkb-utils geïnstalleerd?
Een korte beschrijving hiervan (gespiekt bij Synaptic):
Citaat
xkbutils contains a number of client-side utilities for XKB, the X11
keyboard extension.

setxkbmap is a tool to query and change the current XKB map.

xkbbell generates a bell event through the keyboard.

xkbcomp is a tool to compile XKB definitions into map files the server
can use.

xkbevd is an experimental tool to listen for certain XKB events and execute
defined triggers when actions occur.

xkbprint is a tool to generate an image with the physical representation
of the keyboard as XKB sees it.

xkbvleds shows the changing status of keyboard LEDs.

xkbwatch shows the changing status of modifiers and LEDs.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: Xubuntu dode toetsen niet werkend
« Reactie #19 Gepost op: 2014/11/14, 21:51:20 »
Ubuntu 14.04(.1) blokkeert de dode toetsen niet.

Ik bedoelde Ubuntu ook niet, maar de touchpad. Ik heb een gewoon standaard toetsenbordje met werkende dode toetsen op Xubuntu.
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #20 Gepost op: 2014/11/15, 00:14:12 »
Heb je x11-xkb-utils geïnstalleerd?
sudo apt-get install x11-xkb-utils
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
x11-xkb-utils is al de nieuwste versie.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 20 niet opgewaardeerd.
Jip, is dus ge¨installeerd!
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #21 Gepost op: 2014/11/19, 17:14:02 »
Dank voor de hulp aan allen hier!
Helaas heb ik in Xubuntu 14.04.1 het toetsenbord niet werkend gekregen met de dead keys. Daarom weer terug naar Ubuntu 14.04.1 (met gnome-session-flashback/Metacity).
Xubuntu en m'n Sony laptop; het blijkt net als bij 12.04 LTS geen perfecte match. Maar gelukkig zijn er voldoende alternatieven...  :)
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline JvH

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #22 Gepost op: 2014/11/19, 18:13:44 »
En gaat het in Gnome Session Fallback nu wel goed met de dode toetsen?
Ik kan geen enkele reden bedenken waarom die dode toetsen in Xubuntu niet zouden werken, en in Ubuntu met Gnome Session Fallback wel...
Had je eventueel ook al een schone installatie van Xubuntu geprobeerd?

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #23 Gepost op: 2014/11/19, 18:16:42 »
Dode toetsen hebben in Ubuntu altijd gewerkt. Ik kwam dit probleem pas tegen in (een schone installatie van) Xubuntu.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Xubuntu dode toetsen niet werkend
« Reactie #24 Gepost op: 2014/11/19, 20:21:26 »
Citaat
Xubuntu en m'n Sony laptop; het blijkt net als bij 12.04 LTS geen perfecte match. Maar gelukkig zijn er voldoende alternatieven...  :)
Niemand hoort mij mopperen over het toetsenbord van mijn stokoude Sony VGN-NS38E mét werkende dode toetsen. (Nee, werkende dode toetsen zijn géén zombietoetsen!) OS: LMintMaya13 en Lubuntu14.04.
(Ja, de wifi is iets héél anders)
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523