Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: eID wil niet werken, wat installeren?  (gelezen 3348 keer)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
eID wil niet werken, wat installeren?
« Gepost op: 2014/11/06, 10:16:37 »
Hallo,

ik heb bij mijn vakbond een eID-lezer gekregen. Ik wil dat aan de praat krijgen en hij weigert.
http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/ Dat is de link van de overheid waarmee je die lezer aan de praat moet kunnen krijgen in Linux maar er loopt een en ander mis. Heeft iemand enig idee wat ik moet installeren of juist moet doen, stap voor stap?

Alvast vriendelijk bedankt voor de hulp.

Vriendelijke groeten,

Els

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #1 Gepost op: 2014/11/06, 10:21:06 »
Welke distro gebruik je? Bij mij werkt die probleemloos. Lubuntu 14.04.1

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #2 Gepost op: 2014/11/06, 10:24:20 »
Ik gebruik Linux 14.04. Ik heb de stappen gevolgd op die website van de overheid maar ik draai altijd in hetzelfde kringetje, als ik die eID lezer wil gebruiken zegt hij dat het niet werkt en kom ik terug op de website van de overheid met die uitleg.

Offline staf

  • Lid
Re: eID wil niet werken, wat installeren?
« Reactie #3 Gepost op: 2014/11/06, 10:50:27 »
Wat heb je juist gedaan?
de stappen:
1. download archive bestand en installeer het .deb bestand met package installer.
2. update in terminal
3. sudo apt-get install eid-viewer eid-mw
4. configureer uw firefox of chrome i.v.m. de certificaten

Nu zou het moeten werken.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #4 Gepost op: 2014/11/06, 11:10:37 »
Dag Staf,

heel vriendelijk bedankt voor de hulp, na een klein beetje knoeien is het gelukt. Heel vriendelijk bedankt voor je hulp, het werkt nu heel goed.

Groetjes,

Els

Offline Spidey-Westland

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #5 Gepost op: 2014/11/06, 11:16:11 »
@ Els,

Ik heb ook de de volgende file gedownload
eid-archive.deb van de website http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/

en daarna de tips van "staf" uitgevoerd.

Het werkt wel op mijn desktop, maar ik nog geen eid card viewer. Maar ik ga hiermee verder.

groet

Spidey
Spidey-Westland

Offline Willibuntu

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #6 Gepost op: 2014/11/06, 22:34:08 »
Op de website staat:
1) Installeer het "eID-archive" pakket, zodat de eID-pakketrepositories beschikbaar worden.
2) Installeer de "eid-viewer" en/of "eid-mw" pakketten via de normale weg voor uw distributie. Dit kan mogelijk betekenen dat u eerst een update van de indexen moet doorvoeren (bv. via "apt-get update").

1 is gelukt, van punt 2 begrijp ik niks.
Ook bij de stappen van Staf blijf ik steken op 2... :-[
Wie help mij hier uit?
Ik draai een Ubuntu 14.04.

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #7 Gepost op: 2014/11/06, 22:40:57 »
Op de website staat:
1) Installeer het "eID-archive" pakket, zodat de eID-pakketrepositories beschikbaar worden.
2) Installeer de "eid-viewer" en/of "eid-mw" pakketten via de normale weg voor uw distributie. Dit kan mogelijk betekenen dat u eerst een update van de indexen moet doorvoeren (bv. via "apt-get update").

1 is gelukt, van punt 2 begrijp ik niks.
Ook bij de stappen van Staf blijf ik steken op 2... :-[
Wie help mij hier uit?
Ik draai een Ubuntu 14.04.

Open het softwarecentrum en installeer de eid- vieuwer (grafische tool om je eid te testen en je pin code b.v. te veranderen) én het pakket eid- mw (de middleware nodig om eid te doen draaien)  .

Daarna moet je je Firefox (of Chromium, maar dat is een pak lastiger om te doen) nog de certificaten bewerken zoals opgegeven op de eid-site.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Willibuntu

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #8 Gepost op: 2014/11/06, 22:45:36 »
Als ik in het softwarecentrum zoek op "eid-viewer" of "eid-mw" dan krijg ik geen resultaat.

Offline staf

  • Lid
Re: eID wil niet werken, wat installeren?
« Reactie #9 Gepost op: 2014/11/07, 08:16:54 »
Willibunti,

1. download en installeer eid-archive.
2. sudo apt-get update
3. sudo apt-get install eid-viewer eid-mw

Daarna staat het programmatje "eid kaart-lezer" normaal gezien in het menu.

Voor Firefox en/of Chrome hoef je gewoon de handleiding te volgen op de site , langs "veelgestelde vragen" kom je daar.

good luck.
« Laatst bewerkt op: 2014/11/07, 08:19:29 door staf »

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #10 Gepost op: 2014/11/07, 08:37:20 »
« Laatst bewerkt op: 2016/11/07, 18:00:47 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Jenske

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #11 Gepost op: 2014/11/07, 10:01:19 »
Je moet NOG een bepaald bestand installeren, namelijk met volgende naam:
libacr38u

Je kan dat best installeren door dat in synaptic op te zoeken. Dan krijg je ineens ook wat uitleg over dit onderdeel. Ik vind het wel lastig dat "ze" bij de overheid er de gebruiker niet op wijzen.
.. thuis volledig Ubuntu sinds 2006
.. xubuntu 14.04
.. HP desktop 1,5 Tbyte harde schijf 7200 rpm, 4 Mhz processor, 6 Gbyte RAM

Offline staf

  • Lid
Re: eID wil niet werken, wat installeren?
« Reactie #12 Gepost op: 2014/11/07, 11:59:07 »
Dat is alleen nodig voor de oudere types, maar indien nodig gewoon in de terminal:
 sudo apt-get install libacr38u

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #13 Gepost op: 2014/11/07, 12:45:21 »
Open het softwarecentrum en installeer de eid- vieuwer (grafische tool om je eid te testen en je pin code b.v. te veranderen) én het pakket eid- mw (de middleware nodig om eid te doen draaien)  .
De eID van Ubuntu SoftwareCenter loopt jaren achter. Zeker niet gebruiken, want dan help je de juiste installatie om zeep!!

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #14 Gepost op: 2014/11/07, 13:32:25 »
Open het softwarecentrum en installeer de eid- vieuwer (grafische tool om je eid te testen en je pin code b.v. te veranderen) én het pakket eid- mw (de middleware nodig om eid te doen draaien)  .
De eID van Ubuntu SoftwareCenter loopt jaren achter. Zeker niet gebruiken, want dan help je de juiste installatie om zeep!!

Nochtans zo gedaan, en het werkt perfect : zelfs met een stokoude Dectel 38-reader. De updates voor eid komen hier goed binnen.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Jenske

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #15 Gepost op: 2014/11/07, 14:56:07 »
Open het (...)
De eID van Ubuntu SoftwareCenter loopt jaren achter. Zeker niet gebruiken, want dan help je de juiste installatie om zeep!!

Aan deze uitleg heeft de gebruiker niet veel, want 1/ bij mij (en kennelijk ook anderen) werkt die perfect, 2/ is de eid-viewer van de overheid redelijk actueel (voor Ubuntu 14.04 en ik dacht zelfs al voor 14.10), 3/ stellen dat iets "om zeep" wordt geholpen is in dit geval nogal vaag -- wat moet je je erbij voorstellen en hoe zou je een eventuele fout terug kunnen recht zetten en 4/ je vertelt niet wat de persoon in kwestie dan wél moet doen.

Er is taalkundig iets fout in je zin, waardoor hij zijn bedoeling mist. Want hoe kan je een installatie nu "om zeep" helpen als je gebruik maakt van het software-center? Als je iets installeert, werkt het ofwel wél, ofwel niet, maar je kan "de installatie" niet om zeep helpen, aangezien die er niet was. Bovendien verwijs je in één van je vorige posts zélf naar het installatiecentrum om eid-viewer van te downloaden.

Dus, voor wat mij betreft: de bijkomende installatie van dat ac38-ding heeft het 'em gedaan en sindsdien draai ik naadloos met mijn elektronische identiteitskaart.
.. thuis volledig Ubuntu sinds 2006
.. xubuntu 14.04
.. HP desktop 1,5 Tbyte harde schijf 7200 rpm, 4 Mhz processor, 6 Gbyte RAM

Offline Willibuntu

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #16 Gepost op: 2014/11/07, 15:25:31 »
Tot hiertoe gedaan:

1. download en installeer eid-archive.
2. sudo apt-get update
3. sudo apt-get install eid-viewer eid-mw
4. Firefox: https://addons.mozilla.org/nl/firefox/addon/belgium-eid/
5. Chrome: https://code.google.com/p/eid-mw/wiki/ChromeLinux

Resultaat: Firefox werkt, Chrome doet het niet: "Het certificaat van uw elektronische identiteitskaart kon niet geverifieerd worden."

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: eID wil niet werken, wat installeren?
« Reactie #17 Gepost op: 2014/11/07, 16:41:18 »
De software van de officiële beid-site werkt inderdaad zeer goed. Ubuntu heeft echter jaren lang een eigen versie voor beid aangeboden die het niet deed. Je kon wel je kaart lezen, maar dat was het dan ook. Ermee inloggen op de FOD-sites ging niet. Wat meer is, als je de install gebruikte van eid.belgium.be dan ging het wel. Installeer daarna deze van Ubuntu, en je kon niet meer op de FOD sites.

Voor zover ik weet is het pas sinds dit jaar dat eid.belgium.be een software bron toevoegt, waarna je een apt-get update moet draaien. Daardoor komt de officiële versie wel in het software center terecht. Voordien was dat niet het geval, en wat aangeboden werd in het Ubuntu Center verwijderde bepaalde packages van de officiële install. Minstens tot met 12.10 werd er een versie aangeboden die dateerde van 2008, voor zover ik mij herinner het eerste jaar van Tax-On-Web.

Wat de gebruiker dan wel moet doen is inderdaad het stappenplan uitwerken wat Staf reeds aangaf.

Offline staf

  • Lid
Re: eID wil niet werken, wat installeren?
« Reactie #18 Gepost op: 2014/11/07, 17:07:38 »
Willibuntu, mooi, het werkt in Firefox, Chrome stribbelt af en toe inderdaad wat tegen, maar er is een optie om certificaten te importeren, ik ben er dus wel doorgekomen, even zoeken en proberen.

Offline Willibuntu

  • Lid
  • Steunpunt: Nee
Re: eID wil niet werken, wat installeren?
« Reactie #19 Gepost op: 2014/11/07, 20:50:34 »
Een paar uur gezocht om eID op Chrome aan de praat te krijgen en niets gevonden. Wel gelezen dat Chrome al jaren problemen geeft. Een pluim voor Firefox!
Bedankt aan iedereen die geholpen heeft, in het bijzonder Staf.