Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: HP printer en Utopic 14.10  (gelezen 287 keer)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
HP printer en Utopic 14.10
« Gepost op: 2014/10/25, 23:02:54 »
Na lang zoeken naar de oorzaak van vastlopers, heb ik het eindelijk gevonden.
Soms staat de /tmp map vol met meer dan 800.000 files, hierna wil het systeem niet meer opstarten.
Vandaag had ik geluk, na 10 pagina's printen ging het systeem "vreemd" doen, o.a. waren files waren plots read-only geworden, terwijl ik aan het editten was.
De oorzaak van dit alles is dus de printer-driver, die ik installeer met hplip-gui.
Mijn printer is een all-in-one van HP, de b110.
Met alle voorgaande versies heeft dit altijd zonder problemen gewerkt.
Op dezelfde laptop, maar in een andere partitie staat 14.04 die er geen probleem mee heeft, het doet zich alleen voor in 14.10!.
Nu is het de eerste keer, dat ik het systeem heb weten te redden, na 20 minuten startte hij eindelijk door.
Hierna duurt het booten echter 2x zo lang als eerst, er is dus iets mis, de driver verwijderen helpt niet.

Zijn er misschien meer mensen met dit probleem, of heeft iemand een idee waar en hoe ik moet zoeken ?
« Laatst bewerkt op: 2014/10/25, 23:05:16 door Ron »
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: HP printer en Utopic 14.10
« Reactie #1 Gepost op: 2014/10/26, 10:36:35 »
Omdat ikzelf ook een all-in-one HP printer heb, heb ik dit even kunnen uitproberen op de Xubuntu 14.10 installatie op de notebook uit mijn onderschrift.
De oorzaak van dit alles is dus de printer-driver, die ik installeer met hplip-gui.
Het zou inderdaad aan hplip-gui kunnen liggen. Als ik mijn HP Photosmart 6510 via hplip-gui installeer, en erop klik in Afdrukbeheer dan verschijnt een venster:

Fout

Er is een probleem opgetreden bij het verbinden met de CUPS-server.

En als ik daarmee print, loopt bij mij ook de /tmp map vol
jolo@R61i:/tmp$ du -h
4,0K ./.X11-unix
4,0K ./.ICE-unix
4,0K ./aptdaemon-vhq6H8
3,6M .

jolo@R61i:/tmp$ du -h
4,0K ./.X11-unix
4,0K ./.ICE-unix
4,0K ./aptdaemon-vhq6H8
25M .

jolo@R61i:/tmp$ du -h
4,0K ./.X11-unix
4,0K ./.ICE-unix
4,0K ./aptdaemon-vhq6H8
37M .

Dan staat in top scp-dbus-s+ op ongeveer 90% CPU.
top - 07:08:13 up 22 min,  2 users,  load average: 1,20, 0,91, 0,55
Tasks: 171 total,   1 running, 170 sleeping,   0 stopped,   0 zombie
%Cpu(s): 33,7 us,  9,1 sy,  0,0 ni, 48,1 id,  8,5 wa,  0,2 hi,  0,5 si,  0,0 st
KiB Mem:   2556052 total,  2467348 used,    88704 free,   316264 buffers
KiB Swap:  3077980 total,       68 used,  3077912 free.   680860 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND     
 5278 jolo      20   0  654708  53996  31792 D  90,6  2,1   7:37.06 scp-dbus-s+

Als ik dat proces stop via Taakbeheer, dan wordt de /tmp map niet meer groter. Verder is dit probleem er niet, als ik de all-in-one HP printer installeer via Afdrukbeheer. Nadat de fout geïnstalleerde printer is verwijderd.

Ik had nog wel gecheckt voor hplip-gui bugs, waarvan ik vond dat alleen deze er enigszins in de buurt komt  https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/1036132 al is dat dan system-config-printer met een brother printer. Maar het zou inderdaad om symlinks kunnen gaan. Ik weet dit niet zeker, want ls /tmp gaf geen antwoord. Als ik opnieuw opstart, gaat het booten inderdaad traag.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM