Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: permanent aankoppelen lukt niet  (gelezen 392 keer)

Offline whirlwim

  • Lid
permanent aankoppelen lukt niet
« Gepost op: 2014/10/20, 14:54:15 »
hallo lezer
Ik heb een paar keer geprobeerd een partitie permanent aan te koppelen m.b.v. de instructies van Pjotr (bij de veelgestelde vragen): de desbetreffende regel uit mtab kopiëren naar fstab. alles lijkt goed te gaan, maar bij het opnieuw opstarten krijg ik de melding dat het aankoppelen van de partitie niet gelukt is, zonder nadere toelichting, alleen met de mogelijkheid om het aankoppelen over te slaan.
Heeft iemand suggesties?
« Laatst bewerkt op: 2014/10/20, 15:00:51 door whirlwim »

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: permanent aankoppelen lukt niet
« Reactie #1 Gepost op: 2014/10/20, 15:41:35 »
Zet het resultaat ook best tussen code tags, dan vallen te veel of te weinig spaties makkelijker op.

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #2 Gepost op: 2014/10/20, 17:14:18 »
fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=aa2f4f86-1a4e-47d5-8f4d-b09fadeb8a7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=f6042f34-2eb1-43b5-b333-05391d8b6b5a none            swap    sw              0       0
/dev/sda1 /media/wim/Muziek1 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
het zal duidelijk zijn dat het over de laatste regel gaat.......   ben reuze benieuwd!

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: permanent aankoppelen lukt niet
« Reactie #3 Gepost op: 2014/10/20, 17:25:43 »
fstab:
# /etc/fstab: static file system information.
#
#[b] Use 'blkid' [/b]to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=aa2f4f86-1a4e-47d5-8f4d-b09fadeb8a7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=f6042f34-2eb1-43b5-b333-05391d8b6b5a none            swap    sw              0       0
/dev/sda1 /media/wim/Muziek1 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
het zal duidelijk zijn dat het over de laatste regel gaat.......   ben reuze benieuwd!

Typ in een terminal
sudo blkiddan zie je onder meer een regel die er ongeveer zo uitziet
/dev/sda1: UUID="bcb55503-388c-4b49-8c6a-073fc6ff96d9" TYPE="ext4"of een ander TYPE.
dan open je fstab en voeg je de volgende regel toe:
UUID=bcb55503-388c-4b49-8c6a-073fc6ff96d9 /media/wim/Muziek1 ext4
fstab bewaren, herstarten. Kans dat-ie het zo in 1x doet.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #4 Gepost op: 2014/10/20, 17:46:58 »
dank voor je reactie
jammer genoeg heeft het niet geholpen.  fstab ziet er nu zo uit:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=aa2f4f86-1a4e-47d5-8f4d-b09fadeb8a7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=f6042f34-2eb1-43b5-b333-05391d8b6b5a none            swap    sw              0       0
/dev/sda1 /media/wim/Muziek1 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
UUID=bcb55503-388c-4b49-8c6a-073fc6ff96d9 /media/wim/Muziek1 ext4
gaf dezelfde foutmelding ,maar met nog een tweede:  device niet klaar of afwezig

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: permanent aankoppelen lukt niet
« Reactie #5 Gepost op: 2014/10/20, 17:48:20 »
Is het wel ext4? Wat geeft sudo lsblk -fals resultaat?

En herstarten is normaal niet nodig. Is de partitie reeds aangekoppeld dan doe je eerst een unmount ervan.

Daarnasudo mount -a

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: permanent aankoppelen lukt niet
« Reactie #6 Gepost op: 2014/10/20, 17:56:59 »
Met gparted kijken welke uuid je partitie heeft, dit kopieren naar je fstab.

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #7 Gepost op: 2014/10/20, 21:17:07 »
ja, natuurlijk :-[

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: permanent aankoppelen lukt niet
« Reactie #8 Gepost op: 2014/10/20, 21:25:22 »
# /etc/fstab: static file system information.
[knip]
/dev/sda1 /media/wim/Muziek1 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
UUID=bcb55503-388c-4b49-8c6a-073fc6ff96d9 /media/wim/Muziek1 ext4
gaf dezelfde foutmelding ,maar met nog een tweede:  device niet klaar of afwezig

1. Deze regel in zijn geheel weghalen:
/dev/sda1 /media/wim/Muziek1 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0

2. Nu open je een terminalvenster en je typt:
sudo blkid (van block identifier, een manier om onder andere harde schijven in een Linux-systeem uniek te identificeren)
dan zie je een regel met de info over de schijf die je permanent wilt aankoppelen, iets als:
/dev/sda1: UUID="langnummer" TYPE="iets"

let op dat 'als' hierboven, jouw uuid is zonder enige twijfel anders.

3. Vervolgens voeg je de gevonden uuid-info toe aan fstab, zoals eerder beschreven:

UUID=langnummer /media/wim/Muziek1 iets
Nu beter?

Toevoeging. Dit fstab-gedoe is in het begin voor iedereen een beetje raadselachtig, om maar niet te zeggen: regelrecht ENG! :)
Maar als je eenmaal ziet hoe dit werkt dan zeg je 1) hmm, eigenlijk erg simpel en 2) hmm, eigenlijk erg praktisch/handig!
« Laatst bewerkt op: 2014/10/20, 21:29:40 door Paul Matthijsse »
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #9 Gepost op: 2014/10/20, 22:33:12 »
dank voor je bemoedigende woorden, die kwamen goed van pas
er zijn al enige linux-punten waar ik zoń aha-erlebnis had, gelukkig, maar bij fstab is het nog niet helemaal zo ver....   het is nog niet gelukt
mijn fstab ziet er nu zo uit:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=aa2f4f86-1a4e-47d5-8f4d-b09fadeb8a7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=f6042f34-2eb1-43b5-b333-05391d8b6b5a none            swap    sw              0       0
UUID="24AE54FD31566676" /media/wim/Muziek1 TYPE="ntfs"

heb ik je zo goed begrepen?
kennelijk is de UUID van ee ntfs-partitie anders van samenstelling dan die van een linux-partitie?
ik ben niet zeker of dat cijfer  "1 " wel achter /Muziek moet staan, maar ik heb het ook al zonder geprobeerd, resultaat bleef hetzelfde....

Offline Frederik

  • Lid
    • Vriescheloo
  • Steunpunt: Ja
Re: permanent aankoppelen lukt niet
« Reactie #10 Gepost op: 2014/10/20, 22:34:44 »
Dit fstab-gedoe is in het begin voor iedereen een beetje raadselachtig, om maar niet te zeggen: regelrecht ENG! :)
Maar als je eenmaal ziet hoe dit werkt dan zeg je 1) hmm, eigenlijk erg simpel en 2) hmm, eigenlijk erg praktisch/handig!

Het is een mysterie !
Xubuntu 16.04.1 LTS
Wees wie je bent. Hou van wie je wilt.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: permanent aankoppelen lukt niet
« Reactie #11 Gepost op: 2014/10/20, 22:57:07 »
Zoek eens met google hier op, dan zie je voorbeelden,
ubuntu+fstab+ntfs
De voorbeelden kun je proberen.

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #12 Gepost op: 2014/10/20, 23:04:59 »
bedankt mensen, ik ga er morgen mee verder..........., en zal me weer melden met het resultaat

Offline whirlwim

  • Lid
Re: permanent aankoppelen lukt niet
« Reactie #13 Gepost op: 2014/10/21, 16:23:04 »
Inderdaad, dat was precies wat nodig was: een bemoedigend woord,  een hint over wat en waar te zoeken, de tijd nemen om te lezen en te proberen, en ziedaar: het mysterie wijkt, de weg tekent zich af. leuk, hoor! zoals je merkt wordt ik er zelfs wat lyrisch van.....  bedankt, helpers :)

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: permanent aankoppelen lukt niet
« Reactie #14 Gepost op: 2014/10/21, 21:31:39 »
 ^-^
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...