Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: wachtwoordprobleem netwerk  (gelezen 407 keer)

Offline whirlwim

  • Lid
wachtwoordprobleem netwerk
« Gepost op: 2014/10/11, 00:00:46 »
hallo lezer
ben bezig met netwerk trusty tahr/mint/xubuntu/windows7/Nas(vortexbox). veel gaat goed, maar bij de trusty tahr-machines lukt het me niet om shares weergegeven te krijgen in het netwerk, en ik vermoed dat dit samenhangt met het feit dat er, steeds als ik in het netwerk probeer te bladeren, een schermpje verschijnt waarin om een wachtwoord gevraagd wordt om toegang te krijgen tot die (trusty tahr-)PC's (zowel op die PC zelf als op de ander machines). Het is een schermpje met linksboven een sleutelbosje, drie grote invulvakken (Gebruikersnaam, domein,wachtwoord) en opties over onthouden/vergeten ervan. Mijn gebruikersnaam staat correct ingevuld, evenals de naam van het netwerk/de werkgroep - al wordt die laatste in de schermpje dus aangeduid met de term "domein". Bij mijn weten heb ik bij deze computers steeds één wachtwoord gebruikt, (en met dat wachtwoord kan ik van alles doen) en één gebruikersnaam, maar deze verschaffen geen toegang ; kennelijk gaat het om een ander/andersoortig wachtwoord, maar ik heb geen idee welk.
« Laatst bewerkt op: 2014/10/11, 07:12:38 door whirlwim »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: wachtwoordprobleem netwerk
« Reactie #1 Gepost op: 2014/10/11, 07:58:21 »
Wachtwoord hoeft niet hetzelfde te zijn als je user, dat ligt eraan wat je hebt ingesteld.
Via het samba programma kun je de users en wachtwoord grafisch toevoegen(en ook je gedeelde mappen toevoegen), dan weer rebooten, dan weer testen.
De bovenstaande users en wachtwoord heeft niks te maken met je gebruiker en wachtwoord, voor samba moet je dit apart instellen.
Zoek op mijn user en samba, dan zie je hoe ik de samba installeer, en alles via de grafische samba programma.

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #2 Gepost op: 2014/10/11, 08:50:33 »
dank voor je reactie, jan11000, alleen..... ik ben nieuw in deze omgeving, en ik begrijp je niet goed.  je schrijft "zoek op mijn user en samba"  - wat bedoel je precies? waar moet ik zoeken en naar wat ?
"mijn user en samba" ? "user en samba"?  :|

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #3 Gepost op: 2014/10/11, 10:32:42 »
intussen  heb ik, voortbordurend op de tekst van jan11000, in samba de (enige) user verwijderd en weer opnieuw ingesteld, om zeker te weten dat ik het wachtwoord juist heb. reboot> de binnen samba aangemaakte shares worden nog steeds niet zichtbaar in het netwerk , en ik krijg hetzelfde schermpje weer te zien, met hetzelfde negatieve resultaat. Als ik binnen dit forum  "zoeken" open, en dan "user en samba" invoer krijg ik teksten en links te zien die me niet verder helpen

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #4 Gepost op: 2014/10/11, 11:58:53 »
nu heb ik geprobeerd  smb.conf. te bekijken, in de hoop te snappen wat er niet goed gaat. in terminal getypt: "sudo gedit /etc/samba/smb.conf." . dit gaf de volgende melding:       gedit:2572): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
kan iemand me verder helpen?

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #5 Gepost op: 2014/10/11, 23:03:25 »
mijn smb .config ziet er als volgt uit:

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = workgroup

# server string is the equivalent of the NT Description field
server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic primary
# domain controller", "classic backup domain controller", "active
# directory domain controller".
#
# Most people will want "standalone sever" or "member server".
# Running as "active directory domain controller" will require first
# running "samba-tool domain provision" to wipe databases and create a
# new domain.
server role = standalone server

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using. 
; passdb backend = tdbsam

obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
map to guest = bad user

########## Domains ###########

#
# The following settings only takes effect if 'server role = primary
# classic domain controller', 'server role = backup domain controller'
# or 'domain logons' is set
#

# It specifies the location of the user's
# profile directory from the client point of view) The following
# required a [profiles] share to be setup on the samba server (see
# below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the
# SAMR RPC pipe. 
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe. 
; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
; usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
usershare allow guests = yes
security = user
encrypt passwords = no
guest ok = yes
guest account = wim
username map = /etc/samba/smbusers

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = yes

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = no

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# Un-comment the following parameter to make sure that only "username"
# can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
; guest ok = no
; read only = yes
create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
; browseable = yes
; read only = yes
; guest ok = yes
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

[iPodkopie]
path = /media/wim/administra, loge,FLAC/iPodkopie
writeable = yes
; browseable = yes
valid users = wim

[Muziekflac]
path = /media/wim/administra, loge,FLAC/Muziekflac
writeable = yes
; browseable = yes
valid users = wim

kan iemand mij vertellen of hierin de oorzaak te vinden is van het niet-zichtbaar worden van de samba-shares in het netwerkoverzicht en het niet-toegankelijk zijn ervan?

[Mod edit: codetags toegevoegd.]
« Laatst bewerkt op: 2014/10/13, 12:17:29 door TopGear »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: wachtwoordprobleem netwerk
« Reactie #6 Gepost op: 2014/10/12, 06:47:45 »
Gezocht op samba en op jan 11000, dan had je dit gevonden,

Gigolo is het programma wat vaker goed werkt.

Hoe samba instellen,(zoals ik het doe).

Indien je al met instellingen gespeelt hebt, verwijder alles(tav samba) en reboot,
om zo schoon te beginnen.

Samba installeren,in "software center" zoeken op
samba(SMB/CIFS file, print, and login server for Unix).

Indien je meerdere users gebruikt, dus bijv 3 users die verschillend zijn,
op 3 verschillende pc's.
Dan op elke pc alle users als extra users aanmaken(later als alles werkt kun je de
extra users de rechten beperken, zodat ze minder kunnen, dit hoeft niet maar mag).
Dus je hebt dan de gewone user(die met installatie tot stand is gekomen) en nog 2 extra users.

Dan samba starten,(system-samba in xubuntu).
De share maken,
server instellen, zoals group naam,
security(niks veranderen),
samba users instellen(eigenschappen van je samba map, in de samba programma),
aanvinken die toegang krijgen(nu weet je ook waarom je meerdere users moet
ingeven, want dan zie je alle users, ook die van de andere pc).
Je kan ook extra users ingeven, maar dat heb ik nog niet gebruikt.

-Ook bij ubuntu, bij users kijken of de user ook bij de groep sambashare zit, dus aanvinken.

Nu zou het moeten werken, wel even rebooten.

Je kan nog in je host file de namen van de pc's ingeven,
dit zijn ipnummers met de naam van de pc, zodat deze beter
te vinden is op het netwerk, hoeft niet, maar als het niet goed werkt,
het vinden van de pc's dus.(bij pc's met vaste ip nummers is dit ook beter).
File naam is
hosts
Voorbeeld:
127.0.0.1    localhost  (dit is standaard)
127.0.1.1    jan        (dit is de pc waar samba op staat)
10.16.9.9        ba2        (dit is een andere pc op het netwerk)
10.16.9.99       download   (dit is een andere pc op het netwerk)


# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

De naam van de pc staat in de file hostname,
hier staat alleen een naam.

Indien het vinden van de pc's nog steeds slecht is,(bijv vaste ip nummers en zonder router)
probeer dan met gigolo(even installeren) de andere pc's te vinden,
vaak gaat het dan heel vlug om de pc's te vinden.

Veiligheid,

Nooit iedereen toegang geven, dit omdat als er een fout in een beveiliging/programma/router zit, dan kan iedereen in je files kijken.
Dus altijd een wachtwoord en user erop zetten.

In de samba config file kun je nog,
netwerk interface vastzetten, indien je 2 netwerkkaarten hebt,
zodat samba alleen over bepaalde netwerkkaart gaat.

Hetzelfde geld voor ip nummers, dit kun je ook vastzetten.
10.0.0.0/8 eth0
dit betekend netwerkkaart eth0, alleen hier gaat samba over werken.
en de ip range 10.0.0.0/8 gaat samba werken.

En je kunt nog met de firewall ip adressen en samba blokkeren of open zetten.

Testen netwerk,
40 Gb aan geparde files maken en dit in een ruk kopieren.
dan aan de andere kant parren, dan zie je of alles ook aankomt.
(in windows heb ik een keer gezien dat 1 op de 10 files beschadigd
waren met kopieren, lag aan de firewall, en geen foutmelding).
Bij geen fouten niks doen.
Bij fouten, dan dit gaan wijzigen in samba config(kan soms helpen)
# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY
   socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
Grootte van deze 2 files wijzigen en weer testen.(klein is vaak beter maar ook langzamer).
Kan natuurlijk ook driver zijn, of netwerkkabels.
Zelf heb ik meerdere keren problemen ondervonden, en door te testen merk je opeens
dat niet alles zomaar werkt.
Na het kopieren ook met ifconfig kijken in de terminal,
daar kun je ook problemen/fouten zien.
--------------------------------------------------------------------------------------------------
Indien het nog niet werkt kun je dit nog proberen,
(bij werkte het opeens niet meer(eerste dus wel), oorzaak onbekend, toen dit erbij gezet en het werkte)
Volgend wijzigen in je samba config file(/etc/samba.smb.conf),
Dit erbij zetten,
name resolve order = bcast host

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = workgroup
        name resolve order = bcast host

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: wachtwoordprobleem netwerk
« Reactie #7 Gepost op: 2014/10/12, 07:17:39 »
Vraag voor wachtwoord is normaal.
-Samba testen van ubuntu naar ubuntu(linux) pc, dan pas naar windows gaan, want het kan ook nog aan windows liggen.
-Je werd om een wachtwoord wachtwoord gevraagd, dan werkt samba, maar als wachtwoord weigert, dan klopt er iets niet.

Grafische samba programma is "system-config-samba", hier workgroup instellen zodat dit op alle pc's hetzelfde is,
users kun je hier opgeven, gedeelde mappen instellen, etc.

-Workgroup op alle pc's hetzelfde maken.(of andere naam).
-Hoe heb je ip's op alle pc ingesteld, kontroleer de netwerk instellingen.
-In de host file kun je ook de ip en naam van de pc's opgeven die op het netwerk zitten, dus niet de pc waar je de host file gaat wijzigen. Host file wordt gebruikt op pc om het netwerk te doorzoeken, indien daar niks te vinden is, dan gaat pc bij de dns server zoeken naar pc's. Eigenlijk zou dit niet moeten maar dit mag wel.
- Netwerk dhcp?
-Na wijzigen samba, altijd rebooten, na booten ook even wachten, dan zou netwerk moeten werken.
-Firewall?
« Laatst bewerkt op: 2014/10/12, 08:11:26 door jan11000 »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: wachtwoordprobleem netwerk
« Reactie #8 Gepost op: 2014/10/12, 07:19:25 »

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #9 Gepost op: 2014/10/13, 08:58:22 »
hallo jan 11000
dank voor je reacties
het keyring-gebeuren kwam ik inderdaad ook tegen, en ik begrijp niet waar dat ineens vandaan komt, na een aantal maanden linux-experimenten zonder, maar dat is het probleem niet.
misschien ben ik niet duidelijk geweest, in ieder geval vind ik dat je antwoorden/suggesties maar gedeeltelijk recht doen aan mijn vraag/mijn verstrekte gegevens. ik heb op drie computers de gigolo/samba -combinatie met succes geïnstalleerd (alles werkt, óók met de windows-computers). Alleen bij een vierde computer lukt het niet, ook niet na verwijdering en herinstallatie van samba en gigolo en na het verwijderen/opnieuw aanmaken van de enige user.

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #10 Gepost op: 2014/10/13, 15:27:56 »
ok, zal ik doen!

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: wachtwoordprobleem netwerk
« Reactie #11 Gepost op: 2014/10/13, 16:43:14 »
De weigerende pc/laptop,
zet alle switches en routers eens uit, dus zonder stroom(5 minuten), en probeer opnieuw.

Of  sluit de weigerende pc eens anders aan, ipv wifi maar via kabel,(of andersom)
of aan een andere router,
of aan andere netwerk kabel
of andere netwerkpoort aan de router.

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #12 Gepost op: 2014/10/13, 17:24:59 »
ok, ga ik proberen!

Offline whirlwim

  • Lid
Re: wachtwoordprobleem netwerk
« Reactie #13 Gepost op: 2014/10/13, 21:57:49 »
werkte ook niet.........
ik denk dat ik verder experimenteer met een andere distro op die computer (die eerder met xubuntu geen problemen gaf) . bedankt voor het meedenken :rolleyes: