Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wine probleempje  (gelezen 602 keer)

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Wine probleempje
« Gepost op: 2014/09/17, 21:06:33 »
Hey,

Ik heb onlangs een Chromebook Samsung Series 3 gekocht. Het is een ARM. Daarop heb is Crouton gebruikt om Ubuntu Unity te installeren.  Ik heb De Software Center van Ubuntu ook geinstalleerd, Om hem te open gebruik ik:
gksu support-center
Nu wil ik dus WINE installeren op mijn Ubuntu, maar ik krijg allerlei errors. Ik heb de repository toegevoegd, http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu. Ik zocht dus naar wine, en zag bovenaan de resultaten staan:  Wine Windows Program Loader. Als ik klik op "More Info", dan krijg ik; "There isn’t a software package called “wine1.4” in your current software sources.". Nu heb ik het dus geprobeerd het met terminal te doen;

sudo add-apt-repository ppa:ubuntu-wine/ppa

output:
[spoiler]
(precise)bram@localhost:~$ sudo add-apt-repository ppa:ubuntu-wine/ppa
[sudo] password for bram:
You are about to add the following PPA to your system:
 Welcome to the Wine Team PPA.  Here you can get the latest available Wine betas for every supported version of Ubuntu.  This PPA is managed by Scott Ritchie and Maarten Lankhorst.
 More info: https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpCTZm28/secring.gpg' created
gpg: keyring `/tmp/tmpCTZm28/pubring.gpg' created
gpg: requesting key F9CB8DB0 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpCTZm28/trustdb.gpg: trustdb created
gpg: key F9CB8DB0: public key "Launchpad PPA for Ubuntu Wine Team" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
(precise)bram@localhost:~$

[/spoiler]

Daarna doe ik:

sudo apt-get update

Output:

[spoiler]
(precise)bram@localhost:~$ sudo apt-get update
Hit http://ports.ubuntu.com precise Release.gpg
Hit http://ports.ubuntu.com precise-updates Release.gpg
Hit http://ports.ubuntu.com precise-security Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ports.ubuntu.com precise Release
Hit http://ports.ubuntu.com precise-updates Release
Hit http://ports.ubuntu.com precise-security Release                 
Hit http://ppa.launchpad.net precise Release                         
Hit http://ports.ubuntu.com precise/main Sources                     
Hit http://ports.ubuntu.com precise/restricted Sources
Hit http://ports.ubuntu.com precise/universe Sources
Hit http://ports.ubuntu.com precise/multiverse Sources
Hit http://ports.ubuntu.com precise/main armhf Packages
Hit http://ports.ubuntu.com precise/restricted armhf Packages
Hit http://ppa.launchpad.net precise Release   
Hit http://ports.ubuntu.com precise/universe armhf Packages
Hit http://ports.ubuntu.com precise/multiverse armhf Packages
Hit http://ports.ubuntu.com precise/main TranslationIndex
Hit http://ports.ubuntu.com precise/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise/restricted TranslationIndex               
Hit http://ports.ubuntu.com precise/universe TranslationIndex     
Hit http://ports.ubuntu.com precise-updates/main Sources         
Hit http://ports.ubuntu.com precise-updates/restricted Sources   
Hit http://ports.ubuntu.com precise-updates/universe Sources     
Hit http://ports.ubuntu.com precise-updates/multiverse Sources   
Hit http://ports.ubuntu.com precise-updates/main armhf Packages   
Hit http://ports.ubuntu.com precise-updates/restricted armhf Packages
Hit http://ports.ubuntu.com precise-updates/universe armhf Packages
Hit http://ports.ubuntu.com precise-updates/multiverse armhf Packages
Hit http://ppa.launchpad.net precise/main Sources                 
Hit http://ppa.launchpad.net precise/main armhf Packages         
Ign http://ppa.launchpad.net precise/main TranslationIndex       
Hit http://ports.ubuntu.com precise-updates/main TranslationIndex
Hit http://ports.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://ports.ubuntu.com precise-updates/universe TranslationIndex
Hit http://ports.ubuntu.com precise-security/main Sources
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ports.ubuntu.com precise-security/restricted Sources   
Hit http://ports.ubuntu.com precise-security/universe Sources     
Hit http://ports.ubuntu.com precise-security/multiverse Sources   
Hit http://ports.ubuntu.com precise-security/main armhf Packages 
Hit http://ports.ubuntu.com precise-security/restricted armhf Packages
Hit http://ppa.launchpad.net precise/main armhf Packages         
Ign http://ppa.launchpad.net precise/main TranslationIndex       
Hit http://ports.ubuntu.com precise-security/universe armhf Packages
Hit http://ports.ubuntu.com precise-security/multiverse armhf Packages
Hit http://ports.ubuntu.com precise-security/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise-security/restricted TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe TranslationIndex
Hit http://ports.ubuntu.com precise/main Translation-en           
Hit http://ports.ubuntu.com precise/multiverse Translation-en
Hit http://ports.ubuntu.com precise/restricted Translation-en
Hit http://ports.ubuntu.com precise/universe Translation-en
Hit http://ports.ubuntu.com precise-updates/main Translation-en   
Hit http://ports.ubuntu.com precise-updates/multiverse Translation-en
Hit http://ports.ubuntu.com precise-updates/restricted Translation-en
Hit http://ports.ubuntu.com precise-updates/universe Translation-en
Hit http://ports.ubuntu.com precise-security/main Translation-en 
Hit http://ports.ubuntu.com precise-security/multiverse Translation-en
Hit http://ports.ubuntu.com precise-security/restricted Translation-en
Hit http://ports.ubuntu.com precise-security/universe Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_US       
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_US
Ign http://ppa.launchpad.net precise/main Translation-en
Reading package lists... Done 
[/spoiler]

Tot nu toe nog steeds geen foutmeldingen.
Maar nu komt het:

sudo apt-get install wine

Output:
[spoiler]
(precise)bram@localhost:~$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package wine is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'wine' has no installation candidate
[/spoiler]

Ik heb ook al gebruikt:

sudo apt-get install wine1.6
[/code[

Output:
[spoiler]
[code]
(precise)bram@localhost:~$ sudo apt-get install wine1.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package wine1.6
E: Couldn't find any package by regex 'wine1.6'
[/spoiler]

Sorry dat ik er niet zo veel van snap, ik ben pas 12 en heb nog nooit Linux gebruikt.

Mvg,
Bram

Ik ben een Ubuntu noob :|

Offline ekhnaton

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #1 Gepost op: 2014/09/18, 01:45:50 »
ZOEK naar wubi.exe en gebruik dat om binnen Ubuntu de 'wine' optie te maken.
Daarna komt voortaan bij Rklik van de muis de optie: Opstarten met Windows etc in je context-menu
:)FINI LE TEMPS DU BOUFFON
Though I'm hardly ever smiling, I think it is hilarious it takes a Fool like me to see the madness of reality :)

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #2 Gepost op: 2014/09/18, 10:40:21 »
Ik begrijp je niet hlemelaa? Wubi is bedoeld op Ubuntu mee te installeren staat op de website. En ik kan geen .exe runnen, vandaar dat ik WINE wil.
Ik ben een Ubuntu noob :|

Offline aandendijk

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #3 Gepost op: 2014/09/18, 11:32:45 »
Ik probeer het te begrijpen en eerlijk gezegd valt dat niet mee.
Even wat op een rijtje.
Je hebt dus Ubuntu. Mooi zo. Beter is er niet.
Welke smaak (L, U, of X) en versie (14.04 bijvoorbeeld) gebruik je?
Daarop wil je Wine installeren. Dat snap ik tot zover.
Vervolgens doe je iets ingewikkelds. Wat in mijn ogen simpel kan.
---
Je draait dus een van de smaken van Ubuntu, met een softwarecentrum.
Dat softwarecentrum vind je terug ergens in het menu.
Klik daarop en zoek naar Wine. Klik op installeren en je bent bijna klaar.
Je moet namelijk even wachten tot het softwarecentrum de melding geïnstalleerd laat zien.
Meer is het niet. Dat is alles.
Xubuntu 15.04

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #4 Gepost op: 2014/09/18, 11:50:50 »
Ik draai UBuntu 12.04 LTS.

Ik moet Ubuntu Store open met gksu, omdat hij anders niks isntalleert ivm een rarigheidje op mijn Chromebook. Ik heb de repository toegevoegd. Als ik daarna Wine op zoek in diezelfde store staat, dan staat er als eerste resultaat inderdaad Wine. Maar als ik daarop klik krijg ik:
"There isn’t a software package called “wine1.4” in your current software sources."

Vandaar dat ik het via de terminal probeer. Ik heb trouwens ook Pipelight via de terminal proberen te installeren, maar die geeft dezelfde error als dat ik wine probeer te installeren in de terminal. Tot nu toe heb ik dat bij iedere externe PPA source die ik toevoeg. Ik kan van geen daarvan iets uit de store of via de terminal downlaoden.
Ik ben een Ubuntu noob :|

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #5 Gepost op: 2014/09/18, 11:51:14 »
Wine werkt niet (goed) op Ubuntu ARM en zelfs al krijg je het aan de praat, dan kun je ook alleen maar Windows ARM-apps draaien (welke zeer schaars zijn). Spreek uit ervaring met een Chromebook 2 via Crouton (ook ARM).
« Laatst bewerkt op: 2014/09/18, 11:52:48 door Vistaus »

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #6 Gepost op: 2014/09/18, 12:03:30 »
En Pipelight?
Ik ben een Ubuntu noob :|

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #7 Gepost op: 2014/09/18, 12:10:02 »
Ik heb een alternatief gevonden, PlayOnLinux.
Ik ben een Ubuntu noob :|

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #8 Gepost op: 2014/09/18, 12:15:48 »
2014-09-18 12:13:15,784 - softwarecenter.backend - ERROR - error in _on_trans_finished 'Error: Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

playonlinux: Depends: wine-unstable but it is not going to be installed
             Depends: x-terminal-emulator but it is a virtual package
'
2014-09-18 12:14:01,505 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()


Wanneer ik het probeer te installeren...
Ik ben een Ubuntu noob :|

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #9 Gepost op: 2014/09/18, 12:33:17 »
En Pipelight?

Pipelight produceert geen pakketten voor ARM, maar dan nog zou het niet zomaar werken tenzij de ontwikkelaars van Pipelight een emulatie toevoegen aan de ARM-versie (als die er dus zou zijn).

PlayOnLinux gaat je ook niet verder helpen. Daarmee kun je ook alleen maar schaarse Windows ARM-apps emuleren. Het enige waarmee je ten tijde van schrijven van de post enigszins x86-apps kunt draaien op Ubuntu ARM is Qemu met x86-emulatie en daarin Wine. Maar dan werken alle Wine-apps wel onbruikbaar traag, dus dat is af te raden.

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #10 Gepost op: 2014/09/18, 12:34:27 »
Dus eigenlijk heb ik gewoon de verkeerde Chromebook gekocht? ...

Kan je met uitleggen hoe ik die laatste optie van jou kan gebruiken?
Ik ben een Ubuntu noob :|

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #11 Gepost op: 2014/09/18, 12:45:11 »
Ja, je had beter een Chromebook met Intel-processor kunnen kopen. Dan had je gewoon simpelweg Wine kunnen installeren binnen Ubuntu en alles kunnen draaien. Die laatste optie is echt niet aan te raden want apps zijn dan nauwelijks bruikbaar. Maar als je het echt wilt proberen, kun je QEMU installeren en de hulp-sectie lezen over hoe je x86 emuleert. Doe dat en installeer dan Wine daarbinnen.
De enige andere, iets makkelijkere optie is http://eltechs.com/product/exagear-desktop/ maar die is nog niet verkrijgbaar en kost bovendien geld.
« Laatst bewerkt op: 2014/09/18, 12:47:45 door Vistaus »

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #12 Gepost op: 2014/09/18, 14:09:52 »
Dus eigenlijk open ik dan Ubuntu in Chrome waarin ik weer dat eltech gebruik en daarin gebruik ik WINE en DAARIN gebruik ik windows programmas? haha. Kan ik hierin ook web browsers installeren met Silverlight? Voor school heb ik namelijk MAGISTER nodig, en dat werkt op SIlverlight. En kan ik daarin Minecraft installeren?
Ik ben een Ubuntu noob :|

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #13 Gepost op: 2014/09/18, 14:17:24 »
Eltech is nog niet beschikbaar, maar Qemu dus wel (zoek in je softwarecentrum hierop). Silverlight kun je helaas niet gebruiken, niet via Pipelight en niet via Wine. Minecraft gaat niet lukken vanwege de slechte performance.

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #14 Gepost op: 2014/09/18, 14:20:21 »
Nee maar ik ben van plan ExaGear te kopen, omdat ik bijvoorbeeld Word nodig heb voor mijn school. Maar ik bedoel; is dat ExaGear een soort nieuwe OS, waarin ik wél Silverlight kan installeren? En de performance van ExaGear is 89% terwijl die van Quma iets van 10% is. Maar ik kan dus ook geen silverlight installeren aan de hand van ExaGear?
Ik ben een Ubuntu noob :|

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #15 Gepost op: 2014/09/18, 14:41:17 »
ExaGear is eigenlijk wat Qemu ook doet, alleen dan beter geoptimaliseerd omdat het voor één doeleinde is. Word zal wel lukken, hoewel je voor school ook Word Online kan gebruiken die zelfs op ChromeOS toppie werkt.
Silverlight gaat echt niet lukken, ook niet met ExaGear.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #16 Gepost op: 2014/09/18, 20:21:18 »
....

Sorry dat ik er niet zo veel van snap, ik ben pas 12 en heb nog nooit Linux gebruikt.

Mvg,
Bram

Ik vind dat je al behoorlijk ver komt als een 12 jarige en vooral als beginner.  ;)

Wine op een arm processor gaat niet zomaar lukken.
PlayOnLinux ook niet omdat deze wine nodig heeft.

Betreft tekstverwerkers en office paketten heb je verschillende merken. MS office is daar de bekenste van.
In Ubuntu is LibreOffice standaard geïnstalleerd en bied alles wat je standaard voor school nodig hebt.

Een linux tegehanger voor Silverlight is Pipelight.
Ik heb begrepen dat het de meeste onderdelen van Silverlight prima ondersteund, maar niet alles.
Ik kom op Internet idd tegen dat Pipelight niet zomaar op een arm processor draait. Dit omdat Pipelight de orginele Silverlight versie gebruikt en deze niet beschikbaar is op arm en zal waarschijnlijk ook niet komen.
http://fds-team.de/cms/pipelight-installation-comments-6.html

Betreft Minecraft. Volgens mij kan dat gewoon direct in Ubuntu draaien.

Ik weet niet helemaal precies wel en niet met een ARM processor werkt. Ik heb thuis een BeagleBoard om dingen met ARM uit te proberen, maar ik ben daar nog niet veel aan toe gekomen.
« Laatst bewerkt op: 2014/09/18, 20:23:17 door Erik Krom »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #17 Gepost op: 2014/09/18, 20:31:51 »
@Erik: Lees ook even mijn posts ;) Pipelight niet werkend had ik al vermeld. Minecraft heeft, zoals ik al vermeldde, geen ARM-versie. LibreOffice heeft bij mijn weten ook geen ARM-versie. MS Office Online werkt echter keurig in zowel ChromeOS als Ubuntu ARM.

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #18 Gepost op: 2014/09/18, 21:04:09 »
Maar ik snap niet precies wat Qemu doet. Is dat een programma waarin ik .exe kan runnen of wat is het? Ik snap niet echt wat het is... Kan je het misschien uitleggen?
Ik ben een Ubuntu noob :|

Offline bremdecoolste

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #19 Gepost op: 2014/09/23, 09:59:25 »
Bump. Heb ik er wel de correcte Linux-kernel voor?
Ik ben een Ubuntu noob :|

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Wine probleempje
« Reactie #20 Gepost op: 2014/09/24, 12:58:42 »
Qemu is een hardware emulator. Als je dus Qemu gebruikt dien je een volledige virtuele machine te installeren. Qemu is in dat opzicht te vergelijken met Virtualbox, VMware edm.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Wine probleempje
« Reactie #21 Gepost op: 2014/10/11, 19:36:45 »
Ik heb vandaag eens lopen proberen met mijn Beaglebone.
Hierop heb ik een Debian installatie staan met een lichte desktop omgeving.
Zonder problemen heb ik LibreOffice van uit de pakketbronnen kunnen installeren.
Gebruiken gaat wat lastiger omdat ik al snel niet genoeg ram geheugen heb.
Ik heb ergens met de installatie iets niet goed gedaan waardoor er naar mijn idee meer ram geheugen wordt gebruikt dan nodig, maar heb evengoed een voorbeeld kunnen maken.