Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: update en install werk niet door verkeerd libre office pakket  (gelezen 831 keer)

Offline ayla

  • Lid
  • Steunpunt: Nee
Hallo voor iemand in duitsland de volgede vraag

ik probeer een upgrade te maken maar het systeem kan geen upgrade of een install maken door de volgende melding:

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

libreoffice-calc: Depends: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
                  Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-gnome: Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-gtk: Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-writer: Depends: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
                    Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert

ik heb geprobeerd om libre office te verwijderen maar dat lukt niet:

sudo apt-get remove --purge libreoffice-core
dan komt opnieuw deze fout melding

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

libreoffice-calc: Depends: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
                  Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-gnome: Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-gtk: Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
libreoffice-writer: Depends: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert
                    Depends: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist bereits installiert


wie weet hier in oplossing voor?






Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #1 Gepost op: 2014/09/10, 10:23:23 »
Verwijderen is simpel:sudo apt-get purge libreoffice-core
sudo apt-get autoremove
Maar beter lijkt het mij, om eerst de database te updaten:sudo apt-get update
sudo apt-get upgrade
Gaat het dan ook niet?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #2 Gepost op: 2014/09/10, 12:04:08 »
Verwijderen is simpel:sudo apt-get purge libreoffice-core
sudo apt-get autoremove
Maar beter lijkt het mij, om eerst de database te updaten:sudo apt-get update
sudo apt-get upgrade
Gaat het dan ook niet?

Ron bedankt voor je reactie dit is de uitkomst

sudo apt-get purge libreoffice-core
[sudo] password for stefan:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libreoffice-avmedia-backend-gstreamer : Hängt ab von: libreoffice-core soll aber nicht installiert werden
 libreoffice-base-core : Hängt ab von: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) soll aber nicht installiert werden
 libreoffice-calc : Hängt ab von: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 soll installiert werden
                    Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) soll aber nicht installiert werden
 libreoffice-draw : Hängt ab von: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) soll aber nicht installiert werden
 libreoffice-gnome : Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) soll aber nicht installiert werden
 libreoffice-gtk : Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) soll aber nicht installiert werden
 libreoffice-impress : Hängt ab von: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) soll aber nicht installiert werden
 libreoffice-math : Hängt ab von: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) soll aber nicht installiert werden
 libreoffice-ogltrans : Hängt ab von: libreoffice-core soll aber nicht installiert werden
 libreoffice-pdfimport : Hängt ab von: libreoffice-core soll aber nicht installiert werden
 libreoffice-writer : Hängt ab von: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 soll installiert werden
                      Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) soll aber nicht installiert werden
 mythes-de : Hängt ab von: libreofficep-core soll aber nicht installiert werden oder
                            openoffice.org-core (>= 3.0~) ist aber nicht installierbar
 mythes-en-us : Hängt ab von: libreoffice-core soll aber nicht installiert werden oder
                               openoffice.org-core (>= 1.9) ist aber nicht installierbar oder
                               language-support-writing-en ist aber nicht installierbar
 python3-uno : Hängt ab von: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
stefan@stefanST:~$

en voor upgrade

$ sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libreoffice-calc : Hängt ab von: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
                    Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
 libreoffice-gnome : Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
 libreoffice-gtk : Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
 libreoffice-writer : Hängt ab von: libreoffice-base-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
                      Hängt ab von: libreoffice-core (= 1:4.2.4-0ubuntu2) aber 1:4.2.3~rc3-0ubuntu2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
stefan@stefanST:~$

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #3 Gepost op: 2014/09/10, 12:13:19 »
"Probieren Sie »apt-get -f install«, um dies zu korrigieren.", dus:
sudo apt-get -f install

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #4 Gepost op: 2014/09/10, 12:14:21 »
Dan moet het toch simpel op te lossen zijn .......
sudo apt-get update && sudo apt-get upgrade && sudo apt-get install -y libreoffice && sudo apt-get install -f
En ik zou niet weten, waarom het niet zou werken, tenzij je een PPA hebt benoemd voor LibreOfice ........

@Pjotr: We zeggen hetzelfde, alleen na het "purge" gebeuren lijkt het mij beter, om alles te updaten.
« Laatst bewerkt op: 2014/09/10, 12:16:21 door Ron »
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #5 Gepost op: 2014/09/10, 12:56:44 »
"Probieren Sie »apt-get -f install«, um dies zu korrigieren.", dus:
sudo apt-get -f install

Pjotr bedankt over het hoofd gezien, dat dit kon werken door dat er achter install niets stond/staat.

na

apt-get -f install
werken de updat en upgrade weer





Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #6 Gepost op: 2014/09/10, 16:16:50 »
Dan heb ik het onderwerp nu als "opgelost" gezet.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline jfh

  • Lid
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #7 Gepost op: 2014/10/02, 23:03:11 »
Maar voor mij is het probleem nog steeds niet opgelost. ik blijf de melding krijgen dat libreoffice-base moet worden verwijderd, maar dat lukt mij niet.
Alle manieren die tot nu toe zijn aangegeven heb ik geprobeerd, maar niets helpt. Kan iemand mij vertellen hoe ik LO-base kan verwijderen, of zelfs de hele LO-suite. Ook opnieuw installeren via het terminalvenster heeft geen resultaat opgeleverd. HELP!!!!

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #8 Gepost op: 2014/10/03, 11:40:44 »
Maar voor mij is het probleem nog steeds niet opgelost.

Dat maakt voor het markeren als opgelost niet uit want dit is niet jou topic.

Welke versie van Ubuntu gebruik je? En heb je PPA's toegevoegd?

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Re: update en install werk niet door verkeerd libre office pakket
« Reactie #9 Gepost op: 2014/10/03, 23:56:56 »
Maar voor mij is het probleem nog steeds niet opgelost. ik blijf de melding krijgen dat libreoffice-base moet worden verwijderd, maar dat lukt mij niet.
Alle manieren die tot nu toe zijn aangegeven heb ik geprobeerd, maar niets helpt. Kan iemand mij vertellen hoe ik LO-base kan verwijderen, of zelfs de hele LO-suite. Ook opnieuw installeren via het terminalvenster heeft geen resultaat opgeleverd. HELP!!!!

Je zou het "handmatig" kunnen proberen door het volgende te doen:

Eerst:
mv /var/lib/dpkg/info/libreoffice-base.* /tmp/
Daarna:
dpkg --remove --force-remove-reinstreq libreoffice-base
Hopelijk helpt het je verder...
I'm just a simple guy who uses open source software. What's your excuse?