Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: vidix driver issue onder ubuntu dapper drake 64bit  (gelezen 651 keer)

PelliX

  • Gast
vidix driver issue onder ubuntu dapper drake 64bit
« Gepost op: 2007/03/24, 09:32:46 »
Hi,

Ik gebruik het volgende hierbij:
Ubuntu 6.06, 64bit op een AMD64X2.
MSI ATi Radeon RX1600 Pro.

Mijn probleem is het volgende: Ik heb een paar ouwe pentium 1tjes en wat 486jes staan op zolder, waar ik nooit wat mee doe, afgezien van testen van sommige bootdisks voornamelijk. Dus toen kwam ik op het idee om video te gaan streamen (wat aan de 'server side' verwerkt word) naar deze 'terminals' over SSH2 (spreek, win95 erop met PuTTY, of een DOS met SSH support).
Het is meer een knutselproject dan een poging om wat nuttigs te bereiken.

In ieder geval heb ik dus alle benodigde packages geinstalleerd voor mplayer(ook trouwens geupdate) op mijn ubuntu machine. Ik heb dus de libraries voor ASCII art en color ASCII art en zelfs de caca-utils geinstalleerd voordar ik de mplayer heb gecompiled. De compilatie ging op zich wel redelijk (geen al te bonte errors) en de mplayer speelt ook wel mijn testfilmpje als ik em draai met bash>mplayer -vo null 1.mpg (1.mpg is dan het testfilmpje). Hierbij moet ik toegeven, ik heb dit niet onder X11 geprobeerd, omdat het ook niet de bedoeling was van het geheel.
Maar als ik bijvoorbeeld mplayer -vo caca 1.mpg gebruik, zegt hij dat hij die output niet kan vinden.
Dus: mplayer -vo help : en ik krijg een heel lijstje, maar de enige output driver die van toepassing zou kunnen zijn is cvidix. hierbij neem ik trouwens aan dat het cvidix heet voor ConsoleVidix...? Maar als ik mplayer -vo cvidix 1.mpg gebruik geeft hij mij het volgende:

vo_cvidix: No vidix driver name provided, probing available ones (-v option for details)!
[VO_SUB_VIDIX] Couldn't find working VIDIX driver.
Error opening/initializing the selected video_out (-vo) device.

Ik ben meestal geen 'forum lezend iemand' maar in dit geval heb ik me best plat gegoogled, en iedereen schijnt van mening te zijn dat de video drivers niet in orde zijn. Nou heb ik zelf redelijk veel met linux gewerkt, maar meer servers opzetten voor (web)applicaties, zaken automatiseren, en vreemde dedicated doeleinden. Op het gebied van media onder linux heb ik me nooit mee bezig gehouden, met uitzondering van xmms, wat voor mijn doen een vereiste voor een desktop machine is.
Maar ik zie het nut van een vga driver niet in, als via de console die machine benader. Hij hoeft ook geen hardware rendering te doen, puur het beeld door de ASCII art filter gooien naar de terminal output.
En de fout zelf zegt me dat het om de 'vidix driver' gaat. Of deze afhankelijk is van de radeon driver weet ik niet. Ook lijkt het erop dat ik eigelijk het commando niet gode invul, ivm met 'No vidix driver name provided' maar ik zou niet weten hoe of wat ik in zou moeten vullen. Verwijzingen naar de radeon.so helpen niet, en bovendien merk ik dat ik geen libdha heb.
Ik kan deze ook niet als broncode of deb pkg krijgen, enkel rpm formaat. Dus als iemand mij misschien toch nog een hintje zou kunnen geven voordat ik de rpm's uit mekaar moet pluizen, zou ik erg dankbaar voor zijn.

groeten

PelliX

PelliX

  • Gast
vidix driver issue onder ubuntu dapper drake 64bit
« Reactie #1 Gepost op: 2007/04/30, 18:07:33 »
Hmmmzzz... great forum, een computer verder, probleem opgelost (door m'n eigen geknutsel) maanden later en nog geen reactie...

Cool... toch weer een grote tegenvaller van de linux community, of misschien zijn het alleen ubuntu gebruikers, die een kant en klaar windows pakketje willen, ipv van zelf source compile op een recente debian kernel.

Success en probeer anders suse, met klik-er-doorheen wizards en minimale shell gebruik.

Offline siegi

  • Lid
  • Steunpunt: Nee
vidix driver issue onder ubuntu dapper drake 64bit
« Reactie #2 Gepost op: 2007/04/30, 18:12:49 »
Er zijn redelijk wat vragen op dit forum en soms ontglipt er eens een vraag als je het nu gewoon even naar boven had geschopt had je meest waarschijnlijk wel antwoord gehad.
Suse heeft echt ook wel zijn nadelen hoor,

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
vidix driver issue onder ubuntu dapper drake 64bit
« Reactie #3 Gepost op: 2007/04/30, 19:30:27 »
Wat siegi zegt klopt volledig. Ook is je probleem niet iets waar veel mensen direct antwoord op kunnen geven. En daarbij komt nog dat je geen duidelijke vraag hebt gesteld..

Ik weet niet wat je nu precies wou. Video uitvoer via libcaca laten werken of via cvidix (of via een framebuffer met fbdev(2)).

De versie van mplayer in Feisty Fawn bevat trouwens sowieso fbdev, fbdev2, cvidix, caca en aa, ik weet niet of dit ook al het geval was bij Edgy en/of Dapper. Maar fbdev2 werkt prima hier om beeld te krijgen op de framebuffer.

Citaat van: PelliX
Hij hoeft ook geen hardware rendering te doen, puur het beeld door de ASCII art filter gooien naar de terminal output.
Dat doet me dan weer vermoeden dat je toch libcaca wil gebruiken... Dus ik zie door de bomen het bos niet meer.

Ik wil ook nog ff kwijt dat ik het heel onbeleefd vind om dit soort reactie te plaatsen. Wij zijn vrijwilligers en wij worden niet betaald om jou te helpen, dus we zijn jou niets verplicht. En dat sarcasme kunnen we hier ook wel missen. Geef liever wat constructieve commentaar, zoals bijvoorbeeld de oplossing voor je probleem, zodat andere mensen er misschien nog baat van hebben in de toekomst.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

PelliX

  • Gast
vidix driver issue onder ubuntu dapper drake 64bit
« Reactie #4 Gepost op: 2007/07/20, 00:38:28 »
Hoi,

voor de duidelijkheid; ik draai geen suse, dat was inderdaad sarcasme, en wellicht met slechte smaak... mijn excuses

Wat betreft de oplossing, nou ja, ik kan er weinig van zeggen, ik installeerde debian 3.1 (stable!), vervolgens de media libraries erop, daarna met enige moeite de ati driver package (hiervoor is er een wiki... zeer uitgebreid) geinstalleerd, en aansluitend  caca-utils en de mplayer van source gecompileerd. Dus niet echt bepaald een uitdaging, maar waar de fout nou precies zou hebben gelegen... goeie vraag.

En ja, de bedoeling was om het via caca (of een alternatief) via de terminal te draaien, wat overigens niet slecht loopt, met een fatsoenlijke en/of compatible NIC bij de client.

groeten

PelliX