Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache +PHP5 problemen na update van 12.04.3 naar Ubuntu Linux 14.04.1  (gelezen 438 keer)

Offline kevinx

  • Lid
  • Steunpunt: Nee
Ik heb vanmorgen een do-release-upgrade gedaan van 12.04 naar Ubuntu Linux 14.04.1.  Zover als ik kan nagaan is het upgraden redelijk goedgegaan. Alleen de upgdrade van de Apache is flink in het honderd gelopen.

Had ik eerst Apache 2.2.22 (als ik me niet vergis). Nu is de versie 2.4.7 geïnstalleerd. Buiten dat alle door mij ingestelde virtual host zijn verdwenen heb ik nu problemen met de PHP5 en de include functie.

Als ik in Apache (via webmin 1.700) bij 'Configureer Apache Modules' de module PHP5 aanvink en Apache probeer te restarten, dan krijg ik de melding: 

* Stopping web server apache2
 *
 * There are processes named 'apache2' running which do not match your pid file which are left untouched in the name of safety, Please review the situation by hand.


Probeer ik bij Apache ; 'Wijzigingen toepassen'-link, dan krijg ik de melding:

Fout bij het toepassen van de wijzigingen :

apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.


Wie kan mij helpen om genoemde problemen op te lossen? Als ik het probleem kan oplossen door de vorige versie van Apache te installeren is mij dat prima. In dat geval zou ik graag horen hoe ik deze versie kan verwijderen en de oude kan installeren.

Alvast bedankt!

kevinx

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Apache +PHP5 problemen na update van 12.04.3 naar Ubuntu Linux 14.04.1
« Reactie #1 Gepost op: 2014/09/04, 14:50:37 »
Misschien gewoon de LAMP server verwijderen en opnieuw installeren?
Wel is het zo, dat vroeger de website in /VAR/WWW stond, maar nu in /VAR/WWW/HTML staat.
Kan daar iets mee fout zijn?
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline daniel

  • Lid
  • Steunpunt: Nee
Re: Apache +PHP5 problemen na update van 12.04.3 naar Ubuntu Linux 14.04.1
« Reactie #2 Gepost op: 2014/09/05, 14:32:33 »
probeer eens:

sudo apache2ctl restart
sudo apache2ctl start

Offline daniel

  • Lid
  • Steunpunt: Nee
Re: Apache +PHP5 problemen na update van 12.04.3 naar Ubuntu Linux 14.04.1
« Reactie #3 Gepost op: 2014/09/05, 14:37:14 »
Wat Ron zegt klopt ook, de pad namen zijn in 14.04 anders en daarom kun je als het boven staande niet helpt het beste lamp volledig verwijderen en de computer herstarten en opnieuw installeren en configureren.