Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: installatie lukt niet  (gelezen 596 keer)

Offline m

  • Lid
  • Steunpunt: Nee
installatie lukt niet
« Gepost op: 2014/09/02, 14:47:33 »
Dag allemaal,

Gebruik sinds 2005 linux, heb diverse keren via dit forum advies moeten vragen en doe dat nu maar weer.

Had een pc  met dual boot van Ubuntu en Windows 7 en heb (uit gemakzucht...) via update beheer de upgrade naar laten plaatsvinden (inderdaad spijt van... )en dit ging niet goed: pc start niet meer op.

Daarna op een usb stick nwe versie 14.04.1 gezet en dit geprobeerd te installeren wat diverse foutmeldingen bleef geven tijdens de installatie.
Uiteindelijk een Linux mint cd gepakt (waarvan ik weet dat deze geen fouten bevat) en dit geprobeerd te installeren: dit gaat goed tot er een foutmelding volgt dat 'grub' niet te installeren is.

Graag tips, bij voorbaat dank!

M.

Offline Ronaldus

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #1 Gepost op: 2014/09/02, 16:01:41 »
Voor een volgende keer:

Ik gooi in Windows normaal eerst de Ubuntu schijfgedeeltes weg (Ubuntu zelf + Swap partitie) en herstel de mbr van Windows met het programma EasyBCD. (dan heb je gewoon weer een normaal opstartbare Windows op een gedeelte van je harde schijf staan)
Daarna installeer ik de nieuwe Ubuntu versie op het weer lege schijfgedeelte naast de al bestaande Windows.
Je moet dan wel een nog opstartbare Windows hebben. Grub wordt dan opnieuw aangemaakt.

Zie voor een howto:
https://www.youtube.com/watch?v=vt0N2Cpv8CM
http://neosmart.net/EasyBCD/

Misschien kun je nu Windows herstellen met de installatieschijf van Windows? Of Grub verwijderen met de tips van Pjotr?
(Kun je daarna evt. alsnog weer Linux installeren)

Zie:
https://sites.google.com/site/computertip/grub#TOC-Grub-verwijderen-terug-naar-uitsluitend-Windows-
« Laatst bewerkt op: 2014/09/02, 16:32:17 door Ronaldus »
5 pc's in 'actieve dienst'. Daarop draaiend:
** Mint XFCE 18.2 (gezins pc/hoofd pc) ** W10 (werk-pc) ** Mint XFCE 18.3 (laptop 1)  ** Mint Cinnamon 18.3 (laptop 2) ** W10 (laptop 3) **
Randapparatuur:
** Scanner: een compacte Canon Lide 110 (werkt 'out of the box' in Linux + voeding via usb) + div. HP's ** Printer: div. HP's **

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #2 Gepost op: 2014/09/02, 17:14:09 »
Zoals Ronaldus zegt, maar probeer eerst eens om Grub handmatig te installeren:
https://sites.google.com/site/computertip/grub#TOC-Grub-herstellen-bij-ouderwets-BIOS-bijvoorbeeld-omdat-Windows-Grub-heeft-overschreven-
(punt 2, linkerkolom)

Ik heb zelf namelijk een computer gehad, waarop het installatieprogramma van Ubuntu en Linux Mint (ubiquity), er gewoon niet in slaagde om Grub te installeren aan het einde van de installatie-riedel van het besturingssysteem. Na handmatige installatie van Grub, was het probleem alsnog opgelost.

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #3 Gepost op: 2014/09/02, 17:26:40 »
Dag Ronaldus,

Dank voor je reactie!

Heb Windows eigenlijk niet (meer) nodig (wil ervan af) en wilde de nieuwe Ubuntu 14.04.1 (en nu dus die Linux Mint versie) ervoor in de plaats installeren.
Dit staat op 1 harde schijf, op de andere harde schijf staan de Ubuntu versies, die het nu na die upgrade van 14.04.1 niet meer doen.

Heb die site  van Pjotr meerdere keren bekeken en een aantal dingen uitgeprobeerd maar ik krijg "Grub" niet geinstalleerd.
Niet via de "Terminal" en van "Gparted" begrijp ik te weinig.

Wie kan me verder helpen met wat gerichte vragen?

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #4 Gepost op: 2014/09/02, 17:31:04 »
Dag Pjotr,

Ik herken die pagina van jou maar kwam er niet mee verder.

Als ik Gparted open, worden de harde schijven genoemd, ook met extentie als 'ext' en 'swap', maar bij 'sda' en 'sdb' staat: " unallocated".

Heb je nog een suggestie?

Bvd,

M.

Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #5 Gepost op: 2014/09/02, 18:56:41 »
Als je de windows installatie niet meer wilt gebruiken is nog simpeler. Boot met een live Linux CD, Ubuntu, Mint whatever, start Gparted, gooi alle partities weg, laat Gparted de wijzigingen doorvoeren, sluit Gparted en daarna start je de nieuwe installatie vanaf je live CD.

Omdat je 2 harde schijven hebt installeer dan Linux op de eerste disk, sda De ander disk kan je dan voor andere data gebruiken.

Denk er wel even over na of er nog data op je partities staat die je wilt behouden, want dat ben je namelijk kwijt zodra je bovenstaande uitvoert.

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #6 Gepost op: 2014/09/02, 19:28:54 »
Dag Moob,


Heb ik geprobeerd, die harde schijf heet niet "sda" of "sdb" maar " /dev/mapper/isw_ciehdachae_ARRAY1", maar dan krijg ik op het laatst:


"Uitvoeren van 'grub-install /dev/mapper' is mislukt.

Dit is een fatale fout."


En zo komt 't dus niet goed. Wat doe ik fout?

Bvd,

M.

Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #7 Gepost op: 2014/09/02, 20:52:02 »
Als er geinstalleerd wordt op een /dev/mapper/* device lijkt het erop dat je schijven zijn samengevoegd tot een LVM of RAID device. Deze keuze zou je moeten krijgen aan het begin van het installatie proces. 

Als je aan het begin kiest voor LVM zou je eens kunnen proberen om voor een normale disk te kiezen, dus geen LVM en dan kijken of de installatie van grub wel lukt.

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #8 Gepost op: 2014/09/03, 12:12:41 »
Hmm. heb gekeken bij het opnieuw installeren of ik ergens een keuze qua RAID of LVM kan maken maar zie niet hoe.
Weet niet goed waarom dit op mijn pc zo heet, heb de betekenis ervan opgezocht maar kom zo niet verder.

Hoe krijg ik nu een nieuwe werkende versie van Ubuntu op een van de 2 harde schijven, liefst zo dat ik dan ook nog de oude bestanden kan behouden?

Bvd,

M.

Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #9 Gepost op: 2014/09/03, 13:18:43 »
Ik heb even getest met Ubuntu 14.04.1 in een virtuele machine. Als je kiest voor 'Install Ubuntu' krijg je op een gegeven moment de vraag welk Installatie Type je wilt uitvoeren, encrypted disken, LVM gebruiken of anders.

Als je voor de optie 'Anders' kiest dan kan je kiezen op welke disk je ubuntu wilt installeren, sda, sdb etc

Installeren met behoud van data wordt lastig. Je zou dan moeten kiezen voor de 'Anders' installatie, de disk selecteren waarop geinstalleerd moet worden maar verder niets formateren ! De nieuwe installatie wordt dan over de oude installatie heengezet. Dit houd wel in dat files van de vorige ubuntu versie kunnen blijven rond slingeren. Ik kan ook niet garanderen dat er geen files worden overschreven die belangrijk voor je zijn.

Omdat je al vermelde dat de grub installatie faalde vermoed ik dat je data al niet meer aanwezig is omdat grub als laatste wordt geinstalleerd, nadat heel ubuntu is geinstalleerd. Je kan dit testen door te booten met een live cd en dan te kijken of je jou persoonlijke data op je schijven ziet staan. Bijvoorbeeld op /home/m

Bepaal eerst even wat je wilt, windows behouden of niet ? Indien je die wilt volg dan de post van Ronaldus. Dan kan je daarna op sdb ubuntu installeren. Als je windows niet wilt behouden dan kan je tijdens de ubuntu installatie kiezen om alle disken te wissen.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #10 Gepost op: 2014/09/03, 14:01:52 »
Misschien in je bios raid aan staan?(in je bios moet je harde schijf controller op AHCI staan, voordat je installeren doet).
Misschien aparte raid kaart, die zie je na je bios verschijnen(lijkt op je bios).

Anders start vanaf de livecd, en wis je hd helemaal,

Let op harde schijf wordt nu helemaal leeg gemaakt:

Nu booten van de ubuntu livecd,(of gparted livecd of parted magic(hier zit gparted en clonezilla in)).
Gparted starten,
kies rechtsboven je hd,
unmount hd,
verwijder alle partities,
boven in gparted de pulldown menu, kiezen device, Create partion table(mbr wissen),
(boven in gparted de pulldown menu, kiezen partition, manage flags, vink hier alles uit,)
doe dit voor alle hd's, reboot en installeer ubuntu of windows.

Zo maak je de hd ook schoon van virussen, formateren is niet genoeg.
En als je meerdere hd's hebt, dan moet je ook de andere hd's de mbr wissen,
want als je 1x boot vanaf die hd's die geinfecteerd is, dan ben je weer geinfecteerd.

Na het wissen, kijk met gparted of je niet raid aangevinkt hebt, bij partitie , rechts klik muis dan info over je partitie, zet daar raid uit.

Dan opnieuw installeren proberen.
« Laatst bewerkt op: 2014/09/03, 14:03:49 door jan11000 »

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #11 Gepost op: 2014/09/03, 16:23:38 »
Dag Moob en Jan 11000,

Dank voor jullie reacties, ga ik mee aan de slag.

Grtz.

M.

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #12 Gepost op: 2014/09/09, 11:44:20 »
Dag allen,

Installatie van Linux mint lijkt gelukt te zijn.

Lijkt, want als ik Gparted wil gebruiken en het wachtwoord hiervoor geef, werkt het niet en is het ook niet meer zichtbaar, heb Gparted verwijderd en opnieuw toegevoegd, maar dit helpt niet.

De tweede harde schijf, waar ik graag de gegevens van zou willen redden, kan ik ook niet terugvinden en dus niet openen.
Alleen als ik Disk utility open, zie ik die 2e HDD verschijnen: "connection unknown".

Graag verdere tips,
bvd!

m.



Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #13 Gepost op: 2014/09/09, 12:11:07 »
Probeer anders eens gparted vanaf de commandline te starten, mocht er dan iets fout gaan dan zie je tenminste een foutmelding.
Terminal sessie openen en dan ingeven sudo gparted

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #14 Gepost op: 2014/09/09, 13:26:46 »
Dag Moob,

Dank je, heb dat ingevoerd en krijg:

/usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

Wat nu?

m.

Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #15 Gepost op: 2014/09/09, 13:37:07 »
Het lijkt erop dat de libgtkmm niet is geinstalleerd waardoor gparted niet kan starten. Wel vreemd omdat als je een applicatie vanuit het software centrum of synaptic installeert ook altijd de afhankelijkheden geinstalleerd worden.

Dit kan je oplossen door Synaptic te starten en dan even te zoeken naar libgtkmm en deze te installeren.

NB als je zoekt naar gparted en dan de eigenschappen opvraagd kan je zien welk bibliotheken deze nodig heeft c.q. mist.

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #16 Gepost op: 2014/09/09, 14:48:02 »

Heb via Synaptic dat 'libgtkmm-2.4' laten aanvullen en hetzelfde met gparted gedaan, krijg toch de hieronderstaande melding als in een Terminal 'sudo gparted' invul:

"/usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory"


Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #17 Gepost op: 2014/09/09, 15:56:03 »
Dan lijkt het erop dat gparted de bibiliotheek niet kan vinden.

Geef eens in
sudo ldconfig -v | grep -i libgtkzie je dan de libgtkmm bibliotheek staan ?

Wat je ook nog kan proberen is om de bibliotheek lokatie even specifiek op te geven. In hetzelfde terminal scherm geef je in:
export LD_LIBRARY_PATH=/usr/libNB bij mij staat de libgtk in /usr/lib het kan zijn dat deze bij jou op een andere locatie staat.

Daarna start je nog eens gparted.

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #18 Gepost op: 2014/09/09, 18:52:22 »
......... als ik Gparted wil gebruiken en het wachtwoord hiervoor geef, werkt het niet en is het ook niet meer zichtbaar, heb Gparted verwijderd en opnieuw toegevoegd, maar dit helpt niet.

Download de iso van GParted, gebruik in je brandprogramma de optie om die iso als image op een cd te branden en start met die cd je pc op. Heb je geen wachtwoord voor nodig. ;)

Offline m

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #19 Gepost op: 2014/09/09, 20:32:22 »
Dag Moob,

In terminal ingevoerd: "sudo ldconfig -v | grep -i libgtk" geeft:

"sudo ldconfig -v | grep -i libgtk
[sudo] password for t:
/sbin/ldconfig.real: Can't stat /lib/i686-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/lib/i686-linux-gnu: No such file or directory
/sbin/ldconfig.real: Path `/lib/i386-linux-gnu' given more than once
/sbin/ldconfig.real: Path `/usr/lib/i386-linux-gnu' given more than once
/sbin/ldconfig.real: Cannot stat /usr/lib/i386-linux-gnu/libgtkmm-2.4.so: No such file or directory
/sbin/ldconfig.real: Cannot stat /usr/lib/i386-linux-gnu/libgdkmm-2.4.so: No such file or directory
   libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.2400.10
   libgtksourceview-3.0.so.0 -> libgtksourceview-3.0.so.0.0.0
   libgtk-3.so.0 -> libgtk-3.so.0.400.2
   libgtkmm-utils.so.2 -> libgtkmm-utils.so.2.0.0
   libgtkspell-3.so.0 -> libgtkspell-3.so.0.0.0
   libgtkspell.so.0 -> libgtkspell.so.0.0.0
   libgtkmm-3.0.so.1 -> libgtkmm-3.0.so.1.1.0
t@t-desktop ~ $"

In Terminal ingevoerd "export LD_LIBRARY_PATH=/usr/lib" geeft:

"t@t-desktop ~ $ export LD_LIBRARY_PATH=/usr/lib
t@t-desktop ~ $"

Dag Mikkel, dank voor je tip; zie beetje op tegen dat branden van de ISO van Gparted, maar als niets helpt ga ik dat wel proberen.

m.

Offline Moob

  • Lid
  • Steunpunt: Nee
Re: installatie lukt niet
« Reactie #20 Gepost op: 2014/09/10, 11:50:24 »
Als je op de lokatie  /usr/lib/i386-linux-gnu/libgdkmm-2.4.so kijkt, zie je daar dan wel beide lib files staan ?