Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Zwart beelscherm na installatie  (gelezen 497 keer)

Offline Jan_Kol

  • Lid
  • Steunpunt: Nee
Zwart beelscherm na installatie
« Gepost op: 2014/08/26, 23:23:29 »
Wat kan er mis zijn?  Op een HP Pavilion dv6361eu (Processor: AMD Turion 64 X2 TL-56, RAM: 2 GB, Harde schijf: SSD 119,2 G, in gebruik: sinds 2007) probeer ik Ubuntu  (vanaf DVD gemaakt met ubuntu-14.04.1-desktop-i386.iso) te installeren.  Dat gaat prima tot ik de laptop na installatie en verwijderen van de Ubuntu-installatie DVD herstart.  Het controlelampje van de harde schijf licht op en na verloop van tijd gaat het uit.  Ik zie wel het HP-vignet als het opstarten net is begonnen, dan heel even Ubuntu met de “startstippen” er onder.  Daarna valt het scherm op zwart en dat blijft het.

Ik heb Ubuntu 3 x geïnstalleerd met 3 x een nieuw aangemaakte DVD van steeds een nieuw gedownload ISO-bestand van de Ubuntu website, NL deel (http://nl.releases.ubuntu.com/trusty/ubuntu-14.04.1-desktop-i386.iso).  In alle 3 gevallen blijft het resultaat hetzelfde.

Wie heeft een idee of advies?

Alvast dank voor een reactie,

Jan

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #1 Gepost op: 2014/08/26, 23:24:33 »
Start 'm eens op in de herstelmodus (recovery)?

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #2 Gepost op: 2014/08/27, 08:26:16 »
Waarschijnlijk gaat er wat mis met de grafische driver.
Wat is de grafische kaart in de computer?

Offline Jan_Kol

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #3 Gepost op: 2014/08/27, 19:14:31 »
Dank voor de reacties..

De videokaart is een GeForce Go 7200 (volledige specificaties alleen nog bij Tweakers.net).

Toch zie ik het als iets vreemds, want installeren vanaf een DVD lukt uitstekend en direct na opstarten van de laptop zie ik heel even Ubuntu staan en zie de stipjes, die de opstartvoortgang aangeven (wit word  rood etc.), ook van kleur veranderen. Dan valt alles op zwart op de muisaanwijzer na.  Het pijltje verschijnt op een gegeven moment wel, zo zag ik later toen ik mijn vraag (op een andere computer) had gesteld en de muis bewoog.  En dan zou je toch mogen veronderstellen dat de videokaart door Ubuntu wordt gezien.....

Op dezelfde laptop heeft Ubuntu ook als virtuele machine gefunctioneerd toen ik er Windows 7 op liet draaien, alleen dan draait Ubuntu – voor zover ik weet en kan zien – op de door Virtualbox ge-emuleerde videokaart.

Jan


Offline Ramana

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #5 Gepost op: 2014/08/27, 19:59:45 »
Heb altijd een zwart scherm op de dmi-uitgang van mijn amd-moederbord, niet op de vga- uitgang. Dit ligt aan de open sourse driver. Met de ATI/AMD driver heb weer beeld op de dmi-uitgang.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #6 Gepost op: 2014/08/27, 21:03:44 »
Jan,

Tja een nVidia 7200, in mijn desktop zit een nVidia 7300...
Om een of andere duistere reden werkt deze niet met de nouveau driver.

Hoe dit te om zeilen ...
Zoals Pjotr het al aankaarte, opstarten herstelmodus (recovery).
Eerst kiezen dat je netwerk actief wordt, dus werken met een draadje ipv draadloos heeft de voorkeur.
Dan opstarten van de terminal mode, dus de text mode (helaas niet grafisch).
Het zal om je paswoord vragen en je zit gelijk als root ingelogd.
Dan de de nVidia Proprietary driver installereen.
Hier heb je keuze uit twee versie's: nvidia-current en nvidia-173
Mijn 7300 draai met de nvidia-current, dus ik vermoed dat de 7200 er ook mee zal werken.
Dus de opdracht wordt:
apt-get install nvidia-current
Laat het zijn ding doen .... Als die klaar is herstarten.

MvG,
MauRice
Registered Linux user: 473556

Offline Jan_Kol

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #7 Gepost op: 2014/08/29, 16:05:36 »
Pffff, ik heb beeld.  Helaas werkte het laatste advies van MauRice2 maar ten dele.  Ik kwam weliswaar in de bedoelde modus terecht maar de opdracht "apt-get install nvidia-current"  werd niet herkend.  Toen in die sfeer maar wat verder gesnuffeld en op een gegeven moment werd er van alles geüpdate en bijgevoegd.  Na herstarten was er beeld, weliswaar pover (1024 x 768)  maar ja, ik zie iets.  Ga nu proberen de zaak helemaal naar wens te krijgen.

Jan

Offline Henkp

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #8 Gepost op: 2014/08/29, 16:46:00 »
Pffff, ik heb beeld.  Helaas werkte het laatste advies van MauRice2 maar ten dele.  Ik kwam weliswaar in de bedoelde modus terecht maar de opdracht "apt-get install nvidia-current"  werd niet herkend.  Toen in die sfeer maar wat verder gesnuffeld en op een gegeven moment werd er van alles geüpdate en bijgevoegd.  Na herstarten was er beeld, weliswaar pover (1024 x 768)  maar ja, ik zie iets.  Ga nu proberen de zaak helemaal naar wens te krijgen.

Jan

Je had er ook zo moeten uitvoeren  sudo apt-get install nvidia-current

Offline Jan_Kol

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #9 Gepost op: 2014/08/29, 20:00:04 »
Ga nu proberen de zaak helemaal naar wens te krijgen.
De eerste keer ging het mis maar de tweede keer is alles gelukt.  Misschien een omweg, maar ja, het resultaat geldt.

Ik ben dus toen ik dat  1024 x 768 beeld had naar "Systeeminstellingen" > Software en Updates gegaan en koos voor "Extra stuurprogramma's".  Daar heb ik eerst de voorgestelde "X.Org X server -Nouveau driver van xserver-xorg-nouveau gebruiken (open-bron)" geprobeerd en dat had geen resultaat.  Toen weer gezorgd dat ik in dat 1024 x 768 scherm kwam en gekozen voor "NVIDIA legacy binairy driver - version 304.117 van nvidia-3014 gebruiken (niet-vrij, getest)" en ja daar was het scherm in optimale (1.440 x 800) staat na herstart van de computer.

Overigens viel mij op dat echt herstarten niet lukte.  Ik moest de computer, na het tevoorschijn toveren van de beeldoptie 1024  x 768 met de hand herstarten want het geval bleef wel "hangen":



Kortom: probleem opgelost... op naar het volgende (zal vast wel komen want ik ben nog niet zo bedreven met Ubuntu als met Windows).

Jan

Nu, eindelijk, direct vanaf HP-Ubuntu laptop:  Foutje gemaakt met 1440 x 800 want op de  staat het op 1.280 x 800;  onder Windows was het 1.440 x 800.
« Laatst bewerkt op: 2014/08/29, 20:18:48 door Jan_Kol »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Zwart beelscherm na installatie
« Reactie #10 Gepost op: 2014/08/29, 20:18:17 »
Jan,

Fijn te lezen dat het is gelukt.
Eens je een grafische omgeving heb, ook al is deze niet optimaal  ...
Is het eenvoudiger om via de "Extra stuurprogramma's" de nVidia Proprietary driver te installereen dan via een text opdracht.
MvG,
MauRice
Registered Linux user: 473556