Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Disable alle shortcut's met dconf-editor  (gelezen 328 keer)

Offline gijsvo

  • Lid
Disable alle shortcut's met dconf-editor
« Gepost op: 2014/08/21, 15:04:25 »
Beste,

ik ben een deb pakket aan het bouwen dat het na installatie mogelijk maakt in te loggen op een nieuw gebruikersaccount. In dit account wordt bij logon meteen de browser gestart en deze navigeert direct naar een bij de installatie ingestelde website. De bedoeling is dat deze browser nu alleen gesloten kan worden met een door bij de installatie gespecificeerde shortkey (combinatie van ALT + letter). Hiervoor moet ik natuurlijk alle andere zoals ALT+F4 disablen, maar ook degene om naar het bureaublad te gaan, etc..

Het disable script wordt gerunt bij logon en hierin probeer ik de keys te disablen met dit commando:
gsettings set org.gnome.desktop.wm.keybindings begin-resize []
gsettings set org.gnome.desktop.wm.keybindings begin-move []

Zo dus voor elke mogelijk shortcut een.

De close bind vul ik op op deze manier:
gsettings set org.gnome.desktop.wm.keybindings close ['<ALT>b']
Ik had bij installatie de b gekozen.

Nu log ik aan met het nieuwe account en de browser start op naar de juiste website, maar de ALT-F4 shortcut werkt nog steeds, maar mijn gepersonaliseerde niet.
Ookal open ik de dconf-editor en lijken alle shortcut binds leeg te zijn zoals u hier ziet


Ik heb het web al afgezocht naar oplossing maar lijk er geen te vinden.
Hopelijk kan iemand van jullie me helpen

Mvg