Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Standaard (sans) fonts in Mozilla slecht  (gelezen 330 keer)

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Standaard (sans) fonts in Mozilla slecht
« Gepost op: 2014/08/12, 10:37:45 »
Om het programma Digikam er wat meer uit te laten zien binnen mijn Ubuntu omgeving (Linux Mint) had ik KDE Systemsettings geïnstalleerd en daar wat mee gespeeld. Uiteindelijk weer gedeïnstalleerd en nu zien bij mij de standaard fonts er in Firefox en Mozilla zo uit:
http://i.imgur.com/s8H6NY4.jpg

Ik heb al vanalles geprobeerd via de preferences in Mint en Firefox about:config, maar ik krijg het niet meer goed. En voor mij als webdesigner is dat even niet waar ik op zit te wachten ;).

Iemand dit al meegemaakt en hoe los ik dit op?
JackTummers.nl

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #1 Gepost op: 2014/08/12, 11:36:45 »
En dat kun je met (een aantal keren) [Ctrl] + [ + ] ook niet weer goed krijgen?
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #2 Gepost op: 2014/08/12, 11:39:28 »
Maar Firefox is geen KDE-programma dus die neemt niet de instellingen van je KDE-systeeminstellingen over...

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #3 Gepost op: 2014/08/12, 11:42:51 »
Nee, niet echt. Het lijkt wel alsof de hinting niet goed is of het standaard font niet gevonden wordt:: http://i.imgur.com/JZVWX1b.jpg

Ter vergelijking hoe bijvoorbeeld LibreOffice oogt: http://i.imgur.com/cw5ZdRi.jpg

En kijk ik bijvoorbeeld naar een van mijn eigen sites, dan worden daarin wel de fonts goed weergegeven als die expliciet in de stylesheet zijn opgenomen, maar het lijkt wel alsof de standaard fonts dit niet doen: http://i.imgur.com/8uWVtON.jpg
« Laatst bewerkt op: 2014/08/12, 11:46:27 door moxie »
JackTummers.nl

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #4 Gepost op: 2014/08/12, 11:44:34 »
@Vistaus: Nee, dat weet ik. Ik heb in Firefox niks willen veranderen, het is juist dat na het verwijderen van KDE System Settings fonts in Firefox niet meer goed worden weergegeven.
JackTummers.nl

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #5 Gepost op: 2014/08/13, 09:44:28 »
Ik zie dat ik per ongeluk twee dezelfde schermafbeeldingen had geplaatst. Hopelijk geven deze twee wel een beeld van hoe het er uitziet:

http://i.imgur.com/jaT8kSd.jpg

http://imgur.com/TRinf52

Ik ga weer eens verder kijken, maar ik heb de oplossing helaas nog niet gevonden.
JackTummers.nl

Offline BenMedia

  • Lid
    • Ben-Media
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #6 Gepost op: 2014/08/13, 10:05:28 »
Dit zijn bij mij de instellingen in Firefox.
Leverancier Ubuntu, Xubuntu, Lubuntu en Mint PC's

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #7 Gepost op: 2014/08/13, 10:11:25 »
Ik heb exact dezelfde instellingen :(
JackTummers.nl

Offline BenMedia

  • Lid
    • Ben-Media
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #8 Gepost op: 2014/08/13, 10:35:15 »
Ik heb exact dezelfde instellingen :(

Heel vreemd.
Soms is een nieuwe installatie sneller klaar dan eindeloos zoeken.......
« Laatst bewerkt op: 2014/08/13, 10:40:04 door BenMedia »
Leverancier Ubuntu, Xubuntu, Lubuntu en Mint PC's

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #9 Gepost op: 2014/08/13, 11:18:05 »
Helaas, dat werkt ook niet.
JackTummers.nl

Offline BenMedia

  • Lid
    • Ben-Media
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #10 Gepost op: 2014/08/13, 11:34:21 »
Of FF opnieuw installeren. Dus de map met de punt er voor (in de verborgen mappen dus) weghalen en dan daarna opnieuw opstarten.
Dan zijn namelijk alle instellingen weg.
Je kan het proberen, aangezien het toch FF betreft en niet je systeem.

Op zich heb je gelijk Femke, maar waarschijnlijk zit het dieper in het systeem want zijn instellingen in FF staan goed. Vandaar mijn voorstel voor een nieuwe installatie.
Leverancier Ubuntu, Xubuntu, Lubuntu en Mint PC's

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #11 Gepost op: 2014/08/13, 11:58:43 »
Tenzij iemand nog met een briljant idee komt zit er inderdaad niks anders op dan een niieuwe installatie te plaatsen. En in het vervolg niet te veel klooien met KDE systeeminstellingen in een Cinnamon omgeving.
JackTummers.nl

Offline BenMedia

  • Lid
    • Ben-Media
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #12 Gepost op: 2014/08/13, 12:02:21 »
Met klooien is niets mis, is juist heel leerzaam maar dan op een systeem wat niet belangrijk is (oude pc of wat ik vaak doe, op een andere oude schijf) Op een werk/zakelijke pc beter niet experimenteren.
Leverancier Ubuntu, Xubuntu, Lubuntu en Mint PC's

Offline Ed

  • Lid
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #13 Gepost op: 2014/08/13, 16:31:08 »
Misschien een ander thema proberen.

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #14 Gepost op: 2014/08/13, 18:06:01 »
Werkt ook niet :(. Het moet in Mozilla zitten, want alleen Thunderbird en Firefox hebben er last van, de rest is ok.
Het vreemde is alleen dat ik daar niks aan het zitten doen. Ik heb alleen wat gespeeld met de kleuren in de KDE Systemsettings en daarna dit programma'tje weer verwijderd.
JackTummers.nl

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #15 Gepost op: 2014/08/13, 18:19:07 »
Pak een willekeurige \Windows\Fonts map, kopieer de inhoud naar
~/.fonts
(restart PC? ) en test.

https://wiki.ubuntu.com/Fonts
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Ed

  • Lid
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #16 Gepost op: 2014/08/13, 19:09:43 »
Misschien zijn er restanten van het kde programma achtergebleven.

In de terminal,

sudo apt-get autoremove 

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Re: Standaard (sans) fonts in Mozilla slecht
« Reactie #17 Gepost op: 2014/08/13, 19:47:15 »
Het lijkt erop dat het weer goed is. Maar hoe?....

Ik had die Windows fonts map gekopieerd, maar dat hielp niks. Daarna die KDE Systemsettings weer geïnstalleerd, alles op default gezet, opgeslagen en het programma weer gedeïnstaleerd. Dat leek ook niet te helpen. Daarna nog een keer de .fontconfig map leeggegooid (wat ik dus al een keer gedaan had), en de fonts zagen er toen verschrikkelijk uit, ook die van het systeem. Toen maar weer eens een herstart gedaan en toen was het goed. Het lijkt dus dat er inderdaad nog wat KDE spul was achtergebleven, en ik heb daarom die autoremove er nog maar overheen gedaan.

Het heeft even wat tijd gekost, maar dan heb je ook wat (???).

Bedankt iedereen voor het meedenken en de suggesties!
JackTummers.nl