Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: drivers tv out ati mobile 7500  (gelezen 722 keer)

Mhijink

  • Gast
drivers tv out ati mobile 7500
« Gepost op: 2007/03/22, 18:27:59 »
Hallo,

ik heb de volgende website gevonden die gouden bergen belooft:
http://megahurts.dk/rune/tv_output.html
maar de beknopte handleiding lager op de pagina snap ik niet helemaal
waar ik vastloop is bij het compilen (nog nooit bewust gedaan)
Waar slaat XORG_PREFIX op? moet ik dit vervangen door een locatie?
en een regel lager XORG_CONFIG
hier raak ik het spoor dus bijster.

wie wil me helpen met het laatste stukje
(ik heb sinds gisteren linux voor m'n neus en ik ben aangenaam verrast door wat ubuntu tot nu toe presteert! zelfs m'n webcam met een beetje zoeken aan de praat gekregen, al is het beeld in msn nog niet goed, maar dat komt nog wel.
skype werkt en last.fm ook, divx afspelen van m'n windows xp bak gaat ook goed. tot nu toe ben ik erg onder de indruk (:

de handleiding staat hieronder

Martijn


De korte handleiding is alvolgt:
# Most modern systems use the Xorg 7.0 as default.
# If so you will only need to patch and compile the ati driver.
# Grab a driver release from http://xorg.freedesktop.org/releases/individual/driver/ :
wget http://xorg.freedesktop.org/releases/.../driver/xf86-video-ati-6.5.8.0.tar.bz2

# Grab a matching patch from http://megahurts.dk/rune/tv_output.html :
wget http://megahurts.dk/rune/stuff/xorg7-6.5.8.0-tv_output.patch.gz

# Extract, patch:

tar xjvf xf86-video-ati-6.5.8.0.tar.bz2
gunzip -c xorg7-6.5.8.0-tv_output.patch.gz | \
  patch -p1 -d xf86-video-ati-6.5.8.0

# Compile:
# make sure you have installed the xorg
# and x11 proto development packages for your distribution
export XORG_PREFIX="/usr" (XORG_PREFIX/bin is where Xorg is located)
export XORG_CONFIG="--prefix=$XORG_PREFIX --sysconfdir=/etc --localstatedir=/var"
./configure $XORG_CONFIG --with-xorg-module-dir=$XORG_PREFIX/lib/X11/modules
make

# Install:
make install

# Edit your /etc/X11/xorg.conf according to
# ./xf86-video-ati-6.5.8.0/src/README.out :
# * Set the resolution to 800x600
# * In the "Device" section, add:
    Option "MonitorLayout" "AUTO, NONE"
    Option "TVOutput"      "PAL"       (or "NTSC", etc.)

# Start X and rejoice.
Xorg

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
drivers tv out ati mobile 7500
« Reactie #1 Gepost op: 2007/03/23, 16:24:07 »
Je moet dat XORG_PREFIX etc. wel zo intypen zoals het er staat, maar wat er achter de laatste " staat niet. Ze willen juist dat je tussen de aanhalingstekens de juiste waarde invult:

Zoek eerst uit waar de X executable staat: locate X
Dat is zoiets als /usr/X11R6/bin

Wat je in werkelijkheid doet is een "variabele" definieren die later weer gebruikt wordt om een andere, XORG_CONFIG, te maken.

Ik hoop dat je hiermee voldoende weet om 't aan de praat te krijgen!
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Mhijink

  • Gast
drivers tv out ati mobile 7500
« Reactie #2 Gepost op: 2007/03/26, 17:29:50 »
Hallo tukcedo,

dank je wel voor je reply!
ik begrijp helaas nog niet helemaal wat ik doe, dus misschien wil je nog even de stappen verder uitleggen.

Wat ik nu gedaan heb is als volgt
het maken van het gepatchte bestand xf86-video-ati-6.6.3 (dat was niet echt moeilijk)
maar dan voer ik in

export XORG_PREFIX="/usr"
(dit gaat denk ik ook goed, er wordt dus een variabele gedefinieerd)

export XORG_CONFIG="--prefix=$XORG_PREFIX --sysconfdir=/etc --localstatedir=/var"
(dit snap ik niet, maar goed ik krijg de prompt weer.)

./configure $XORG_CONFIG --with-xorg-module-dir=$XORG_PREFIX/lib/X11/modules
en dan krijg ik:
bash: ./configure: No such file or directory
dus blijkbaar gaat er nog iets niet goed met de variabele XORG_CONFIG of XORG_PREFIX..... maar wat moet het dan wel zijn.

ik zoek even naar de map X11 en vind zowaar 9 locaties!
dus welke moet ik hoe waar in vullen (:
/etc, /var/lib, /usr/bin, /usr/include, /usr/lib, /usr/share, /usr/share/xman en /usr/share/fondts.....

meer hulp is dus erg welkom.
verder vraag ik mij af of dit patchen niet om zeep wordt geholpen als er een update van X11 komt... maar goed, dan patch ik die ook wel weer.

alvast bedankt!
Martijn

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
drivers tv out ati mobile 7500
« Reactie #3 Gepost op: 2007/03/27, 16:49:27 »
He Martijn,

Zo te zien gaan de definities van de variabelen goed. Die 2e definitie gebruikt trouwens de eerste weer om een nieuwe te maken. Als je 't echt wilt begrijpen moet je ze even "uitschrijven". Dus in dit geval vul je wat je had opgegeven voor XORG_PREFIX in. Maar goed, dit terzijde.

Het probleem is nu dat er blijkbaar geen (executable) script is in de directory waar je zit dat "configure" heet. Dat "./" betekent namelijk: in DEZE directory (in tegenstelling tot het zoeken naar iets van die naam in je $PATH variabele).

Ik vermoed dat je dus niet ge-CD hebt naar de directory waar de software in staat. Doe in de directory waar je denkt dat je moet zijn even "ls" en dan zou je 'm moeten zien. Zo niet dan zit je verkeerd.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl