Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 14.04 LTS gebruikt oude kernel- en grubversie: hoe updaten?  (gelezen 299 keer)

Offline RumaNoV

  • Lid
Hallo,

Ik draai reeds een aantal jaren een headless Ubuntu Server. Onlangs heb ik de upgrade uitgevoerd naar versie 14.04, die op het eerste zicht normaal was verlopen. Nu ben ik op het volgende probleem gestoten:

Er wordt een oude versie van de kernel (3.2.0-26-generic x86_64) en grub (versie 0.97) gebruikt. Het bootscherm van grub toont ook Ubuntu 12.04 bij het booten, maar bij het afsluiten van het systeem krijg ik dan weer een scherm met versie 14.04.

Mijn probleem is gelijkaardig aan het probleem in dit topic. Daar lost men het probleem op door hetvolgende te doen:

Citaat
I opened Synaptic from the applications menu's System category, typed "grub2" without the quotes into the search box, and selected it for installation. The program told me several other packages were required; I told it to mark them too. I then clicked the "Apply" icon at top center of the Synaptic window, and the system chugged away. It asked me where I wanted the boot data placed and I selected /dev/sda from the list it offered, clicked forward, and it continued. When I rebooted after it finished, I had a Grub2 menu in place of the old legacy grub one, and the /etc/default/grub file in place with default settings.

Aangezien ik geen GUI gebruik, kan ik dus Synaptic niet gebruiken... Ikzelf ken praktisch niets van linux, dus weet niet hoe er aan te beginnen. Heb al enkele uren zitten zoeken, doch zonder echt resultaat :( Alle hulp welkom.

Offline RumaNoV

  • Lid
Re: Ubuntu 14.04 LTS gebruikt oude kernel- en grubversie: hoe updaten?
« Reactie #1 Gepost op: 2014/07/06, 22:57:43 »
Probleem opgelost: even een GUI geïnstalleerd en dan met synaptic grub2 geïnstalleerd zoals hierboven aangegeven in het citaat.