Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nieuwe pip, oude versies?  (gelezen 738 keer)

Offline MKe

  • Lid
nieuwe pip, oude versies?
« Gepost op: 2014/07/01, 14:35:46 »
Hoi,

Ik heb pip geupgraded naar de nieuwe versie 1.5.6. Als ik dan pydot installeer is de laatste versie die ik kan installeren versie 1.0.2. Maar ik heb 1.0.28 nodig. Als ik dan downgrade met pip install -U pip==1.3.1 kan ik met deze oude versie wel pydot 1.0.28 installeren. Is dit normaal? Kan iemand mij uitleggen waarom dit gebeurt? Dit is trouwens nog op Ubuntu 12.0.4 met virtualenv.

Re: nieuwe pip, oude versies?
« Reactie #1 Gepost op: 2014/07/01, 20:48:34 »
In principe pakt PIP (ongeacht de versie van PIP) altijd de nieuwste versie van een component, dat is gewoon standaard zo ingebouwd.

Offline MKe

  • Lid
Re: nieuwe pip, oude versies?
« Reactie #2 Gepost op: 2014/07/01, 21:47:04 »
In principe pakt PIP (ongeacht de versie van PIP) altijd de nieuwste versie van een component, dat is gewoon standaard zo ingebouwd.
klopt, maar in dit geval dus niet. Pip1.5.6 installeerd pydot1.0.2 en niet pydot1.0.28. Ik kan dat zelfs niet forceren. Hij ziet de laatste versie niet eens. Pip1.3.1 dus wel. Waarom dat verschil?