Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: GRUB - time-out functioneert niet meer  (gelezen 292 keer)

Offline BartenB

  • Lid
  • Steunpunt: Nee
GRUB - time-out functioneert niet meer
« Gepost op: 2014/06/28, 14:27:53 »
Hallo allemaal
Ik ben hier bezig voor een vriend die het eindelijk ook eens wil proberen met LINUX.
Met de installatie van Xubuntu 12.04 LTS  op een oudere Fujitsi Siemens “ESPRIMO” met Intel(R) Pentium(R) 4 CPU 3.00GHz en 2GB RAM geen probleem.
De harddisk heb ik opgesplitst in 3 primaire partities
sda1 in NTFS waar WinXP steeds op heeft gestaan en nu nog staat :O
sda 2 in EXT4 wat de Linux partitie geworden is en waar ik dus de Xubuntu 12.04 LTS op installeerde
sda 3 in NTFS waar de data op terecht komen (documenten, muziek, foto's) die ik dus wil benaderen van zowel windows Xp als vanuit
Xubuntu.
en dan uiteraard nog de SWAP-partitie
Installatie verliep wel lekker, ...

MAAR de time-out ingesteld in de GRUB laat het afweten! Hoewel deze juist na de installatie wel heeft gewerkt. :-X
Ttz de time-out stond aanvankelijk op 10... dus na 10 sec liep het opstarten verder naar de Xubuntu-versie, die op de eerste rij in de GRUB stond vermeld, zoals het eigenlijk hoort zeg maar.
Daarna heb ik wat aanpassingen in de GRUB gedaan, volgens de tips die ik kon terugvinden op de website van Pjotr (waarvoor mijn dank Pjotr met de meer dan waardevolle info voor elke linuxgebruiker)
Ik heb de GRUB wat aangepast: Time-out verminderd naar 5 sec, resolutie wat aangepast naar 800x600 en een leuke achtergrondafbeelding....
allemaal met het vereiste/gewenste effect (resolutie en afbeelding zijn OK) , BEHALVE dat de time-out dus helemaal niet meer functioneert:
De opstartprocedure gaat niet automatisch verder met het laden van Xubuntu wanneer er door de gebruiker geen handeling gebeurt.... terwijl deze na 5 sec automatisch zou moeten verder gaan met Xubuntu, hier in dat geval dan toch.
Voor de rest loopt het allemaal gesmeerd, maar ik vind die time-out functie best handig en wil deze dus wel blijven gebruiken... Iemand enig idee?
Btw het herstellen van de GRUB met de originele DVD (in mijn geval Xubuntu 12.04 LTS), zoals omschreven op de site van Pjotr, bracht ook geen soelaas :-(

Hierna de inhoud van de GRUB.CFG

Citaat
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=800x600

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: GRUB - time-out functioneert niet meer
« Reactie #1 Gepost op: 2014/06/29, 11:33:25 »
Het is trouwens niet het bestand /boot/grub/grub.cfg wat je toonde (a.u.b. niet handmatig aanpassen), maar het bestand /etc/default/grub (dat "mag", als sudo, wel handmatig  aangepast worden).
Had je na de aanpassingen gedaan wat er boven in de 1e regel staat?
Citaat
# If you change this file, run 'update-grub' afterwards to update
... in de terminal:
sudo update-grub
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline BartenB

  • Lid
  • Steunpunt: Nee
Re: GRUB - time-out functioneert niet meer
« Reactie #2 Gepost op: 2014/06/29, 11:44:03 »
ja hoor,
sudo update-grub werd ook uitgevoerd
maar mocht geen effect hebben l :|

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: GRUB - time-out functioneert niet meer
« Reactie #3 Gepost op: 2014/06/29, 12:32:35 »
Zou wel eens een fout kunnen zijn in Grub.... Eentje die mogelijk is opgeroepen door de wijzigingen die je in Grub hebt aangebracht.

In dat geval zit er weinig anders op dan de fout te melden op Launchpad, en te wachten op de verlossende update.

Offline daniel

  • Lid
  • Steunpunt: Nee
Re: GRUB - time-out functioneert niet meer
« Reactie #4 Gepost op: 2014/07/10, 10:04:36 »
en van hieruit veranderen:

sudo gedit /etc/default/grub
ipv  /boot/grub/grub.cfg
Misschien dat dit werkt